Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-11-10

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
telnet 23 tcp Telnet Jon Postel Jon Postel RFC 854 Defined TXT keys: u=<username> p=<password>
telnet 23 udp Telnet Jon Postel Jon Postel RFC 854 Defined TXT keys: u=<username> p=<password>
dlep 854 tcp Dynamic Link Exchange Protocol (DLEP) IESG IETF Chair 2017-04-03 RFC 8175
dlep 854 udp Dynamic Link Exchange Protocol (DLEP) IESG IETF Chair 2017-04-03 RFC 8175
owamp-test 861 udp OWAMP-Test IESG IETF Chair 2018-12-21 RFC 8545
twamp-test 862 udp TWAMP-Test Receiver Port IESG IETF Chair 2018-12-21 RFC 8545
buddy-draw 1854 tcp Buddy Draw Marvin Shin Marvin Shin
buddy-draw 1854 udp Buddy Draw Marvin Shin Marvin Shin
infomover 2854 tcp InfoMover Carla Caputo Carla Caputo
infomover 2854 udp InfoMover Carla Caputo Carla Caputo
stryker-com 3854 tcp Stryker Comm Port Andrew Schultz Andrew Schultz 2003-08
stryker-com 3854 udp Stryker Comm Port Andrew Schultz Andrew Schultz 2003-08
40854-41110 Unassigned

Contact Information

Name Organization Contact URI Last Updated
Andrew Schultz aschultz&strykercom.com 2003-08
Carla Caputo caputo&emc.com
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Jon Postel postel&isi.edu
Marvin Shin president&medialingo.com