Service Name and Transport Protocol Port Number Registry

Last Updated
2026-10-09
Expert(s)
TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell,
and Michael Scharf
SCTP: Michael Tuexen
DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
[RFC 6335]
Note
Service names and port numbers are used to distinguish between different
services that run over transport protocols such as TCP, UDP, DCCP, and
SCTP.

Service names are assigned on a first-come, first-served process, as
documented in [RFC 6335].

Port numbers are assigned in various ways, based on three ranges: System
Ports (0-1023), User Ports (1024-49151), and the Dynamic and/or Private
Ports (49152-65535); the different uses of these ranges are described in
[RFC 6335]. According to Section 8.1.2 of [RFC 6335], System Ports are 
assigned by the "IETF Review" or "IESG Approval" procedures described in 
[RFC 8126]. User Ports are assigned by IANA using the "IETF Review" process, 
the "IESG Approval" process, or the "Expert Review" process, as per 
[RFC 6335]. Dynamic Ports are not assigned.

The registration procedures for service names and port numbers are
described in [RFC 6335].

Assigned ports both System and User ports SHOULD NOT be used without
or prior to IANA registration.

************************************************************************
* PLEASE NOTE THE FOLLOWING:                                           *
*                                                                      *
* ASSIGNMENT OF A PORT NUMBER DOES NOT IN ANY WAY IMPLY AN             *
* ENDORSEMENT OF AN APPLICATION OR PRODUCT, AND THE FACT THAT NETWORK  *
* TRAFFIC IS FLOWING TO OR FROM A REGISTERED PORT DOES NOT MEAN THAT   *
* IT IS "GOOD" TRAFFIC, NOR THAT IT NECESSARILY CORRESPONDS TO THE     *
* ASSIGNED SERVICE. FIREWALL AND SYSTEM ADMINISTRATORS SHOULD          *
* CHOOSE HOW TO CONFIGURE THEIR SYSTEMS BASED ON THEIR KNOWLEDGE OF    *
* THE TRAFFIC IN QUESTION, NOT WHETHER THERE IS A PORT NUMBER          *
* REGISTERED OR NOT.                                                   *
************************************************************************

Request an Assignment
  [https://www.iana.org/protocols/apply]

Available Formats

CSV

XML

HTML

TXT
Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
tacacss 300 tcp TLS Secure Login Host Protocol (TACACSS) [IESG] [IETF_Chair] 2025-07-15 [RFC 9887]
iclcnet-svinfo 887 tcp ICL coNETion server info

IANA assigned this well-formed service name as a replacement for "iclcnet_svinfo".
[Bob_Lyon] [Bob_Lyon]
iclcnet_svinfo 887 tcp ICL coNETion server info [Bob_Lyon] [Bob_Lyon] This entry is an alias to "iclcnet-svinfo". This entry is now historic, not usable for use with many common service discovery mechanisms.
iclcnet-svinfo 887 udp ICL coNETion server info

IANA assigned this well-formed service name as a replacement for "iclcnet_svinfo".
[Bob_Lyon] [Bob_Lyon]
iclcnet_svinfo 887 udp ICL coNETion server info [Bob_Lyon] [Bob_Lyon] This entry is an alias to "iclcnet-svinfo". This entry is now historic, not usable for use with many common service discovery mechanisms.
mtqp 1038 tcp Message Tracking Query Protocol [RFC 3887]
mtqp 1038 udp Message Tracking Query Protocol [RFC 3887]
filex-lport 1887 tcp FileX Listening Port [Megan_Woods] [Megan_Woods]
filex-lport 1887 udp FileX Listening Port [Megan_Woods] [Megan_Woods]
aironetddp 2887 tcp aironet [Victor_Griswold] [Victor_Griswold]
aironetddp 2887 udp aironet [Victor_Griswold] [Victor_Griswold]
ciphire-data 3887 tcp Ciphire Data Transport [Lars_Eilebrecht] [Lars_Eilebrecht] 2003-10
ciphire-data 3887 udp Ciphire Data Transport [Lars_Eilebrecht] [Lars_Eilebrecht] 2003-10
4886-4887 Unassigned
pcp-multicast 5350 udp Port Control Protocol Multicast [IESG] [IETF_Chair] [RFC 6887]
pcp 5351 udp Port Control Protocol [IESG] [IETF_Chair] [RFC 6887]
6869-6887 Unassigned
ubroker 7887 tcp Universal Broker [Nathan_Hammond] [Nathan_Hammond] 2005-10
ubroker 7887 udp Universal Broker [Nathan_Hammond] [Nathan_Hammond] 2005-10
8810-8872 Unassigned
dxspider 8873 tcp dxspider linking protocol [Dirk_Koopman] [Dirk_Koopman] 2005-08
dxspider 8873 udp dxspider linking protocol [Dirk_Koopman] [Dirk_Koopman] 2005-08
8874-8879 Unassigned
8884-8887 Unassigned
9879-9887 Unassigned
18882-18887 Unassigned
44323 udp Unassigned "pcp" assignment withdrawn, moved to port 5351 per RFC6887

Contact Information

ID Name Organization Contact URI Last Updated
[Bob_Lyon] Bob Lyon mailto:bl&oasis.icl.co.uk
[Dirk_Koopman] Dirk Koopman mailto:djk&tobit.co.uk 2005-08
[IESG] IESG mailto:iesg&ietf.org
[IETF_Chair] IETF Chair IETF mailto:chair&ietf.org
[Lars_Eilebrecht] Lars Eilebrecht mailto:le+iana&leogic.com 2003-10
[Megan_Woods] Megan Woods mailto:megan.woods&woods-gebler.com 2024-08-29
[Nathan_Hammond] Nathan Hammond mailto:nathan.hammond&stonebranch.com 2005-10
[Victor_Griswold] Victor Griswold mailto:vgris&aironet.com