Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
dnsix 90 tcp DNSIX Securit Attribute Token Map Charles Watt Charles Watt PORT 90 also being used unofficially by Pointcast
dnsix 90 udp DNSIX Securit Attribute Token Map Charles Watt Charles Watt PORT 90 also being used unofficially by Pointcast
ntp 123 tcp Network Time Protocol Dave Mills Dave Mills RFC 5905
ntp 123 udp Network Time Protocol Dave Mills Dave Mills RFC 5905
imap 143 tcp Internet Message Access Protocol IESG IETF Chair 2021-02-22 RFC 3501; RFC 9051
143 udp Reserved 2021-02-22 RFC 9051
gacp 190 tcp Gateway Access Control Protocol C. Philip Wood C. Philip Wood
gacp 190 udp Gateway Access Control Protocol C. Philip Wood C. Philip Wood
uis 390 tcp UIS Ed Barron Ed Barron
uis 390 udp UIS Ed Barron Ed Barron
micom-pfs 490 tcp micom-pfs David Misunas David Misunas
micom-pfs 490 udp micom-pfs David Misunas David Misunas
tns-cml 590 tcp TNS CML Jerome Albin Jerome Albin
tns-cml 590 udp TNS CML Jerome Albin Jerome Albin
vatp 690 tcp Velneo Application Transfer Protocol Velneo David Gutiérrez 2015-02-03
vatp 690 udp Velneo Application Transfer Protocol Velneo David Gutiérrez 2015-02-03
831 tcp Reserved 2025-09-29 Previously assigned to NETCONF over BEEP but released by RFC 9900
831 udp Reserved 2025-09-29 Previously assigned to NETCONF over BEEP but released by RFC 9900
832 tcp Reserved 2025-09-29 Previously assigned to NETCONF over SOAP but released by RFC 9900
832 udp Reserved 2025-09-29 Previously assigned to NETCONF over SOAP but released by RFC 9900
833 tcp Reserved 2025-09-29 Previously assigned to NETCONF over SOAP but released by RFC 9900
833 udp Reserved 2025-09-29 Previously assigned to NETCONF over SOAP but released by RFC 9900
omginitialrefs 900 tcp OMG Initial Refs Christian Callsen Christian Callsen
omginitialrefs 900 udp OMG Initial Refs Christian Callsen Christian Callsen
smpnameres 901 tcp SMPNAMERES Leif Ekblad Leif Ekblad
smpnameres 901 udp SMPNAMERES Leif Ekblad Leif Ekblad
ideafarm-door 902 tcp self documenting Telnet Door
ideafarm-door 902 udp self documenting Door: send 0x00 for info
ideafarm-panic 903 tcp self documenting Telnet Panic Door Wo'o Ideafarm Wo'o Ideafarm
ideafarm-panic 903 udp self documenting Panic Door: send 0x00 for info Wo'o Ideafarm Wo'o Ideafarm
904-909 Unassigned
ftps 990 tcp ftp protocol, control, over TLS/SSL Christopher Allen Christopher Allen
ftps 990 udp ftp protocol, control, over TLS/SSL Christopher Allen Christopher Allen
imaps 993 tcp IMAP over TLS protocol IESG IETF Chair 2021-02-22 RFC 3501; RFC 8314; RFC 9051
993 udp Reserved 2021-02-22 RFC 9051
ff-fms 1090 tcp FF Fieldbus Message Specification
ff-fms 1090 udp FF Fieldbus Message Specification
commlinx-avl 1190 tcp CommLinx GPS / AVL System Peter Johnson Peter Johnson 2004-11
commlinx-avl 1190 udp CommLinx GPS / AVL System Peter Johnson Peter Johnson 2004-11
tsdos390 1237 tcp tsdos390 Ben Pracht Ben Pracht
tsdos390 1237 udp tsdos390 Ben Pracht Ben Pracht
winjaserver 1290 tcp WinJaServer
winjaserver 1290 udp WinJaServer
iclpv-sc 1390 tcp Storage Controller
iclpv-sc 1390 udp Storage Controller
insitu-conf 1490 tcp insitu-conf Paul Blacknell Paul Blacknell
insitu-conf 1490 udp insitu-conf Paul Blacknell Paul Blacknell
gemini-lm 1590 tcp gemini-lm Tony Sawyer Tony Sawyer
gemini-lm 1590 udp gemini-lm Tony Sawyer Tony Sawyer
ng-umds 1690 tcp ng-umds Louis E. Simard Louis E. Simard
ng-umds 1690 udp ng-umds Louis E. Simard Louis E. Simard
nmsp 1790 tcp Narrative Media Streaming Protocol Paul Santinelli Jr. Paul Santinelli Jr.
nmsp 1790 udp Narrative Media Streaming Protocol Paul Santinelli Jr. Paul Santinelli Jr.
wilkenlistener 1890 tcp wilkenListener Wilken GmbH Wilken GmbH
wilkenlistener 1890 udp wilkenListener Wilken GmbH Wilken GmbH
ssdp 1900 tcp SSDP UPnP Forum UPnP Forum
ssdp 1900 udp SSDP UPnP Forum UPnP Forum
fjicl-tep-a 1901 tcp Fujitsu ICL Terminal Emulator Program A Bob Lyon Bob Lyon
fjicl-tep-a 1901 udp Fujitsu ICL Terminal Emulator Program A Bob Lyon Bob Lyon
fjicl-tep-b 1902 tcp Fujitsu ICL Terminal Emulator Program B Bob Lyon Bob Lyon
fjicl-tep-b 1902 udp Fujitsu ICL Terminal Emulator Program B Bob Lyon Bob Lyon
linkname 1903 tcp Local Link Name Resolution Dan Harrington Dan Harrington
linkname 1903 udp Local Link Name Resolution Dan Harrington Dan Harrington
fjicl-tep-c 1904 tcp Fujitsu ICL Terminal Emulator Program C Bob Lyon Bob Lyon
fjicl-tep-c 1904 udp Fujitsu ICL Terminal Emulator Program C Bob Lyon Bob Lyon
sugp 1905 tcp Secure UP.Link Gateway Protocol Peter King Peter King
sugp 1905 udp Secure UP.Link Gateway Protocol Peter King Peter King
tpmd 1906 tcp TPortMapperReq Sheila Devins Sheila Devins
tpmd 1906 udp TPortMapperReq Sheila Devins Sheila Devins
intrastar 1907 tcp IntraSTAR Peter Schoenberger Peter Schoenberger
intrastar 1907 udp IntraSTAR Peter Schoenberger Peter Schoenberger
dawn 1908 tcp Dawn Michael Crawford Michael Crawford
dawn 1908 udp Dawn Michael Crawford Michael Crawford
global-wlink 1909 tcp Global World Link Nicholas Davies Nicholas Davies
global-wlink 1909 udp Global World Link Nicholas Davies Nicholas Davies
stun-p1 1990 tcp cisco STUN Priority 1 port
stun-p1 1990 udp cisco STUN Priority 1 port
lrp 2090 tcp Load Report Protocol Amir Peless Amir Peless
lrp 2090 udp Load Report Protocol Amir Peless Amir Peless
tivoconnect 2190 tcp TiVoConnect Beacon Jeffrey J. Peters Jeffrey J. Peters 2002-08
tivoconnect 2190 udp TiVoConnect Beacon Jeffrey J. Peters Jeffrey J. Peters 2002-08
sonus-logging 2290 tcp Sonus Logging Services Adwait Sathe Adwait Sathe 2005-08
sonus-logging 2290 udp Sonus Logging Services Adwait Sathe Adwait Sathe 2005-08
rsmtp 2390 tcp RSMTP Geoff Collyer Geoff Collyer
rsmtp 2390 udp RSMTP Geoff Collyer Geoff Collyer
lan900-remote 2395 tcp LAN900 Remote

IANA assigned this well-formed service name as a replacement for "lan900_remote".
Tom Quinlan Tom Quinlan
lan900_remote 2395 tcp LAN900 Remote Tom Quinlan Tom Quinlan This entry is an alias to "lan900-remote". This entry is now historic, not usable for use with many common service discovery mechanisms.
lan900-remote 2395 udp LAN900 Remote

IANA assigned this well-formed service name as a replacement for "lan900_remote".
Tom Quinlan Tom Quinlan
lan900_remote 2395 udp LAN900 Remote Tom Quinlan Tom Quinlan This entry is an alias to "lan900-remote". This entry is now historic, not usable for use with many common service discovery mechanisms.
qip-qdhcp 2490 tcp qip_qdhcp Mike Morgan Mike Morgan
qip-qdhcp 2490 udp qip_qdhcp Mike Morgan Mike Morgan
idotdist 2590 tcp idotdist Jason Hunter Jason Hunter
idotdist 2590 udp idotdist Jason Hunter Jason Hunter
hp-nnm-data 2690 tcp HP NNM Embedded Database Chris Das Chris Das
hp-nnm-data 2690 udp HP NNM Embedded Database Chris Das Chris Das
plgproxy 2790 tcp PLG Proxy Charlie Hava Charlie Hava
plgproxy 2790 udp PLG Proxy Charlie Hava Charlie Hava
cspclmulti 2890 tcp CSPCLMULTI Yoneda Terumasa Yoneda Terumasa
cspclmulti 2890 udp CSPCLMULTI Yoneda Terumasa Yoneda Terumasa
quicksuite 2900 tcp QUICKSUITE William Egge William Egge

Contact Information

Name Organization Contact URI Last Updated
Adwait Sathe asathe&sonusnet.com 2005-08
Amir Peless amirp&radware.co.il
Ben Pracht ben.pracht&tivoli.com
Bob Lyon bl&oasis.icl.co.uk
C. Philip Wood cpw&lanl.gov
Charles Watt watt&sware.com
Charlie Hava charlieh&aks.com
Chris Das cdas&cnd.hp.com
Christian Callsen Christian.Callsen&eng.sun.com
Christopher Allen ChristopherA&consensus.com
Dan Harrington dth&lucent.com
Dave Mills mills&udel.edu 2022-06-03
David Gutiérrez Velneo velneo&velneo.com 2015-02-03
David Misunas DMisunas&micom.com
Ed Barron
Geoff Collyer geoff&research.bell-labs.com
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Jason Hunter jthunter&invino.com
Jeffrey J. Peters jpeters&tivo.com 2002-08
Jerome Albin albin&taec.enet.dec.com
Leif Ekblad leif&rdos.net
Louis E. Simard 76400.3371&compuserve.com
Michael Crawford michaelc&travsoft.com
Mike Morgan mmorgan&lucent.com
Nicholas Davies N.Davies&globalcomm.co.uk
Paul Blacknell paul&insitu.com
Paul Santinelli Jr. psantinelli&narrative.com
Peter Johnson peter&commlinx.com.au 2004-11
Peter King king&uplanet.com
Peter Schoenberger ps&teles.de
Sheila Devins sheila_devins&vnet.ibm.com
Tom Quinlan tquinlan&digitechinc.com
Tony Sawyer tonys&gemtech.com
UPnP Forum upnpadmin&forum.upnp.org
Velneo velneo&velneo.com
Wilken GmbH fy&wilken.de
William Egge begge&emagisoft.com
Wo'o Ideafarm b85f3c23.9ad6f42c&ideafarm.com
Yoneda Terumasa yonedat&pfu.co.jp