Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-13

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
ideafarm-panic 903 tcp self documenting Telnet Panic Door Wo'o Ideafarm Wo'o Ideafarm
ideafarm-panic 903 udp self documenting Panic Door: send 0x00 for info Wo'o Ideafarm Wo'o Ideafarm
linkname 1903 tcp Local Link Name Resolution Dan Harrington Dan Harrington
linkname 1903 udp Local Link Name Resolution Dan Harrington Dan Harrington
suitcase 2903 tcp SUITCASE Milton E. Sagen Milton E. Sagen
suitcase 2903 udp SUITCASE Milton E. Sagen Milton E. Sagen
charsetmgr 3903 tcp CharsetMGR Tatsuya Ueda Tatsuya Ueda 2003-10
charsetmgr 3903 udp CharsetMGR Tatsuya Ueda Tatsuya Ueda 2003-10
4903-4911 Unassigned
ff-ice 5903 tcp Flight & Flow Info for Collaborative Env International Civil Aviation Organisation (ICAO) Greg Saccone 2022-06-03 Defined TXT keys: FF-ICE
ff-ice 5903 udp Flight & Flow Info for Collaborative Env International Civil Aviation Organisation (ICAO) Greg Saccone 2022-06-03 Defined TXT keys: FF-ICE
ff-ice 5903 sctp Flight & Flow Info for Collaborative Env International Civil Aviation Organisation (ICAO) Greg Saccone 2022-06-03 Defined TXT keys: FF-ICE
tnos-dps 7903 tcp TNOS Secure DiaguardProtocol Rene Kurt Rene Kurt 2005-08
tnos-dps 7903 udp TNOS Secure DiaguardProtocol Rene Kurt Rene Kurt 2005-08
9903 tcp Reserved
multicast-ping 9903 udp Multicast Ping Protocol 2011-12-09 RFC 6450
niprobe 25903 tcp NIProbe Roman Oliynyk Roman Oliynyk
niprobe 25903 udp NIProbe Roman Oliynyk Roman Oliynyk

Contact Information

Name Organization Contact URI Last Updated
Dan Harrington dth&lucent.com
Greg Saccone gregory.t.saccone&boeing.com 2022-08-08
International Civil Aviation Organisation (ICAO) gisinbox&icao.int 2024-11-19
Milton E. Sagen msagen&extensis.com
Rene Kurt rene.kurt&adasoft.ch 2005-08
Roman Oliynyk romano&netinst.com
Tatsuya Ueda tatsu&ist.fujitsu.com 2003-10
Wo'o Ideafarm b85f3c23.9ad6f42c&ideafarm.com