Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
http 80 tcp World Wide Web HTTP IESG IETF Chair 2021-10-01 RFC 9110 Defined TXT keys: u=<username> p=<password> path=<path to document>
http 80 udp World Wide Web HTTP IESG IETF Chair 2021-10-01 RFC 9110 Defined TXT keys: u=<username> p=<password> path=<path to document>
www 80 tcp World Wide Web HTTP IESG IETF Chair 2021-10-01 RFC 9110 This is a duplicate of the "http" service and should not be used for discovery purposes.
www 80 udp World Wide Web HTTP IESG IETF Chair 2021-10-01 RFC 9110 This is a duplicate of the "http" service and should not be used for discovery purposes.
https 443 tcp http protocol over TLS/SSL IESG IETF Chair 2021-10-01 RFC 9110
https 443 udp http protocol over TLS/SSL IESG IETF Chair 2021-10-01 RFC 9110
xact-backup 911 tcp xact-backup Bill Carroll Bill Carroll
xact-backup 911 udp xact-backup Bill Carroll Bill Carroll
mtp 1911 tcp Starlight Networks Multimedia Transport Protocol Bruce Lieberman Bruce Lieberman
mtp 1911 udp Starlight Networks Multimedia Transport Protocol Bruce Lieberman Bruce Lieberman
blockade 2911 tcp Blockade VP - Research & Development VP - Research & Development
blockade 2911 udp Blockade VP - Research & Development VP - Research & Development
prnstatus 3911 tcp Printer Status Port Brett Green Brett Green 2003-11
prnstatus 3911 udp Printer Status Port Brett Green Brett Green 2003-11
4903-4911 Unassigned
ats-acars 5911 tcp Air Traffic Services applications using ACARS Eivan Cerasi Greg Saccone 2008-10-10 2022-08-08
ats-acars 5911 udp Air Traffic Services applications using ACARS Eivan Cerasi Greg Saccone 2008-10-10 2022-08-08
cpdlc 5911 sctp Controller Pilot Data Link Communication Justin Yu Justin Yu 2011-05-18
manyone-xml 8911 tcp manyone-xml Matt King Matt King 2002-04
manyone-xml 8911 udp manyone-xml Matt King Matt King 2002-04
9108-9110 Unassigned
hexxorecore 9111 tcp Multiple Purpose, Distributed Message Bus Hexxore Patrick Roozeboom 2018-07-31
hexxorecore 9111 udp Multiple Purpose, Distributed Message Bus Hexxore Patrick Roozeboom 2018-07-31
9112-9118 Unassigned
mxit 9119 tcp MXit Instant Messaging Marnus Freeman Marnus Freeman 2006-02
mxit 9119 udp MXit Instant Messaging Marnus Freeman Marnus Freeman 2006-02
sype-transport 9911 tcp SYPECom Transport Protocol Sylvain Pedneault Sylvain Pedneault 2003-03
sype-transport 9911 udp SYPECom Transport Protocol Sylvain Pedneault Sylvain Pedneault 2003-03
29001-29117 Unassigned
29118 tcp Reserved
29118 udp Reserved
sgsap 29118 sctp SGsAP in 3GPP Dongwook Kim Dongwook Kim 2009-06-11
29119-29166 Unassigned

Contact Information

Name Organization Contact URI Last Updated
Bill Carroll billc&xactlabs.com
VP - Research & Development development&blockade.com
Brett Green brett_green&hp.com 2003-11
Bruce Lieberman brucel&iserver.starlight.com
Eivan Cerasi eivan.cerasi&eurocontrol.int 2022-08-08
Dongwook Kim 3GPP Specifications Manager dongwook.kim&etsi.org 2026-01-23
Greg Saccone gregory.t.saccone&boeing.com 2022-08-08
Hexxore info&hexxore.nl 2018-07-31
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Justin Yu yyu&mitre.org 2011-05-25
Marnus Freeman marnus&swistgroup.com 2006-02
Matt King m&manyone.net 2002-04
Patrick Roozeboom info&hexxore.nl 2018-07-31
Sylvain Pedneault sylvain&sypecom.qc.ca 2003-03