Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-22

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
apex-edge 913 tcp APEX endpoint-relay service RFC 3340
apex-edge 913 udp APEX endpoint-relay service RFC 3340
armadp 1913 tcp armadp Kevin Welton Kevin Welton
armadp 1913 udp armadp Kevin Welton Kevin Welton
boosterware 2913 tcp Booster Ware Ido Ben-David Ido Ben-David
boosterware 2913 udp Booster Ware Ido Ben-David Ido Ben-David
listcrt-port 3913 tcp ListCREATOR Port Tomokazu Asai Tomokazu Asai 2003-11
listcrt-port 3913 udp ListCREATOR Port Tomokazu Asai Tomokazu Asai 2003-11
dots-signal 4646 tcp Distributed Denial-of-Service Open Threat Signaling (DOTS) Signal Channel Protocol. The service name is used to construct the SRV service names "_dots-signal._udp" and "_dots-signal._tcp" for discovering DOTS servers used to establish DOTS signal channel. IESG IETF Chair 2020-01-16 2021-06-14 RFC 8973; RFC 9132
dots-signal 4646 udp Distributed Denial-of-Service Open Threat Signaling (DOTS) Signal Channel Protocol. The service name is used to construct the SRV service names "_dots-signal._udp" and "_dots-signal._tcp" for discovering DOTS servers used to establish DOTS signal channel. IESG IETF Chair 2020-01-16 2021-06-14 RFC 8973; RFC 9132
lutcp 4913 tcp LUTher Control Protocol Markus Loeffler Markus Loeffler 2007-07-03
aoc-acars 5913 tcp Airline operational communications applications using ACARS Eivan Cerasi Greg Saccone 2008-10-10 2022-08-08
aoc-acars 5913 udp Airline operational communications applications using ACARS Eivan Cerasi Greg Saccone 2008-10-10 2022-08-08
ads-c 5913 sctp Automatic Dependent Surveillance Justin Yu Justin Yu 2011-05-25
qo-secure 7913 tcp QuickObjects secure port Jonas Bovin Jonas Bovin
qo-secure 7913 udp QuickObjects secure port Jonas Bovin Jonas Bovin
dragonfly 8913 tcp Dragonfly System Service Paul Hodara Paul Hodara 2005-11
dragonfly 8913 udp Dragonfly System Service Paul Hodara Paul Hodara 2005-11
9124-9130 Unassigned
dddp 9131 tcp Dynamic Device Discovery Shane Dick Shane Dick 2005-08
dddp 9131 udp Dynamic Device Discovery Shane Dick Shane Dick 2005-08
9132-9159 Unassigned

Contact Information

Name Organization Contact URI Last Updated
Eivan Cerasi eivan.cerasi&eurocontrol.int 2022-08-08
Greg Saccone gregory.t.saccone&boeing.com 2022-08-08
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Ido Ben-David dgntcom&netvision.net.il
Jonas Bovin jonas.bovin&quickobjects.com
Justin Yu yyu&mitre.org 2011-05-25
Kevin Welton Kevin.Welton&armltd.co.uk
Markus Loeffler markus.loeffler&thomson.net 2009-02-17
Paul Hodara phodara&netwave.com 2005-11
Shane Dick shane.dick&amx.com 2005-08
Tomokazu Asai asai.tomokazu&pfu.fujitsu.com 2003-11