Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-11-10

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
914c-g 211 tcp Texas Instruments 914C/G Terminal

IANA assigned this well-formed service name as a replacement for "914c/g".
Bill Harrell Bill Harrell
914c/g 211 tcp Texas Instruments 914C/G Terminal Bill Harrell Bill Harrell This entry is an alias to "914c-g". This entry is now historic, not usable for use with many common service discovery mechanisms.
914c-g 211 udp Texas Instruments 914C/G Terminal

IANA assigned this well-formed service name as a replacement for "914c/g".
Bill Harrell Bill Harrell
914c/g 211 udp Texas Instruments 914C/G Terminal Bill Harrell Bill Harrell This entry is an alias to "914c-g". This entry is now historic, not usable for use with many common service discovery mechanisms.
914 tcp Reserved
rift-lies 914 udp Routing in Fat Trees Link Information Element IESG IETF Chair 2023-02-17 2024-06-07 RFC 9692
elm-momentum 1914 tcp Elm-Momentum Willie Wu Willie Wu
elm-momentum 1914 udp Elm-Momentum Willie Wu Willie Wu
gamelobby 2914 tcp Game Lobby Paul Ford-Hutchinson Paul Ford-Hutchinson
gamelobby 2914 udp Game Lobby Paul Ford-Hutchinson Paul Ford-Hutchinson
listcrt-port-2 3914 tcp ListCREATOR Port 2 Tomokazu Asai Tomokazu Asai 2003-11
listcrt-port-2 3914 udp ListCREATOR Port 2 Tomokazu Asai Tomokazu Asai 2003-11
bones 4914 tcp Bones Remote Control Andreas Foedrowitz Andreas Foedrowitz 2008-06-18
bones 4914 udp Bones Remote Control Andreas Foedrowitz Andreas Foedrowitz 2008-06-18
ipsdtls 5914 tcp Security for Internet Protocol Suite International Civil Aviation Organisation (ICAO) Nathan Lackey 2024-11-19 Defined TXT keys: IPSDTLS
ipsdtls 5914 udp Security for Internet Protocol Suite International Civil Aviation Organisation (ICAO) Nathan Lackey 2024-11-19 Defined TXT keys: IPSDTLS
ipsdtls 5914 sctp Security for Internet Protocol Suite International Civil Aviation Organisation (ICAO) Nathan Lackey 2024-11-19 Defined TXT keys: IPSDTLS
7914-7931 Unassigned
8914-8936 Unassigned
49002-49149 Unassigned
est-coaps udp EST over secure CoAP (EST-coaps) Toerless Eckert Toerless Eckert 2022-05-03 2022-05-04 RFC 9148. Defined TXT keys: None
jnx-kcsync tcp jollys keychain cloud sync protocol Patrick Stein Patrick Stein 2011-10-24 Defined TXT keys: hash=<40hex characters> salt=<40hex characters> uuid=<40hex characters> Example: hash=5e7580598c0d7064d4fc79faaeb42585e1a675f8 salt=f0164cb3a0c3d7efe75abea8fda86d2d56c8dda9 uuid=db61dc092922252e45bbb264f59147138c7fd5fa

Contact Information

Name Organization Contact URI Last Updated
Andreas Foedrowitz andreas.foedrowitz&thomson.net 2008-06-18
Bill Harrell
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
International Civil Aviation Organisation (ICAO) gisinbox&icao.int 2024-11-19
Nathan Lackey nathan.lackey&boeing.com 2024-11-19
Patrick Stein Patrick.Stein&jinx.eu 2011-10-24
Paul Ford-Hutchinson paulfordh&uk.ibm.com 2003-01
Toerless Eckert tte&cs.fau.de 2022-05-03
Tomokazu Asai asai.tomokazu&pfu.fujitsu.com 2003-11
Willie Wu willie&mds.com