Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
ftps-data 989 tcp ftp protocol, data, over TLS/SSL
ftps-data 989 udp ftp protocol, data, over TLS/SSL
tr-rsrb-p3 1989 tcp cisco RSRB Priority 3 port
tr-rsrb-p3 1989 udp cisco RSRB Priority 3 port
mshnet 1989 tcp MHSnet system Bob Kummerfeld Bob Kummerfeld This entry records an unassigned but widespread use
mshnet 1989 udp MHSnet system Bob Kummerfeld Bob Kummerfeld This entry records an unassigned but widespread use
zarkov 2989 tcp ZARKOV Intelligent Agent Communication Robin Felix Robin Felix 2014-02-17
zarkov 2989 udp ZARKOV Intelligent Agent Communication Robin Felix Robin Felix 2014-02-17
bv-queryengine 3989 tcp BindView-Query Engine
bv-queryengine 3989 udp BindView-Query Engine
parallel 4989 tcp Parallel for GAUSS (tm) Matthew Ford Matthew Ford 2003-03
parallel 4989 udp Parallel for GAUSS (tm) Matthew Ford Matthew Ford 2003-03
wbem-https 5989 tcp WBEM CIM-XML (HTTPS) Jim Davis Jim Davis
wbem-https 5989 udp WBEM CIM-XML (HTTPS) Jim Davis Jim Davis
sunwebadmins 8989 tcp Sun Web Server SSL Admin Service Jyri J. Virkki Jyri J. Virkki 2005-12
sunwebadmins 8989 udp Sun Web Server SSL Admin Service Jyri J. Virkki Jyri J. Virkki 2005-12
9890-9897 Unassigned
monkeycom 9898 tcp MonkeyCom Yuji Kuwabara Yuji Kuwabara
monkeycom 9898 udp MonkeyCom Yuji Kuwabara Yuji Kuwabara
9899 tcp Reserved 2013-04-10
sctp-tunneling 9899 udp SCTP TUNNELING IESG IETF Chair 2013-04-10 RFC 6951
9989-9989 Unassigned
10934-10989 Unassigned

Contact Information

Name Organization Contact URI Last Updated
Bob Kummerfeld bob&sarad.cs.su.oz.au
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Jim Davis jim.davis&wbemsolutions.com 2007-06
Jyri J. Virkki jyri.virkki&sun.com 2005-12
Matthew Ford Matthew.Ford&forward.com.au 2003-03
Robin Felix zarkovport&outlook.com 2020-03-11
Yuji Kuwabara HHG01200&niftyserve.or.jp