Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
dhcpv6-client 546 udp DHCPv6 Client IESG IETF Chair 2018-05-21 RFC 9915
dhcpv6-server 547 udp DHCPv6 Server IESG IETF Chair 2018-05-21 RFC 9915
nas 991 tcp Netnews Administration System Vera Heinau; Heiko Schlichting Vera Heinau; Heiko Schlichting 2017-02-10 RFC 4707
nas 991 udp Netnews Administration System Vera Heinau; Heiko Schlichting Vera Heinau; Heiko Schlichting 2017-02-10 RFC 4707
stun-p2 1991 tcp cisco STUN Priority 2 port
stun-p2 1991 udp cisco STUN Priority 2 port
wkstn-mon 2991 tcp WKSTN-MON William David William David
wkstn-mon 2991 udp WKSTN-MON William David William David
bv-smcsrv 3991 tcp BindView-SMCServer
bv-smcsrv 3991 udp BindView-SMCServer
vrt 4991 tcp VITA Radio Transport Sam Bretheim Sam Bretheim 2009-01-08
vrt 4991 udp VITA Radio Transport Sam Bretheim Sam Bretheim 2009-01-08
nuxsl 5991 tcp NUXSL Kai Kretschmann Kai Kretschmann 2002-03
nuxsl 5991 udp NUXSL Kai Kretschmann Kai Kretschmann 2002-03
netconf-tls 6513 tcp NETCONF over TLS IESG IETF Chair 2024-01-24 RFC 7589; RFC 9918
https-wmap 8991 tcp webmail HTTPS service Chris Newman Chris Newman 2007-12-03
https-wmap 8991 udp webmail HTTPS service Chris Newman Chris Newman 2007-12-03
9910 Unassigned
sype-transport 9911 tcp SYPECom Transport Protocol Sylvain Pedneault Sylvain Pedneault 2003-03
sype-transport 9911 udp SYPECom Transport Protocol Sylvain Pedneault Sylvain Pedneault 2003-03
9912-9924 Unassigned
osm-oev 9991 tcp OSM Event Server Vinay Gupta Vinay Gupta 2003-08
osm-oev 9991 udp OSM Event Server Vinay Gupta Vinay Gupta 2003-08
10991-10999 Unassigned
intel-rci-mp 16991 tcp INTEL-RCI-MP Jane Dashevsky Jane Dashevsky
intel-rci-mp 16991 udp INTEL-RCI-MP Jane Dashevsky Jane Dashevsky

Contact Information

Name Organization Contact URI Last Updated
Chris Newman chris.newman&oracle.com 2017-01-26
Heiko Schlichting heiko.schlichting&fu-berlin.de 2022-06-07
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Jane Dashevsky jane.dashevsky&intel.com
Kai Kretschmann K.Kretschmann&security-gui.de 2002-03
Sam Bretheim info&opensigint.org 2009-01-08
Sylvain Pedneault sylvain&sypecom.qc.ca 2003-03
Vera Heinau vera.heinau&fu-berlin.de 2022-06-07
Vinay Gupta vinay.gupta&hp.com 2003-08
William David william.david&lmco.com