Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
iris-xpcs 714 tcp IRIS over XPCS RFC 4992
iris-xpcs 714 udp IRIS over XPCS RFC 4992
telnets 992 tcp telnet protocol over TLS/SSL
telnets 992 udp telnet protocol over TLS/SSL
stun-p3 1992 tcp cisco STUN Priority 3 port
stun-p3 1992 udp cisco STUN Priority 3 port
ipsendmsg 1992 tcp IPsendmsg Bob Kummerfeld Bob Kummerfeld This entry records an unassigned but widespread use
ipsendmsg 1992 udp IPsendmsg Bob Kummerfeld Bob Kummerfeld This entry records an unassigned but widespread use
avenyo 2992 tcp Avenyo Server Bodo Rueskamp Bodo Rueskamp
avenyo 2992 udp Avenyo Server Bodo Rueskamp Bodo Rueskamp
bv-ds 3992 tcp BindView-DirectoryServer
bv-ds 3992 udp BindView-DirectoryServer
4992-4998 Unassigned
consul-insight 5992 tcp Consul InSight Security Arthur Hillenaar Arthur Hillenaar 2006-01
consul-insight 5992 udp Consul InSight Security Arthur Hillenaar Arthur Hillenaar 2006-01
8992-8996 Unassigned
9912-9924 Unassigned
xybrid-cloud 9925 tcp XYBRID Cloud Rx Networks Inc. Drew Davies 2013-04-25
9925 udp Reserved
9926-9949 Unassigned
palace-1 9992 tcp OnLive-1 Douglas Crockford Douglas Crockford
palace-1 9992 udp OnLive-1 Douglas Crockford Douglas Crockford
amt-soap-http 16992 tcp Intel(R) AMT SOAP/HTTP David T. Hines David T. Hines 2005-02
amt-soap-http 16992 udp Intel(R) AMT SOAP/HTTP David T. Hines David T. Hines 2005-02

Contact Information

Name Organization Contact URI Last Updated
Arthur Hillenaar arthur.hillenaar&consul.com 2006-01
Bob Kummerfeld bob&sarad.cs.su.oz.au
Bodo Rueskamp iana+spam&pinda.de 2020-06-04
David T. Hines david.hines&intel.com 2005-02
Douglas Crockford douglas&crockford.com
Drew Davies Rx Networks Inc. ddavies&rxnetworks.com 2013-04-25
Rx Networks Inc. ddavies&rxnetworks.com 2013-04-25