Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-15
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| www-http | 80 | tcp | World Wide Web HTTP | Tim Berners-Lee | Tim Berners-Lee | This is a duplicate of the "http" service and should not be used for discovery purposes. u=<username> p=<password> path=<path to document> (see txtrecords.html#http) Known Subtypes: _printer NOTE: The meaning of this service type, though called just "http", actually denotes something more precise than just "any data transported using HTTP". The DNS-SD service type "http" should only be used to advertise content that: * is served over HTTP, * can be displayed by "typical" web browser client software, and * is intented primarily to be viewed by a human user. Of course, the definition of "typical web browser" is subjective, and may change over time, but for practical purposes the DNS-SD service type "http" can be understood as meaning "human-readable HTML content served over HTTP". In some cases other widely-supported content types may also be appropriate, such as plain text over HTTP, or JPEG image over HTTP. Content types not intented primarily for viewing by a human user, or not widely-supported in web browsing clients, should not be advertised as DNS-SD service type "http", even if they do happen to be transported over HTTP. Such types should be advertised as their own logical service type with their own DNS-SD service type, for example, XUL (XML User Interface Language) transported over HTTP is advertised explicitly as DNS-SD service type "xul-http". | |||||
| www-http | 80 | udp | World Wide Web HTTP | Tim Berners-Lee | Tim Berners-Lee | This is a duplicate of the "http" service and should not be used for discovery purposes. u=<username> p=<password> path=<path to document> (see txtrecords.html#http) Known Subtypes: _printer NOTE: The meaning of this service type, though called just "http", actually denotes something more precise than just "any data transported using HTTP". The DNS-SD service type "http" should only be used to advertise content that: * is served over HTTP, * can be displayed by "typical" web browser client software, and * is intented primarily to be viewed by a human user. Of course, the definition of "typical web browser" is subjective, and may change over time, but for practical purposes the DNS-SD service type "http" can be understood as meaning "human-readable HTML content served over HTTP". In some cases other widely-supported content types may also be appropriate, such as plain text over HTTP, or JPEG image over HTTP. Content types not intented primarily for viewing by a human user, or not widely-supported in web browsing clients, should not be advertised as DNS-SD service type "http", even if they do happen to be transported over HTTP. Such types should be advertised as their own logical service type with their own DNS-SD service type, for example, XUL (XML User Interface Language) transported over HTTP is advertised explicitly as DNS-SD service type "xul-http". | |||||
| dnsix | 90 | tcp | DNSIX Securit Attribute Token Map | Charles Watt | Charles Watt | PORT 90 also being used unofficially by Pointcast | |||||
| dnsix | 90 | udp | DNSIX Securit Attribute Token Map | Charles Watt | Charles Watt | PORT 90 also being used unofficially by Pointcast | |||||
| dn6-nlm-aud | 195 | tcp | DNSIX Network Level Module Audit | ||||||||
| dn6-nlm-aud | 195 | udp | DNSIX Network Level Module Audit | ||||||||
| dn6-smm-red | 196 | tcp | DNSIX Session Mgt Module Audit Redir | Lawrence Lebahn | Lawrence Lebahn | ||||||
| dn6-smm-red | 196 | udp | DNSIX Session Mgt Module Audit Redir | Lawrence Lebahn | Lawrence Lebahn | ||||||
| sdnskmp | 558 | tcp | SDNSKMP | ||||||||
| sdnskmp | 558 | udp | SDNSKMP | ||||||||
| domain-s | 853 | tcp | DNS query-response protocol run over TLS | IESG | IETF Chair | 2015-10-08 | 2022-04-11 | RFC 7858 | |||
| domain-s | 853 | udp | DNS query-response protocol run over DTLS or QUIC | IESG | IETF Chair | 2015-10-08 | 2022-04-01 | RFC 7858; RFC 8094; RFC 9250 | |||
| ddt | 1052 | tcp | Dynamic DNS Tools | Remi Lefebvre | Remi Lefebvre | ||||||
| ddt | 1052 | udp | Dynamic DNS Tools | Remi Lefebvre | Remi Lefebvre | ||||||
| dns2go | 1227 | tcp | DNS2Go | Deerfield Communications Inc. | Mike Courterier | 2015-07-15 | |||||
| dns2go | 1227 | udp | DNS2Go | Deerfield Communications Inc. | Mike Courterier | 2015-07-15 | |||||
| menandmice-dns | 1337 | tcp | menandmice DNS | Sigfus Magnusson | Sigfus Magnusson | ||||||
| menandmice-dns | 1337 | udp | menandmice DNS | Sigfus Magnusson | Sigfus Magnusson | ||||||
| sunscalar-dns | 1870 | tcp | SunSCALAR DNS Service | Sanjay Radia | Sanjay Radia | ||||||
| sunscalar-dns | 1870 | udp | SunSCALAR DNS Service | Sanjay Radia | Sanjay Radia | ||||||
| ddns-v3 | 2164 | tcp | Dynamic DNS Version 3 | Alan Yates | Alan Yates | ||||||
| ddns-v3 | 2164 | udp | Dynamic DNS Version 3 | Alan Yates | Alan Yates | ||||||
| spw-dnspreload | 3849 | tcp | SPACEWAY DNS Preload | Daniel Friedman | Daniel Friedman | 2003-08 | |||||
| spw-dnspreload | 3849 | udp | SPACEWAY DNS Preload | Daniel Friedman | Daniel Friedman | 2003-08 | |||||
| dns-llq | 5352 | tcp | DNS Long-Lived Queries | Stuart Cheshire | Stuart Cheshire | 2005-08 | 2019-08-26 | RFC 8764 | |||
| dns-llq | 5352 | udp | DNS Long-Lived Queries | Stuart Cheshire | Stuart Cheshire | 2005-08 | 2019-08-26 | RFC 8764 | |||
| mdns | 5353 | tcp | Multicast DNS | IESG | IETF Chair | RFC 6762 | |||||
| mdns | 5353 | udp | Multicast DNS | IESG | IETF Chair | RFC 6762 | |||||
| mdnsresponder | 5354 | tcp | Multicast DNS Responder IPC | Stuart Cheshire | Stuart Cheshire | 2004-06 | |||||
| mdnsresponder | 5354 | udp | Multicast DNS Responder IPC | Stuart Cheshire | Stuart Cheshire | 2004-06 | |||||
| ub-dns-control | 8953 | tcp | unbound dns nameserver control | NLnet Labs Support | NLnet Labs Support | 2011-05-10 | 2011-07-11 | ||||
| pdl-datastream | 9100 | tcp | Printer PDL Data Stream | Stuart Cheshire | Stuart Cheshire | 2002-09 | The protocol name "pdl-datastream" is primarily registered for use in DNS SRV records (RFC 2782). DNS SRV records allow a protocol to run on any port number, but the default port for this protocol is 9100. | ||||
| pdl-datastream | 9100 | udp | Printer PDL Data Stream | Stuart Cheshire | Stuart Cheshire | 2002-09 | The protocol name "pdl-datastream" is primarily registered for use in DNS SRV records (RFC 2782). DNS SRV records allow a protocol to run on any port number, but the default port for this protocol is 9100. | ||||
| odnsp | 9966 | tcp | OKI Data Network Setting Protocol | Masato Sato | Masato Sato | 2006-05 | |||||
| odnsp | 9966 | udp | OKI Data Network Setting Protocol | Masato Sato | Masato Sato | 2006-05 | |||||
| conecube | udp | DNS SRV service for smarthome server | cone smart solution | Christoph Bimminger | 2019-04-22 | Defined TXT keys: none | |||||
| device-info | Device Info | Stuart Cheshire; Marc Krochmal | Stuart Cheshire; Marc Krochmal | Not a service type. Special name reserved for DNS-SD device info. | |||||||
| dns-llq-tls | tcp | DNS Long-Lived Queries over TLS | Stuart Cheshire | Stuart Cheshire | 2019-05-04 | RFC 6281 | Defined TXT Keys: None | ||||
| dns-push-tls | tcp | DNS Push Notification Service Type | IESG | IETF Chair | 2019-11-25 | RFC 8765, Section 6.1 | Defined TXT Keys: None | ||||
| dns-query-tls | tcp | DNS queries to the authoritative server over TLS | Stuart Cheshire | Stuart Cheshire | 2019-05-04 | Defined TXT Keys: None | |||||
| dns-sd | DNS Service Discovery | Stuart Cheshire; Marc Krochmal | Stuart Cheshire; Marc Krochmal | Not a service type. Special name reserved for DNS-SD meta queries. | |||||||
| dns-update | tcp | DNS Dynamic Update Service | Stuart Cheshire | Stuart Cheshire | 2019-05-04 | DNS Dynamic Update Service for a given domain may not necessarily be provided by the principal name servers as advertised by the domain's "NS" records, and may not necessarily always be provided on port 53. The "_dns-update._udp.<domain>." SRV record gives the target host and port where DNS Dynamic Update Service is provided for the named domain. | |||||
| dns-update | udp | DNS Dynamic Update Service | Stuart Cheshire | Stuart Cheshire | 2019-05-04 | DNS Dynamic Update Service for a given domain may not necessarily be provided by the principal name servers as advertised by the domain's "NS" records, and may not necessarily always be provided on port 53. The "_dns-update._udp.<domain>." SRV record gives the target host and port where DNS Dynamic Update Service is provided for the named domain. | |||||
| dns-update-tls | tcp | DNS Dynamic Update Service over TLS | Stuart Cheshire | Stuart Cheshire | 2019-05-04 | RFC 6281 | DNS Dynamic Update Service for a given domain may not necessarily be provided by the principal name servers as advertised by the domain's "NS" records, and may not necessarily always be provided on port 53. The "_dns-update._udp.<domain>." SRV record gives the target host and port where DNS Dynamic Update Service is provided for the named domain. | ||||
| dnssd-srp | tcp | DNS-Based Service Discovery | IESG | IETF Chair | 2024-04-12 | 2024-09-05 | RFC 9665 | Defined TXT keys: None | |||
| dnssd-srp-tls | tcp | DNS-Based Service Discovery (TLS) | IESG | IETF Chair | 2024-04-12 | 2024-09-05 | RFC 9665 | Defined TXT keys: None | |||
| ep | Endpoint Protocol (EP) for use in Home Automation systems | Tommy van der Vorst | Tommy van der Vorst | Defined TXT keys: dns-sd_mdns | |||||||
| eucalyptus | Eucalyptus Discovery | Support Team | Support Team | Defined TXT keys: Eucalyptus-DNS-SD | |||||||
| guid | Special service type for resolving by GUID (Globally Unique Identifier) | Defined TXT keys: Varies; Depends on type of service being offered/resolved Although DNS-SD does not recommend or advocate using GUIDs as the primary name of an offered service why not?, it does support use of GUIDs as service names where developers want to use them that way. Typically users do not browse for GUIDs. They are not user-friendly and not very informative. Typically, the service is advertised as usual, using a user-friendly name. One of the TXT record attributes is a GUID for the service instance. Once the user has browsed and chosen the desired service instance via its user-friendly name, the service is resolved, the TXT record is retrieved, and the GUID is stored. A given network service instance is therefore being advertised two ways, for example: <User-Friendly-Name>._ptp._tcp.local <GUID>._guid._tcp.local On subsequent accesses to the service, the GUID-based name is resolved, and that particular service instance is discovered, even if the user has subsequently changed the user-friendly name to something else. Note: Although each different logical service type needs to have its own different DNS-SD service type, all GUID-based names use the same pseudo-type: "_guid._tcp". There is no possibility of name conflict because (by definition) GUIDs are globally unique. | |||||||||
| https | tcp | HTTP over SSL/TLS | Tim Berners-Lee | Tim Berners-Lee | Web browsers like Safari and Internet Explorer (with the Bonjour for Windows plugin) DO NOT browse for DNS-SD service type "_https._tcp" in addition to browsing for "_http._tcp". This is a conscious decision to reduce proliferation of service types, to help keep DNS-SD efficient on the network. Today, if a user types http://www.mybank.com/ into their web browser, the web server automatically redirects the user to https://www.mybank.com/. Rather than having an entirely different DNS-SD service type for https, we recommend using the same redirection mechanism: advertise a plain "http" service, which consists of nothing except an HTTP redirection to the desired "https" URL. Work is currently being done on adding mechanisms to HTTP and TLS to allow the server to tell the client that it needs to activate TLS on the current connection before proceeding. If this becomes widely adopted, it further justifies the decision to not create a separate DNS-SD service type "_https._tcp", because security becomes just another one of the things that is negotiated on a per-connection basis (like content-type negotiation today) rather than being an entirely separate thing. | ||||||
| nasunifiler | tcp | This DNS-SD service is used by mobile clients to locate the Nasuni Filer (a storage product) for a given company. | Nasuni Corporation | David Shaw | 2016-01-22 | Defined TXT keys: companyfullname == The name of the company hosting the Nasuni Filer | |||||
| presence | Peer-to-peer messaging / Link-Local Messaging | XMPP Registrar | XMPP Registrar | Defined TXT keys: See http://www.xmpp.org/registrar/linklocal.html Note: Registration updated May 2007. Was formerly listed as "iChat AV" (Apple's IM client for Mac OS X) with TXT keys: txtvers, port.p2pj, phsh, vc, 1st, AIM, msg, status, last When first shipped in Mac OS X 10.2, iChat's peer-to-peer messaging protocol was created to solve the problem of serverless messaging between peers on the same link. However, there is nothing inherent in the protocol that limits it to being only link-local; it was simply an artifact of iChat in Mac OS X 10.2 using link-local Multicast DNS to discover peers. With the advent of Wide-Area DNS-SD, it is also possible to use iChat's peer-to-peer messaging between machines on different links. | |||||||
| recipe-sharing | tcp | Recipe Sharing Protocol | Daniel G. Taylor | Daniel G. Taylor | 2007-11 | Defined TXT keys: http://www.recipemanager.org/rsp/rsp10draft.html#dnssd | |||||
| rfbc | Remote Frame Buffer Client (Used by VNC viewers in listen-mode) | Ole-Morten Duesund | Ole-Morten Duesund | Defined TXT keys: server=dns-name/ip-address:port of currently displayed VNC server. Empty if not showing anything/available. | |||||||
| s2connect | tcp | S2 Connect energy management protocol | TNO | Wilco Wijbrandi | 2026-03-27 | Defined TXT Keys: https://docs.s2standard.org/docs/communication-layer/discovery-pairing-authentication/#dns-sd-based-discovery | |||||
| services | DNS Service Discovery | Stuart Cheshire; Marc Krochmal | Stuart Cheshire; Marc Krochmal | Not a service type. Special name reserved for DNS-SD meta queries. | |||||||
| split-dns64 | tcp | DNS64 in split configuration | Kasper Dupont | Kasper Dupont | 2021-10-19 | Defined TXT keys: None | |||||
| voalte2 | tcp | Server location via DNS-SD | Voalte, Inc. | John Simpson | 2019-01-22 | Defined TXT keys: txtvers, name, (others not publicly documented) | |||||
| voalte3 | tcp | Server location via DNS-SD | Voalte, Inc. | John Simpson | 2019-01-22 | Defined TXT keys: txtvers, name, (others not publicly documented) |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Alan Yates | alany&ay.com.au | ||
| Charles Watt | watt&sware.com | ||
| Christoph Bimminger | cone smart solution | christoph.bimminger&cone.at | 2019-04-22 |
| cone smart solution | office&cone.at | 2019-04-22 | |
| Daniel Friedman | dfriedman&hns.com | 2003-08 | |
| Daniel G. Taylor | dan&programmer-art.org | 2007-11 | |
| David Shaw | dshaw&nasuni.com | 2016-01-22 | |
| Deerfield Communications Inc. | mikec&deerfield.net | 2015-07-15 | |
| IESG | iesg&ietf.org | ||
| IETF Chair | IETF | chair&ietf.org | |
| John Simpson | Voalte, Inc. | jms1&voalte.com | 2019-01-22 |
| Kasper Dupont | kasperd&xwhfx.16.oct.2021.kasperd.dk | 2021-10-19 | |
| Lawrence Lebahn | DIA3&paxrv-nes.navy.mil | ||
| Marc Krochmal | marc&apple.com | ||
| Masato Sato | satou203&oki.com | 2006-05 | |
| Mike Courterier | Deerfield Communications Inc. | mikec&deerfield.net | 2015-07-15 |
| NLnet Labs Support | NLnet Labs | support&nlnetlabs.nl | 2011-07-11 |
| Nasuni Corporation | it&nasuni.com | 2016-01-22 | |
| Ole-Morten Duesund | ole-morten.duesund&bbvisuals.no | ||
| Remi Lefebvre | remi&debian.org | ||
| Sanjay Radia | srradia&kasumbi.eng.sun.com | ||
| Sigfus Magnusson | sigfusm&menandmice.com | ||
| Stuart Cheshire | cheshire&apple.com | 2022-07-11 | |
| Stuart Cheshire | mdnsresponder-ipc&multicastdns.org | 2004-06 | |
| Stuart Cheshire | pdl-datastream&apple.com | 2002-09 | |
| Support Team | support&eucalyptus.com | ||
| Tim Berners-Lee | timbl&w3.org | ||
| TNO | info&tno.nl | 2026-03-27 | |
| Tommy van der Vorst | tommy&pixelspark.nl | ||
| Voalte, Inc. | engops&voalte.com | 2019-01-22 | |
| Wilco Wijbrandi | wilco.wijbrandi&tno.nl | 2026-03-27 | |
| XMPP Registrar | registrar&xmpp.org |