Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-27
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| ftp-data | 20 | tcp | File Transfer [Default Data] | Jon Postel | Jon Postel | ||||||
| ftp-data | 20 | udp | File Transfer [Default Data] | Jon Postel | Jon Postel | ||||||
| ftp-data | 20 | sctp | FTP | Randall Stewart | Randall Stewart | 2022-02-07 | RFC 9260 | ||||
| ftp | 21 | tcp | File Transfer Protocol [Control] | Jon Postel | Jon Postel | RFC 959 | Defined TXT keys: u=<username> p=<password> path=<path> | ||||
| ftp | 21 | udp | File Transfer Protocol [Control] | Jon Postel | Jon Postel | RFC 959 | Defined TXT keys: u=<username> p=<password> path=<path> | ||||
| ftp | 21 | sctp | FTP | Randall Stewart | Randall Stewart | 2022-02-07 | RFC 9260 | Defined TXT keys: u=<username> p=<password> path=<path> | |||
| tftp | 69 | tcp | Trivial File Transfer | David Clark | David Clark | ||||||
| tftp | 69 | udp | Trivial File Transfer | David Clark | David Clark | ||||||
| sftp | 115 | tcp | Simple File Transfer Protocol | Mark Lottor | Mark Lottor | ||||||
| sftp | 115 | udp | Simple File Transfer Protocol | Mark Lottor | Mark Lottor | ||||||
| bftp | 152 | tcp | Background File Transfer Program | Annette DeSchon | Annette DeSchon | ||||||
| bftp | 152 | udp | Background File Transfer Program | Annette DeSchon | Annette DeSchon | ||||||
| softpc | 215 | tcp | Insignia Solutions | Martyn Thomas | Martyn Thomas | ||||||
| softpc | 215 | udp | Insignia Solutions | Martyn Thomas | Martyn Thomas | ||||||
| subntbcst-tftp | 247 | tcp | SUBNTBCST_TFTP IANA assigned this well-formed service name as a replacement for "subntbcst_tftp". |
John Fake | John Fake | ||||||
| subntbcst_tftp | 247 | tcp | SUBNTBCST_TFTP | John Fake | John Fake | This entry is an alias to "subntbcst-tftp". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| subntbcst-tftp | 247 | udp | SUBNTBCST_TFTP IANA assigned this well-formed service name as a replacement for "subntbcst_tftp". |
John Fake | John Fake | ||||||
| subntbcst_tftp | 247 | udp | SUBNTBCST_TFTP | John Fake | John Fake | This entry is an alias to "subntbcst-tftp". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| mftp | 349 | tcp | mftp | Dave Feinleib | Dave Feinleib | ||||||
| mftp | 349 | udp | mftp | Dave Feinleib | Dave Feinleib | ||||||
| ftp-agent | 574 | tcp | FTP Software Agent System | Michael S. Greenberg | Michael S. Greenberg | ||||||
| ftp-agent | 574 | udp | FTP Software Agent System | Michael S. Greenberg | Michael S. Greenberg | ||||||
| pftp | 662 | tcp | PFTP | Ben Schluricke | Ben Schluricke | ||||||
| pftp | 662 | udp | PFTP | Ben Schluricke | Ben Schluricke | ||||||
| ftps-data | 989 | tcp | ftp protocol, data, over TLS/SSL | ||||||||
| ftps-data | 989 | udp | ftp protocol, data, over TLS/SSL | ||||||||
| ftps | 990 | tcp | ftp protocol, control, over TLS/SSL | Christopher Allen | Christopher Allen | ||||||
| ftps | 990 | udp | ftp protocol, control, over TLS/SSL | Christopher Allen | Christopher Allen | ||||||
| tftp-mcast | 1758 | tcp | tftp-mcast | Tom Emberson | Tom Emberson | ||||||
| tftp-mcast | 1758 | udp | tftp-mcast | Tom Emberson | Tom Emberson | ||||||
| etftp | 1818 | tcp | Enhanced Trivial File Transfer Protocol | William Polites | William Polites | ||||||
| etftp | 1818 | udp | Enhanced Trivial File Transfer Protocol | William Polites | William Polites | ||||||
| utsftp | 2529 | tcp | UTS FTP | David Moore | David Moore | ||||||
| utsftp | 2529 | udp | UTS FTP | David Moore | David Moore | ||||||
| gsiftp | 2811 | tcp | GSI FTP | Von Welch | Von Welch | ||||||
| gsiftp | 2811 | udp | GSI FTP | Von Welch | Von Welch | ||||||
| odette-ftp | 3305 | tcp | ODETTE-FTP | David Nash | David Nash | RFC 5024 | |||||
| odette-ftp | 3305 | udp | ODETTE-FTP | David Nash | David Nash | RFC 5024 | |||||
| tftps | 3713 | tcp | TFTP over TLS | Mark mayernick | Mark mayernick | 2003-03 | |||||
| tftps | 3713 | udp | TFTP over TLS | Mark mayernick | Mark mayernick | 2003-03 | |||||
| exasoftport1 | 3920 | tcp | Exasoft IP Port | Alan Malik | Alan Malik | 2003-11 | |||||
| exasoftport1 | 3920 | udp | Exasoft IP Port | Alan Malik | Alan Malik | 2003-11 | |||||
| nst | 4687 | tcp | Network Scanner Tool FTP | Mala Bhat | Mala Bhat | 2005-08 | |||||
| nst | 4687 | udp | Network Scanner Tool FTP | Mala Bhat | Mala Bhat | 2005-08 | |||||
| mftp | 5402 | tcp | OmniCast MFTP | Steve Bannister | Steve Bannister | ||||||
| mftp | 5402 | udp | OmniCast MFTP | Steve Bannister | Steve Bannister | ||||||
| odette-ftps | 6619 | tcp | ODETTE-FTP over TLS/SSL | Ieuan Friend | Ieuan Friend | 2006-03 | RFC 5024 | ||||
| odette-ftps | 6619 | udp | ODETTE-FTP over TLS/SSL | Ieuan Friend | Ieuan Friend | 2006-03 | RFC 5024 | ||||
| kftp-data | 6620 | tcp | Kerberos V5 FTP Data | Robert J. Scott | Robert J. Scott | 2005-08 | |||||
| kftp-data | 6620 | udp | Kerberos V5 FTP Data | Robert J. Scott | Robert J. Scott | 2005-08 | |||||
| kftp | 6621 | tcp | Kerberos V5 FTP Control | Robert J. Scott | Robert J. Scott | 2005-08 | |||||
| kftp | 6621 | udp | Kerberos V5 FTP Control | Robert J. Scott | Robert J. Scott | 2005-08 | |||||
| mcftp | 6622 | tcp | Multicast FTP | Bruce Lueckenhoff | Bruce Lueckenhoff | 2006-02 | |||||
| mcftp | 6622 | udp | Multicast FTP | Bruce Lueckenhoff | Bruce Lueckenhoff | 2006-02 | |||||
| 3gpp-monp | 8809 | udp | MCPTT Off-Network Protocol (MONP) | 3GPP | Dongwook Kim | 2019-04-15 | 2026-01-23 | 3GPP TS 24.379 v13.5.0s | |||
| eftp | 37601 | tcp | Epipole File Transfer Protocol | Epipole Limited | Colin Buchanan | 2014-11-13 | |||||
| spremotetablet | 46998 | tcp | Connection between a desktop computer or server and a signature tablet to capture handwritten signatures | SOFTPRO GmbH | Christoph Hipp | 2012-07-19 | 2013-08-02 | ||||
| cftp | CFTP | ||||||||||
| via-ftp | VIA Systems-File Transfer Protocol | ||||||||||
| ftpcroco | Crocodile FTP Server | Xnet Communications | Xnet Communications | Defined TXT keys: None | |||||||
| ni-ftp | tcp | NI FTP | Steve Kille | Steve Kille | 2017-05-18 | Defined TXT keys: None | |||||
| ni-ftp | udp | NI FTP | Steve Kille | Steve Kille | 2017-05-18 | Defined TXT keys: None | |||||
| scoop-sftp | tcp | The service name is used by the SFTP protocol to upload log files from vehicles to road side units in a securely way in a cooperative intelligent transportation system. | SCOOP@F Project | Houda Labiod | 2016-02-04 | Defined TXT keys: None | |||||
| scoop-sftp | udp | The service name is used by the SFTP protocol to upload log files from vehicles to road side units in a securely way in a cooperative intelligent transportation system. | SCOOP@F Project | Houda Labiod | 2016-02-04 | Defined TXT keys: None | |||||
| sftp-ssh | Secure File Transfer Protocol over SSH | Bryan Cole | Bryan Cole | Defined TXT keys: u=<username> p=<password> path=<path> | |||||||
| simusoftpong | simusoftpong iPhone game protocol | Anders Svensson | Anders Svensson | Defined TXT keys: Proprietary |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| 3GPP | info&3gpp.org | 2026-10-20 | |
| Alan Malik | alan&exasoft.co.uk | 2003-11 | |
| Anders Svensson | pong&simusoft.dk | ||
| Annette DeSchon | DESCHON&isi.edu | ||
| Ben Schluricke | support&pftp.de | ||
| Bruce Lueckenhoff | bruce&scalabledesign.com | 2006-02 | |
| Bryan Cole | bryan.cole&teraview.com | ||
| Christoph Hipp | SOFTPRO GmbH | christoph.hipp&softpro.de | 2013-08-02 |
| Christopher Allen | ChristopherA&consensus.com | ||
| Colin Buchanan | Epipole Limited | colin&epipole.com | 2014-11-13 |
| Dave Feinleib | davefeµsoft.com | ||
| David Clark | ddc&lcs.mit.edu | ||
| David Moore | dmoore&uttc-uts.com | ||
| David Nash | dnash&ford.com | ||
| Dongwook Kim | 3GPP | info&3gpp.org | 2026-10-20 |
| Epipole Limited | info&epipole.com | 2014-11-13 | |
| Houda Labiod | SCOOP@F Project | houda.labiod&telecom-paristech.fr | 2016-02-04 |
| Ieuan Friend | ieuan.friend&dip.co.uk | 2006-03 | |
| John Fake | fake&us.ibm.com | ||
| Jon Postel | postel&isi.edu | ||
| Mala Bhat | bmala&ssdi.sharp.co.in | 2005-08 | |
| Mark Lottor | MKL&nisc.sri.com | ||
| Mark mayernick | Mark.Mayernick&thomson.net | 2003-03 | |
| Martyn Thomas | |||
| Michael S. Greenberg | arnoff&ftp.com | ||
| Randall Stewart | IETF TSVWG | rrs&lakerest.net | |
| Robert J. Scott | rob&hpcmo.hpc.mil | 2005-08 | |
| SCOOP@F Project | houda.labiod&telecom-paristech.fr | 2016-02-04 | |
| SOFTPRO GmbH | christoph.hipp&softpro.de | 2013-08-02 | |
| Steve Bannister | sbannister&stratacache.com | ||
| Steve Kille | steve.kille&isode.com | 2017-05-18 | |
| Tom Emberson | tom&lanworks.com | ||
| Von Welch | vwelch&ncsa.uiuc.edu | ||
| William Polites | wpolites&mitre.org | ||
| Xnet Communications | croco&xdsnet.de |