Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-27

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
ftp-data 20 tcp File Transfer [Default Data] Jon Postel Jon Postel
ftp-data 20 udp File Transfer [Default Data] Jon Postel Jon Postel
ftp-data 20 sctp FTP Randall Stewart Randall Stewart 2022-02-07 RFC 9260
kftp-data 6620 tcp Kerberos V5 FTP Data Robert J. Scott Robert J. Scott 2005-08
kftp-data 6620 udp Kerberos V5 FTP Data Robert J. Scott Robert J. Scott 2005-08

Contact Information

Name Organization Contact URI Last Updated
Jon Postel postel&isi.edu
Randall Stewart IETF TSVWG rrs&lakerest.net
Robert J. Scott rob&hpcmo.hpc.mil 2005-08