Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-13
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| http | 80 | tcp | World Wide Web HTTP | IESG | IETF Chair | 2021-10-01 | RFC 9110 | Defined TXT keys: u=<username> p=<password> path=<path to document> | |||
| http | 80 | udp | World Wide Web HTTP | IESG | IETF Chair | 2021-10-01 | RFC 9110 | Defined TXT keys: u=<username> p=<password> path=<path to document> | |||
| www | 80 | tcp | World Wide Web HTTP | IESG | IETF Chair | 2021-10-01 | RFC 9110 | This is a duplicate of the "http" service and should not be used for discovery purposes. | |||
| www | 80 | udp | World Wide Web HTTP | IESG | IETF Chair | 2021-10-01 | RFC 9110 | This is a duplicate of the "http" service and should not be used for discovery purposes. | |||
| www-http | 80 | tcp | World Wide Web HTTP | Tim Berners-Lee | Tim Berners-Lee | This is a duplicate of the "http" service and should not be used for discovery purposes. u=<username> p=<password> path=<path to document> (see txtrecords.html#http) Known Subtypes: _printer NOTE: The meaning of this service type, though called just "http", actually denotes something more precise than just "any data transported using HTTP". The DNS-SD service type "http" should only be used to advertise content that: * is served over HTTP, * can be displayed by "typical" web browser client software, and * is intented primarily to be viewed by a human user. Of course, the definition of "typical web browser" is subjective, and may change over time, but for practical purposes the DNS-SD service type "http" can be understood as meaning "human-readable HTML content served over HTTP". In some cases other widely-supported content types may also be appropriate, such as plain text over HTTP, or JPEG image over HTTP. Content types not intented primarily for viewing by a human user, or not widely-supported in web browsing clients, should not be advertised as DNS-SD service type "http", even if they do happen to be transported over HTTP. Such types should be advertised as their own logical service type with their own DNS-SD service type, for example, XUL (XML User Interface Language) transported over HTTP is advertised explicitly as DNS-SD service type "xul-http". | |||||
| www-http | 80 | udp | World Wide Web HTTP | Tim Berners-Lee | Tim Berners-Lee | This is a duplicate of the "http" service and should not be used for discovery purposes. u=<username> p=<password> path=<path to document> (see txtrecords.html#http) Known Subtypes: _printer NOTE: The meaning of this service type, though called just "http", actually denotes something more precise than just "any data transported using HTTP". The DNS-SD service type "http" should only be used to advertise content that: * is served over HTTP, * can be displayed by "typical" web browser client software, and * is intented primarily to be viewed by a human user. Of course, the definition of "typical web browser" is subjective, and may change over time, but for practical purposes the DNS-SD service type "http" can be understood as meaning "human-readable HTML content served over HTTP". In some cases other widely-supported content types may also be appropriate, such as plain text over HTTP, or JPEG image over HTTP. Content types not intented primarily for viewing by a human user, or not widely-supported in web browsing clients, should not be advertised as DNS-SD service type "http", even if they do happen to be transported over HTTP. Such types should be advertised as their own logical service type with their own DNS-SD service type, for example, XUL (XML User Interface Language) transported over HTTP is advertised explicitly as DNS-SD service type "xul-http". | |||||
| http | 80 | sctp | HTTP | Randall Stewart | Randall Stewart | 2022-02-07 | RFC 9260 | Defined TXT keys: u=<username> p=<password> path=<path to document> | |||
| http-mgmt | 280 | tcp | http-mgmt | Adrian Pell | Adrian Pell | ||||||
| http-mgmt | 280 | udp | http-mgmt | Adrian Pell | Adrian Pell | ||||||
| http-alt | 591 | tcp | FileMaker, Inc. - HTTP Alternate (see Port 80) | Clay Maeckel | Clay Maeckel | ||||||
| http-alt | 591 | udp | FileMaker, Inc. - HTTP Alternate (see Port 80) | Clay Maeckel | Clay Maeckel | ||||||
| ipps | 631 | tcp | Internet Printing Protocol over HTTPS | IESG | IETF Chair | 2018-07-06 | RFC 8011 | ||||
| webpush | 1001 | tcp | HTTP Web Push | IESG | IETF Chair | 2016-11-01 | RFC 8030 | ||||
| httpx | 4180 | tcp | HTTPX | Paul McGough | Paul McGough | 2007-02 | |||||
| httpx | 4180 | udp | HTTPX | Paul McGough | Paul McGough | 2007-02 | 2016-01-05 | ||||
| xmpp-bosh | 5280 | tcp | Bidirectional-streams Over Synchronous HTTP (BOSH) | Peter Saint-Andre | Peter Saint-Andre | 2009-11-25 | |||||
| sun-sr-http | 6480 | tcp | Service Registry Default HTTP Domain | Paul Sterk | Paul Sterk | 2006-03 | |||||
| sun-sr-http | 6480 | udp | Service Registry Default HTTP Domain | Paul Sterk | Paul Sterk | 2006-03 | |||||
| asr | 7800 | tcp | Apple Software Restore | Jim Kateley; Shantonu Sen | Jim Kateley; Shantonu Sen | 2006-01 | Defined TXT keys: image=<HTTP URL of disk image> | ||||
| asr | 7800 | udp | Apple Software Restore | Jim Kateley; Shantonu Sen | Jim Kateley; Shantonu Sen | 2006-01 | Defined TXT keys: image=<HTTP URL of disk image> | ||||
| http-alt | 8008 | tcp | HTTP Alternate | James Gettys | James Gettys | ||||||
| http-alt | 8008 | udp | HTTP Alternate | James Gettys | James Gettys | ||||||
| http-alt | 8080 | tcp | HTTP Alternate (see port 80) | Stephen Casner | Stephen Casner | ||||||
| http-alt | 8080 | udp | HTTP Alternate (see port 80) | Stephen Casner | Stephen Casner | ||||||
| websnp | 8084 | tcp | Snarl Network Protocol over HTTP | full phat products | Chris Peel | 2019-08-08 | |||||
| radan-http | 8088 | tcp | Radan HTTP | Steve Hay | Steve Hay | 2008-06-13 | |||||
| radan-http | 8088 | udp | Radan HTTP | Steve Hay | Steve Hay | 2008-06-13 | |||||
| synapse-nhttp | 8280 | tcp | Synapse Non Blocking HTTP | Ruwan Linton | Ruwan Linton | 2008-06-05 | |||||
| synapse-nhttp | 8280 | udp | Synapse Non Blocking HTTP | Ruwan Linton | Ruwan Linton | 2008-06-05 | |||||
| 3gpp-monp | 8809 | udp | MCPTT Off-Network Protocol (MONP) | 3GPP | Dongwook Kim | 2019-04-15 | 2026-01-23 | 3GPP TS 24.379 v13.5.0s | |||
| nbd | 10809 | tcp | Network Block Device | Wouter Verhelst | Wouter Verhelst | 2010-08-02 | 2024-04-30 | https://github.com/NetworkBlockDevice/nbd/blob/master/doc/proto.md | |||
| bveapi | 10880 | tcp | BVEssentials HTTP API | Tri Tech Computers Ltd. | James Emerton | 2012-11-19 | |||||
| bveapi | 10880 | udp | BVEssentials HTTP API | Tri Tech Computers Ltd. | James Emerton | 2012-11-19 | |||||
| tcc-http | 24680 | tcp | TCC User HTTP Service | Brian Kennedy | Brian Kennedy | 2006-08 | |||||
| tcc-http | 24680 | udp | TCC User HTTP Service | Brian Kennedy | Brian Kennedy | 2006-08 | |||||
| timezone | tcp | Time Zone Data Distribution Service - non-TLS | IESG | IETF Chair | 2015-08-03 | RFC 7808 | This is an extension of the http service. Defined TXT keys: path=<context path> (as per Section 6 of RFC 6763). | ||||
| timezones | tcp | Time Zone Data Distribution Service - over TLS | IESG | IETF Chair | 2015-08-03 | RFC 7808 | This is an extension of the https service. Defined TXT keys: path=<context path> (as per Section 6 of RFC 6763). |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| 3GPP | dongwook.kim&etsi.org | 2026-01-23 | |
| Adrian Pell | PELL_ADRIAN/HP-UnitedKingdom_om6@hplb.hpl.hp.com | ||
| Brian Kennedy | BrianK&targetedconvergence.com | 2006-08 | |
| Chris Peel | chris.gsi&fullphat.net | 2014-05-16 | |
| Clay Maeckel | clay&claris.com | 2023-09-12 | |
| Dongwook Kim | 3GPP | dongwook.kim&etsi.org | 2026-01-23 |
| full phat products | chris.gsi&fullphat.net | 2019-08-08 | |
| IESG | iesg&ietf.org | ||
| IETF Chair | IETF | chair&ietf.org | |
| James Emerton | Tri Tech Computers Ltd. | james&tri-tech.com | 2012-11-19 |
| James Gettys | jg&w3.org | ||
| Jim Kateley | asr-dev&group.apple.com | 2006-01 | |
| Paul McGough | paulmcgough&yahoo.com | 2016-01-05 | |
| Paul Sterk | paul.sterk&sun.com | 2006-03 | |
| Peter Saint-Andre | stpeter&stpeter.im | 2009-11-25 | |
| Randall Stewart | IETF TSVWG | rrs&lakerest.net | |
| Ruwan Linton | ruwan&wso2.com | 2008-08-20 | |
| Shantonu Sen | ssen&apple.com | ||
| Stephen Casner | casner&precpt.com | ||
| Steve Hay | SteveHay&planit.com | 2008-06-13 | |
| Tim Berners-Lee | timbl&w3.org | ||
| Tri Tech Computers Ltd. | admins&tri-tech.com | 2012-11-19 | |
| Wouter Verhelst | w&uter.be | 2010-08-02 |