Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-26
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| https | 443 | tcp | http protocol over TLS/SSL | IESG | IETF Chair | 2021-10-01 | RFC 9110 | ||||
| https | 443 | udp | http protocol over TLS/SSL | IESG | IETF Chair | 2021-10-01 | RFC 9110 | ||||
| https | 443 | sctp | HTTPS | Randall Stewart | Randall Stewart | 2022-02-07 | RFC 9260 | ||||
| ipps | 631 | tcp | Internet Printing Protocol over HTTPS | IESG | IETF Chair | 2018-07-06 | RFC 8011 | ||||
| oob-ws-https | 664 | tcp | DMTF out-of-band secure web services management protocol | Jim Davis | Jim Davis | 2007-06 | |||||
| saphostctrls | 1129 | tcp | SAPHostControl over SOAP/HTTPS | Muscarella Fabrizio | Muscarella Fabrizio | 2006-04 | |||||
| saphostctrls | 1129 | udp | SAPHostControl over SOAP/HTTPS | Muscarella Fabrizio | Muscarella Fabrizio | 2006-04 | |||||
| llsurfup-https | 1184 | tcp | LL Surfup HTTPS | Katy Lynn McCullough | Katy Lynn McCullough | ||||||
| llsurfup-https | 1184 | udp | LL Surfup HTTPS | Katy Lynn McCullough | Katy Lynn McCullough | ||||||
| compaq-https | 2381 | tcp | Compaq HTTPS | Scott Shaffer | Scott Shaffer | ||||||
| compaq-https | 2381 | udp | Compaq HTTPS | Scott Shaffer | Scott Shaffer | ||||||
| wap-push-https | 4036 | tcp | WAP Push OTA-HTTP secure | Matthieu Lachance | Matthieu Lachance | ||||||
| wap-push-https | 4036 | udp | WAP Push OTA-HTTP secure | Matthieu Lachance | Matthieu Lachance | ||||||
| appserv-https | 4849 | tcp | App Server - Admin HTTPS | Sreeram Duvvuru | Sreeram Duvvuru | 2002-04 | |||||
| appserv-https | 4849 | udp | App Server - Admin HTTPS | Sreeram Duvvuru | Sreeram Duvvuru | 2002-04 | |||||
| spss | 5443 | tcp | Pearson HTTPS | Pearson | Pearson | 2008-01-17 | |||||
| spss | 5443 | udp | Pearson HTTPS | Pearson | Pearson | 2008-01-17 | |||||
| wbem-https | 5989 | tcp | WBEM CIM-XML (HTTPS) | Jim Davis | Jim Davis | ||||||
| wbem-https | 5989 | udp | WBEM CIM-XML (HTTPS) | Jim Davis | Jim Davis | ||||||
| wbem-exp-https | 5990 | tcp | WBEM Export HTTPS | Denise Eckstein | Denise Eckstein | 2004-11 | |||||
| wbem-exp-https | 5990 | udp | WBEM Export HTTPS | Denise Eckstein | Denise Eckstein | 2004-11 | |||||
| sun-sr-https | 6443 | tcp | Service Registry Default HTTPS Domain | Paul Sterk | Paul Sterk | 2006-03 | |||||
| sun-sr-https | 6443 | udp | Service Registry Default HTTPS Domain | Paul Sterk | Paul Sterk | 2006-03 | |||||
| plysrv-https | 6771 | tcp | PolyServe https | Mike Spitzer | Mike Spitzer | 2005-08 | |||||
| plysrv-https | 6771 | udp | PolyServe https | Mike Spitzer | Mike Spitzer | 2005-08 | |||||
| pon-ictp | 7202 | tcp | Inter-Channel Termination Protocol (ICTP) for multi-wavelength PON (Passive Optical Network) systems | Broadband Forum | Broadband Forum | 2017-02-22 | 2019-12-16 | TR-352; Inter-Channel-Termination protocol (ICTP) is a peer-to-peer protocol with a binary message format that is used by a set of optical line terminal (OLT) channel terminations (CT) comprising a 40-Gigabit-capable next-generation passive optical network (NG-PON2) system to exchange channel profile configuration and status information and to coordinate the operation of tunable optical network units (ONUs) in a multi-wavelength channel environment. | |||
| oracleas-https | 7443 | tcp | Oracle Application Server HTTPS | David McMarlin | David McMarlin | 2006-08 | |||||
| oracleas-https | 7443 | udp | Oracle Application Server HTTPS | David McMarlin | David McMarlin | 2006-08 | |||||
| sun-user-https | 7677 | tcp | Sun App Server - HTTPS | Abhijit Kumar | Abhijit Kumar | 2005-11 | |||||
| sun-user-https | 7677 | udp | Sun App Server - HTTPS | Abhijit Kumar | Abhijit Kumar | 2005-11 | |||||
| synapse-nhttps | 8243 | tcp | Synapse Non Blocking HTTPS | Ruwan Linton | Ruwan Linton | 2008-07-10 | |||||
| synapse-nhttps | 8243 | udp | Synapse Non Blocking HTTPS | Ruwan Linton | Ruwan Linton | 2008-07-10 | |||||
| pcsync-https | 8443 | tcp | PCsync HTTPS | ||||||||
| pcsync-https | 8443 | udp | PCsync HTTPS | ||||||||
| https-wmap | 8991 | tcp | webmail HTTPS service | Chris Newman | Chris Newman | 2007-12-03 | |||||
| https-wmap | 8991 | udp | webmail HTTPS service | Chris Newman | Chris Newman | 2007-12-03 | |||||
| armcenterhttps | 9295 | tcp | ARMCenter https Service | Eric Thiebaut-George | Eric Thiebaut-George | 2006-04 | |||||
| armcenterhttps | 9295 | udp | ARMCenter https Service | Eric Thiebaut-George | Eric Thiebaut-George | 2006-04 | |||||
| tungsten-https | 9443 | tcp | WSO2 Tungsten HTTPS | Afkham Azeez | Afkham Azeez | 2006-06 | |||||
| tungsten-https | 9443 | udp | WSO2 Tungsten HTTPS | Afkham Azeez | Afkham Azeez | 2006-06 | |||||
| wso2esb-console | 9444 | tcp | WSO2 ESB Administration Console HTTPS | Ruwan Linton | Ruwan Linton | 2008-08-20 | |||||
| wso2esb-console | 9444 | udp | WSO2 ESB Administration Console HTTPS | Ruwan Linton | Ruwan Linton | 2008-08-20 | |||||
| nbd | 10809 | tcp | Network Block Device | Wouter Verhelst | Wouter Verhelst | 2010-08-02 | 2024-04-30 | https://github.com/NetworkBlockDevice/nbd/blob/master/doc/proto.md | |||
| amt-soap-https | 16993 | tcp | Intel(R) AMT SOAP/HTTPS | David T. Hines | David T. Hines | 2005-02 | |||||
| amt-soap-https | 16993 | udp | Intel(R) AMT SOAP/HTTPS | David T. Hines | David T. Hines | 2005-02 | |||||
| commtact-https | 20003 | tcp | Commtact HTTPS | Tomas Svoboda | Tomas Svoboda | 2004-12 | |||||
| commtact-https | 20003 | udp | Commtact HTTPS | Tomas Svoboda | Tomas Svoboda | 2004-12 | |||||
| xahaud | 21337 | tcp | Xahau P2P network protocol | INFTF MTU | Bharath Chari | 2025-10-16 | https://xahau.network | ||||
| netconfsoaphttp | NETCONF for SOAP over HTTPS | RFC 4743; RFC 9900 | |||||||||
| boardgame | tcp | Two-player board game play | Tianren Chen | Tianren Chen | 2026-08-05 | https://github.com/chentianren0/MiniXiangqi/blob/main/docs/boardgame-protocol.md | Defined TXT keys: None | ||||
| bootstrap | tcp | Bootstrap service discovery | Pedro Garcia | Pedro Garcia | 2023-03-20 | Defined TXT keys: "url": if present, indicates a connection url (i.e. wss://example.com/bootstrap, or https://example.com/bootstrap) to be used by the device for bootstrapping; "namespace": identifies the underlying application-level protocol (should be unique for the application protocol, typically a UUID or a URN) | |||||
| bootstrap | udp | Bootstrap service discovery | Pedro Garcia | Pedro Garcia | 2023-03-20 | Defined TXT keys: "url": if present, indicates a connection url (i.e. wss://example.com/bootstrap, or https://example.com/bootstrap) to be used by the device for bootstrapping; "namespace": identifies the underlying application-level protocol (should be unique for the application protocol, typically a UUID or a URN) | |||||
| caldavs | tcp | Calendaring Extensions to WebDAV (CalDAV) - over TLS | IESG | IETF Chair | 2012-02-17 | RFC 6764 | This is an extension of the https service. Defined TXT keys: path=<context path> | ||||
| carddavs | tcp | vCard Extensions to WebDAV (CardDAV) - over TLS | IESG | IETF Chair | 2012-02-17 | RFC 6352 | This is an extension of the https service. Defined TXT keys: path=<context path> | ||||
| https | tcp | HTTP over SSL/TLS | Tim Berners-Lee | Tim Berners-Lee | Web browsers like Safari and Internet Explorer (with the Bonjour for Windows plugin) DO NOT browse for DNS-SD service type "_https._tcp" in addition to browsing for "_http._tcp". This is a conscious decision to reduce proliferation of service types, to help keep DNS-SD efficient on the network. Today, if a user types http://www.mybank.com/ into their web browser, the web server automatically redirects the user to https://www.mybank.com/. Rather than having an entirely different DNS-SD service type for https, we recommend using the same redirection mechanism: advertise a plain "http" service, which consists of nothing except an HTTP redirection to the desired "https" URL. Work is currently being done on adding mechanisms to HTTP and TLS to allow the server to tell the client that it needs to activate TLS on the current connection before proceeding. If this becomes widely adopted, it further justifies the decision to not create a separate DNS-SD service type "_https._tcp", because security becomes just another one of the things that is negotiated on a per-connection basis (like content-type negotiation today) rather than being an entirely separate thing. | ||||||
| meshcop | udp | Thread Mesh Commissioning | Thread Group, Inc. | Esko Dijk | 2020-11-20 | Defined TXT keys: Thread 1.1 Specification, Section 8.4.1.1.2. https://www.threadgroup.org/ThreadSpec | |||||
| meshcop-e | udp | Thread Mesh Commissioning Ephemeral-key | Thread Group, Inc. | Esko Dijk | 2024-01-22 | Defined TXT keys: TXT records keys, if any, will be defined in Section 8.12 of the Thread Specification. https://www.threadgroup.org/ThreadSpec | |||||
| mist | tcp | A Medical Interoperability Service Type, used to identify medical devices providing network interfaces. | Jon Griffeth | Jon Griffeth | 2017-01-12 | Defined TXT keys: https://www.praesentia.com/medkit/mist-service-type (dn dt md mf pr sn vn) | |||||
| pgpkey-https | PGP Keyserver using HTTPS | Jeroen Massar | Jeroen Massar | Defined TXT keys: path=<path on the server where the HKP applications reside> normally: "path=/pks/" | |||||||
| s2connect | tcp | S2 Connect energy management protocol | TNO | Wilco Wijbrandi | 2026-03-27 | Defined TXT Keys: https://docs.s2standard.org/docs/communication-layer/discovery-pairing-authentication/#dns-sd-based-discovery | |||||
| secugen-connect | tcp | SecuGen Connect local biometric bridge | SecuGen Corporation | SecuGen Corporation | 2026-09-04 | 2026-09-07 | https://connect.secugen.com/dev-guide-doc/bridge-api-contract | Defined TXT keys: None | |||
| sztp | tcp | This service name is used to construct the SRV service label "_sztp" for discovering SZTP bootstrap servers. | IESG | IETF Chair | 2019-01-17 | RFC 8572 | This protocol uses HTTPS as a substrate. | ||||
| timezones | tcp | Time Zone Data Distribution Service - over TLS | IESG | IETF Chair | 2015-08-03 | RFC 7808 | This is an extension of the https service. Defined TXT keys: path=<context path> (as per Section 6 of RFC 6763). | ||||
| vapix-http | tcp | Indicator for VAPIX support over HTTP | Axis Communications | Christian Storm | 2023-04-18 | Defined TXT keys: https://help.axis.com/en-us/axis-os#axis-bonjour-implementation | |||||
| vapix-https | tcp | Indicator for VAPIX support over HTTPS | Axis Communications | Christian Storm | 2023-04-18 | Defined TXT keys: https://help.axis.com/en-us/axis-os#axis-bonjour-implementation | |||||
| wdp | tcp | Windows Device Portal | Microsoft Corporation | Hirsch Singhal | 2016-03-03 | Defined TXT keys: D (device type), S (https port), A (architecture), T (tags) |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Abhijit Kumar | as-iana-ports&sun.com | 2005-11 | |
| Afkham Azeez | azeez&wso2.com | 2006-06 | |
| Axis Communications | christnn&axis.com | 2023-04-18 | |
| Bharath Chari | bharath&inftf.org | 2025-10-16 | |
| Broadband Forum | help&broadband-forum.org | 2020-03-17 | |
| Chris Newman | chris.newman&oracle.com | 2017-01-26 | |
| Christian Storm | Axis Communications | christnn&axis.com | 2023-04-18 |
| David McMarlin | david.mcmarlin&oracle.com | 2006-08 | |
| David T. Hines | david.hines&intel.com | 2005-02 | |
| Denise Eckstein | denise.eckstein&hp.com | 2004-11 | |
| Eric Thiebaut-George | erict&aurema.com | 2006-04 | |
| Esko Dijk | Thread Group, Inc. | esko.dijk&iotconsultancy.nl | 2024-01-22 |
| Hirsch Singhal | Microsoft Corporation | hirsinµsoft.com | 2016-03-03 |
| IESG | iesg&ietf.org | ||
| IETF Chair | IETF | chair&ietf.org | |
| INFTF MTU | bharath&inftf.org | 2025-10-16 | |
| Jeroen Massar | jeroen&unfix.org | ||
| Jim Davis | jim.davis&wbemsolutions.com | 2007-06 | |
| Jon Griffeth | griffeth&praesentia.com | 2017-01-12 | |
| Katy Lynn McCullough | KatyM&laplink.com | ||
| Matthieu Lachance | matthieu.lachance&openwave.com | ||
| Microsoft Corporation | hirsinµsoft.com | 2016-03-03 | |
| Mike Spitzer | mjs&polyserve.com | 2005-08 | |
| Muscarella Fabrizio | fabrizio.muscarella&sap.com | 2006-04 | |
| Paul Sterk | paul.sterk&sun.com | 2006-03 | |
| Pearson | chad.smith&pearson.com | 2008-01-17 | |
| Pedro Garcia | pedro.garcia&puzzle-star.com | 2023-03-20 | |
| Randall Stewart | IETF TSVWG | rrs&lakerest.net | |
| Ruwan Linton | ruwan&wso2.com | 2008-08-20 | |
| Scott Shaffer | scott.shaffer&hp.com | ||
| SecuGen Corporation | connect&secugen.com | 2026-09-04 | |
| Sreeram Duvvuru | sduv&sfbay.sun.com | 2002-04 | |
| Thread Group, Inc. | help&threadgroup.org | 2024-01-22 | |
| Tianren Chen | chentianren0&gmail.com | 2026-08-05 | |
| Tim Berners-Lee | timbl&w3.org | ||
| TNO | info&tno.nl | 2026-03-27 | |
| Tomas Svoboda | svoboda&infima.cz | 2004-12 | |
| Wilco Wijbrandi | wilco.wijbrandi&tno.nl | 2026-03-27 | |
| Wouter Verhelst | w&uter.be | 2010-08-02 |