Service Name and Transport Protocol Port Number Registry

Last Updated
2026-10-09
Expert(s)
TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell,
and Michael Scharf
SCTP: Michael Tuexen
DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
[RFC 6335]
Note
Service names and port numbers are used to distinguish between different
services that run over transport protocols such as TCP, UDP, DCCP, and
SCTP.

Service names are assigned on a first-come, first-served process, as
documented in [RFC 6335].

Port numbers are assigned in various ways, based on three ranges: System
Ports (0-1023), User Ports (1024-49151), and the Dynamic and/or Private
Ports (49152-65535); the different uses of these ranges are described in
[RFC 6335]. According to Section 8.1.2 of [RFC 6335], System Ports are 
assigned by the "IETF Review" or "IESG Approval" procedures described in 
[RFC 8126]. User Ports are assigned by IANA using the "IETF Review" process, 
the "IESG Approval" process, or the "Expert Review" process, as per 
[RFC 6335]. Dynamic Ports are not assigned.

The registration procedures for service names and port numbers are
described in [RFC 6335].

Assigned ports both System and User ports SHOULD NOT be used without
or prior to IANA registration.

************************************************************************
* PLEASE NOTE THE FOLLOWING:                                           *
*                                                                      *
* ASSIGNMENT OF A PORT NUMBER DOES NOT IN ANY WAY IMPLY AN             *
* ENDORSEMENT OF AN APPLICATION OR PRODUCT, AND THE FACT THAT NETWORK  *
* TRAFFIC IS FLOWING TO OR FROM A REGISTERED PORT DOES NOT MEAN THAT   *
* IT IS "GOOD" TRAFFIC, NOR THAT IT NECESSARILY CORRESPONDS TO THE     *
* ASSIGNED SERVICE. FIREWALL AND SYSTEM ADMINISTRATORS SHOULD          *
* CHOOSE HOW TO CONFIGURE THEIR SYSTEMS BASED ON THEIR KNOWLEDGE OF    *
* THE TRAFFIC IN QUESTION, NOT WHETHER THERE IS A PORT NUMBER          *
* REGISTERED OR NOT.                                                   *
************************************************************************

Request an Assignment
  [https://www.iana.org/protocols/apply]

Available Formats

CSV

XML

HTML

TXT
Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
nfsd-keepalive 1110 udp Client status info [Beth_Crespo] [Beth_Crespo]
picknfs 1598 tcp picknfs [John_Lombardo] [John_Lombardo]
picknfs 1598 udp picknfs [John_Lombardo] [John_Lombardo]
shiva-confsrvr 1651 tcp shiva_confsrvr

IANA assigned this well-formed service name as a replacement for "shiva_confsrvr".
[Mike_Horowitz] [Mike_Horowitz]
shiva_confsrvr 1651 tcp shiva_confsrvr [Mike_Horowitz] [Mike_Horowitz] This entry is an alias to "shiva-confsrvr". This entry is now historic, not usable for use with many common service discovery mechanisms.
shiva-confsrvr 1651 udp shiva_confsrvr

IANA assigned this well-formed service name as a replacement for "shiva_confsrvr".
[Mike_Horowitz] [Mike_Horowitz]
shiva_confsrvr 1651 udp shiva_confsrvr [Mike_Horowitz] [Mike_Horowitz] This entry is an alias to "shiva-confsrvr". This entry is now historic, not usable for use with many common service discovery mechanisms.
nfs 2049 tcp Network File System - Sun Microsystems [Brent_Callaghan] [Brent_Callaghan] Defined TXT keys: path=<path to mount point>
nfs 2049 udp Network File System - Sun Microsystems [Brent_Callaghan] [Brent_Callaghan] Defined TXT keys: path=<path to mount point>
nfs 2049 sctp Network File System [RFC 5665] Defined TXT keys: path=<path to mount point>
3d-nfsd 2323 tcp 3d-nfsd [Mike_Sherrill] [Mike_Sherrill]
3d-nfsd 2323 udp 3d-nfsd [Mike_Sherrill] [Mike_Sherrill]
mediacntrlnfsd 2363 tcp Media Central NFSD [Shivakumar_S_Govind] [Shivakumar_S_Govind]
mediacntrlnfsd 2363 udp Media Central NFSD [Shivakumar_S_Govind] [Shivakumar_S_Govind]
winfs 5009 tcp Microsoft Windows Filesystem [Simon_Skaria] [Simon_Skaria] 2006-01
winfs 5009 udp Microsoft Windows Filesystem [Simon_Skaria] [Simon_Skaria] 2006-01
enfs 5233 tcp Etinnae Network File Service [Chris_Peel] [Chris_Peel] 2011-03-09
mountd 20048 tcp NFS mount protocol [Nicolas_Williams] [Nicolas_Williams] 2010-08-09
mountd 20048 udp NFS mount protocol [Nicolas_Williams] [Nicolas_Williams] 2010-08-09
nfsrdma 20049 tcp Network File System (NFS) over RDMA 2017-09-05 [RFC 8267]
nfsrdma 20049 udp Network File System (NFS) over RDMA 2017-09-05 [RFC 8267]
nfsrdma 20049 sctp Network File System (NFS) over RDMA 2017-09-05 [RFC 8267]
netconfsoapbeep NETCONF for SOAP over BEEP [RFC 4743][RFC 9900]
netconfsoaphttp NETCONF for SOAP over HTTPS [RFC 4743][RFC 9900]
nfs-domainroot tcp NFS service for the domain root, the root of an organization's published file namespace. [IESG] [IETF_Chair] 2012-04-24 [RFC 6641] Defined TXT keys: None
sessionfs Session File Sharing [Anthony_Williams] [Anthony_Williams] Defined TXT keys: Text keys are the file extensions of any file the user plans to share, i.e. pdf, doc, mp3.

Contact Information

ID Name Organization Contact URI Last Updated
[Anthony_Williams] Anthony Williams mailto:tonydubs&gmail.com
[Beth_Crespo] Beth Crespo mailto:beth.crespo&hp.com
[Brent_Callaghan] Brent Callaghan mailto:brent&terra.eng.sun.com
[Chris_Peel] Chris Peel mailto:chrispeel.gsi&googlemail.com 2011-03-09
[IESG] IESG mailto:iesg&ietf.org
[IETF_Chair] IETF Chair IETF mailto:chair&ietf.org
[John_Lombardo] John Lombardo mailto:johnl&picksys.com
[Mike_Horowitz] Mike Horowitz mailto:mah&shiva.com
[Mike_Sherrill] Mike Sherrill mailto:sherrill&commvault.com
[Nicolas_Williams] Nicolas Williams mailto:Nicolas.Williams&oracle.com 2010-08-09
[Shivakumar_S_Govind] Shivakumar S. Govindarajapuram mailto:shivak&eng.sun.com
[Simon_Skaria] Simon Skaria mailto:simonsk&microsoft.com 2006-01