Service Name and Transport Protocol Port Number Registry

Last Updated
2026-10-09
Expert(s)
TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell,
and Michael Scharf
SCTP: Michael Tuexen
DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
[RFC 6335]
Note
Service names and port numbers are used to distinguish between different
services that run over transport protocols such as TCP, UDP, DCCP, and
SCTP.

Service names are assigned on a first-come, first-served process, as
documented in [RFC 6335].

Port numbers are assigned in various ways, based on three ranges: System
Ports (0-1023), User Ports (1024-49151), and the Dynamic and/or Private
Ports (49152-65535); the different uses of these ranges are described in
[RFC 6335]. According to Section 8.1.2 of [RFC 6335], System Ports are 
assigned by the "IETF Review" or "IESG Approval" procedures described in 
[RFC 8126]. User Ports are assigned by IANA using the "IETF Review" process, 
the "IESG Approval" process, or the "Expert Review" process, as per 
[RFC 6335]. Dynamic Ports are not assigned.

The registration procedures for service names and port numbers are
described in [RFC 6335].

Assigned ports both System and User ports SHOULD NOT be used without
or prior to IANA registration.

************************************************************************
* PLEASE NOTE THE FOLLOWING:                                           *
*                                                                      *
* ASSIGNMENT OF A PORT NUMBER DOES NOT IN ANY WAY IMPLY AN             *
* ENDORSEMENT OF AN APPLICATION OR PRODUCT, AND THE FACT THAT NETWORK  *
* TRAFFIC IS FLOWING TO OR FROM A REGISTERED PORT DOES NOT MEAN THAT   *
* IT IS "GOOD" TRAFFIC, NOR THAT IT NECESSARILY CORRESPONDS TO THE     *
* ASSIGNED SERVICE. FIREWALL AND SYSTEM ADMINISTRATORS SHOULD          *
* CHOOSE HOW TO CONFIGURE THEIR SYSTEMS BASED ON THEIR KNOWLEDGE OF    *
* THE TRAFFIC IN QUESTION, NOT WHETHER THERE IS A PORT NUMBER          *
* REGISTERED OR NOT.                                                   *
************************************************************************

Request an Assignment
  [https://www.iana.org/protocols/apply]

Available Formats

CSV

XML

HTML

TXT
Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
35 tcp any private printer server [Jon_Postel] [Jon_Postel]
35 udp any private printer server [Jon_Postel] [Jon_Postel]
www-http 80 tcp World Wide Web HTTP [Tim_Berners_Lee] [Tim_Berners_Lee] This is a duplicate of the "http" service and should not be used for discovery purposes. u=<username> p=<password> path=<path to document> (see txtrecords.html#http) Known Subtypes: _printer NOTE: The meaning of this service type, though called just "http", actually denotes something more precise than just "any data transported using HTTP". The DNS-SD service type "http" should only be used to advertise content that: * is served over HTTP, * can be displayed by "typical" web browser client software, and * is intented primarily to be viewed by a human user. Of course, the definition of "typical web browser" is subjective, and may change over time, but for practical purposes the DNS-SD service type "http" can be understood as meaning "human-readable HTML content served over HTTP". In some cases other widely-supported content types may also be appropriate, such as plain text over HTTP, or JPEG image over HTTP. Content types not intented primarily for viewing by a human user, or not widely-supported in web browsing clients, should not be advertised as DNS-SD service type "http", even if they do happen to be transported over HTTP. Such types should be advertised as their own logical service type with their own DNS-SD service type, for example, XUL (XML User Interface Language) transported over HTTP is advertised explicitly as DNS-SD service type "xul-http".
www-http 80 udp World Wide Web HTTP [Tim_Berners_Lee] [Tim_Berners_Lee] This is a duplicate of the "http" service and should not be used for discovery purposes. u=<username> p=<password> path=<path to document> (see txtrecords.html#http) Known Subtypes: _printer NOTE: The meaning of this service type, though called just "http", actually denotes something more precise than just "any data transported using HTTP". The DNS-SD service type "http" should only be used to advertise content that: * is served over HTTP, * can be displayed by "typical" web browser client software, and * is intented primarily to be viewed by a human user. Of course, the definition of "typical web browser" is subjective, and may change over time, but for practical purposes the DNS-SD service type "http" can be understood as meaning "human-readable HTML content served over HTTP". In some cases other widely-supported content types may also be appropriate, such as plain text over HTTP, or JPEG image over HTTP. Content types not intented primarily for viewing by a human user, or not widely-supported in web browsing clients, should not be advertised as DNS-SD service type "http", even if they do happen to be transported over HTTP. Such types should be advertised as their own logical service type with their own DNS-SD service type, for example, XUL (XML User Interface Language) transported over HTTP is advertised explicitly as DNS-SD service type "xul-http".
printer 515 tcp spooler
printer 515 udp spooler
kme-trap-port 2081 tcp KME PRINTER TRAP PORT [Masakatsu_Matsuo] [Masakatsu_Matsuo]
kme-trap-port 2081 udp KME PRINTER TRAP PORT [Masakatsu_Matsuo] [Masakatsu_Matsuo]
eapsp 2291 tcp EPSON Advanced Printer Share Protocol [SEIKO_EPSON] [SEIKO_EPSON] 2006-06
eapsp 2291 udp EPSON Advanced Printer Share Protocol [SEIKO_EPSON] [SEIKO_EPSON] 2006-06
printer-agent 3396 tcp Printer Agent

IANA assigned this well-formed service name as a replacement for "printer_agent".
[Devon_Taylor] [Devon_Taylor]
printer_agent 3396 tcp Printer Agent [Devon_Taylor] [Devon_Taylor] This entry is an alias to "printer-agent". This entry is now historic, not usable for use with many common service discovery mechanisms.
printer-agent 3396 udp Printer Agent

IANA assigned this well-formed service name as a replacement for "printer_agent".
[Devon_Taylor] [Devon_Taylor]
printer_agent 3396 udp Printer Agent [Devon_Taylor] [Devon_Taylor] This entry is an alias to "printer-agent". This entry is now historic, not usable for use with many common service discovery mechanisms.
prnrequest 3910 tcp Printer Request Port [Brett_Green] [Brett_Green] 2003-11
prnrequest 3910 udp Printer Request Port [Brett_Green] [Brett_Green] 2003-11
prnstatus 3911 tcp Printer Status Port [Brett_Green] [Brett_Green] 2003-11
prnstatus 3911 udp Printer Status Port [Brett_Green] [Brett_Green] 2003-11
jprinter 5309 tcp J Printer [Ken_Blackwell] [Ken_Blackwell]
jprinter 5309 udp J Printer [Ken_Blackwell] [Ken_Blackwell]
canon-cpp-disc 8609 udp Canon Compact Printer Protocol Discovery [Canon_Inc] [Ryusuke_Okuhara] 2012-06-08 2012-06-15
pdl-datastream 9100 tcp Printer PDL Data Stream [Stuart_Cheshire_4] [Stuart_Cheshire_4] 2002-09 The protocol name "pdl-datastream" is primarily registered for use in DNS SRV records (RFC 2782). DNS SRV records allow a protocol to run on any port number, but the default port for this protocol is 9100.
pdl-datastream 9100 udp Printer PDL Data Stream [Stuart_Cheshire_4] [Stuart_Cheshire_4] 2002-09 The protocol name "pdl-datastream" is primarily registered for use in DNS SRV records (RFC 2782). DNS SRV records allow a protocol to run on any port number, but the default port for this protocol is 9100.
riousbprint Remote I/O USB Printer Protocol [Rob_Newberry] [Rob_Newberry] Defined TXT keys: See BonjourPrinting.pdf.

Contact Information

ID Name Organization Contact URI Last Updated
[Brett_Green] Brett Green mailto:brett_green&hp.com 2003-11
[Canon_Inc] Canon Inc. mailto:fujii.ken-ichi149&canon.co.jp 2011-10-10
[Devon_Taylor] Devon Taylor mailto:dtaylor&novell.com
[Jon_Postel] Jon Postel mailto:postel&isi.edu
[Ken_Blackwell] Ken Blackwell mailto:kenb&bristol.com
[Masakatsu_Matsuo] Masakatsu Matsuo mailto:masa&sdsft.kme.mei.co.jp
[Rob_Newberry] Rob Newberry mailto:rnewberry&apple.com
[Ryusuke_Okuhara] Ryusuke Okuhara Canon Inc. mailto:okuhara.ryuusuke&canon.co.jp 2012-06-08
[SEIKO_EPSON] SEIKO EPSON mailto:APD.admin&exc.epson.co.jp 2006-06
[Stuart_Cheshire_4] Stuart Cheshire mailto:pdl-datastream&apple.com 2002-09
[Tim_Berners_Lee] Tim Berners-Lee mailto:timbl&w3.org