Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-27
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| telnet | 23 | tcp | Telnet | Jon Postel | Jon Postel | RFC 854 | Defined TXT keys: u=<username> p=<password> | ||||
| telnet | 23 | udp | Telnet | Jon Postel | Jon Postel | RFC 854 | Defined TXT keys: u=<username> p=<password> | ||||
| su-mit-tg | 89 | tcp | SU/MIT Telnet Gateway | Mark Crispin | Mark Crispin | ||||||
| su-mit-tg | 89 | udp | SU/MIT Telnet Gateway | Mark Crispin | Mark Crispin | ||||||
| rtelnet | 107 | tcp | Remote Telnet Service | Jon Postel | Jon Postel | ||||||
| rtelnet | 107 | udp | Remote Telnet Service | Jon Postel | Jon Postel | ||||||
| login | 513 | tcp | remote login a la telnet; automatic authentication performed based on priviledged port numbers and distributed data bases which identify "authentication domains" | ||||||||
| ideafarm-door | 902 | tcp | self documenting Telnet Door | ||||||||
| ideafarm-panic | 903 | tcp | self documenting Telnet Panic Door | Wo'o Ideafarm | Wo'o Ideafarm | ||||||
| telnets | 992 | tcp | telnet protocol over TLS/SSL | ||||||||
| telnets | 992 | udp | telnet protocol over TLS/SSL | ||||||||
| skytelnet | 1618 | tcp | skytelnet | Byron Jones | Byron Jones | ||||||
| skytelnet | 1618 | udp | skytelnet | Byron Jones | Byron Jones | ||||||
| hp-3000-telnet | 2564 | tcp | HP 3000 NS/VT block mode telnet | ||||||||
| hp-3000-telnet | 2564 | udp | HP 3000 NS/VT block mode telnet | ||||||||
| tl1-telnet | 3083 | tcp | TL1-TELNET | SONET Internetworking Forum (SIF) | SONET Internetworking Forum (SIF) | ||||||
| tl1-telnet | 3083 | udp | TL1-TELNET | SONET Internetworking Forum (SIF) | SONET Internetworking Forum (SIF) | ||||||
| telnetcpcd | 3696 | tcp | Telnet Com Port Control | Thomas J. Pinkl | Thomas J. Pinkl | 2003-02 | |||||
| telnetcpcd | 3696 | udp | Telnet Com Port Control | Thomas J. Pinkl | Thomas J. Pinkl | 2003-02 | |||||
| scpi-telnet | 5024 | tcp | SCPI-TELNET | Interchangeable Virtual Instruments Foundation, Inc. | Larry Ostheimer | 2021-05-06 | |||||
| scpi-telnet | 5024 | udp | SCPI-TELNET | Interchangeable Virtual Instruments Foundation, Inc. | Larry Ostheimer | 2021-05-06 | |||||
| ktelnet | 6623 | tcp | Kerberos V5 Telnet | Robert J. Scott | Robert J. Scott | 2005-08 | |||||
| ktelnet | 6623 | udp | Kerberos V5 Telnet | Robert J. Scott | Robert J. Scott | 2005-08 | |||||
| scpi-telnet | IEEE 488.2 (SCPI) Telnet | Nick Barendt | Nick Barendt | Defined TXT keys: None |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Byron Jones | byronj&bellsouth.net | ||
| Interchangeable Virtual Instruments Foundation, Inc. | ivi.contact&ivifoundation.org | 2021-05-06 | |
| Jon Postel | postel&isi.edu | ||
| Larry Ostheimer | larry_ostheimer&keysight.com | 2021-05-06 | |
| Mark Crispin | MRC&panda.com | ||
| Nick Barendt | nbarendt&vxitech.com | ||
| Robert J. Scott | rob&hpcmo.hpc.mil | 2005-08 | |
| SONET Internetworking Forum (SIF) | bwarijsman&lucent.com | ||
| Thomas J. Pinkl | tom&pinkl.com | 2003-02 | |
| Wo'o Ideafarm | b85f3c23.9ad6f42c&ideafarm.com |