Armenian
Root Zone Label Generation Rules, 5th Edition
Summary
| Version | 5 — Root Zone LGR for the Armenian Script |
|---|---|
| Date | |
| Tag |
und-Armn (Armenian)
|
| Unicode | 11.0.0 |
| Scope | DNS root zone |
| Source file | rz-lgr-5-armenian-script-26may22-en.xml (31.6kb) |
Description
Root Zone Label Generation Rules for the Armenian Script
Overview
This file contains Label Generation Rules (LGR) for the Armenian script for the Root Zone. For more details on this LGR and additional background on the script, see “Proposal for a Armenian Script Root Zone LGR” [Proposal-Armenian]. This file is one of a set of LGR files that together form an integrated LGR for the DNS Root Zone [RZ-LGR-5]. The format of this file follows [RFC 7940].
Repertoire
According to [Proposal-Armenian], the repertoire of 38 code points is based on [MSR-5], which is a subset of [Unicode 11.0]. The range of permissible code points is U+0561–U+0586 and supports the Armenian language as written in the Armenian script.
Note that U+0587 is not included in the repertoire because it is DISALLOWED in IDNA2008 [RFC 5892] and therefore not permissible in IDNs.
Read the rest of the description Show less
Code points outside this range that are listed in this file are targets for out-of-script variants and are identified by a reflexive (identity) variant of type “out-of-repertoire-var”. They do not form part of the repertoire.
As part of the Root Zone, this LGR includes neither decimal digits nor the HYPHEN-MINUS.
Each code point is tagged with the script or scripts with which the code point is used, and one or more references documenting sufficient justification for inclusion in the repertoire; see “References” below. For code points that are part of the repertoire, comments identify the languages using the code point.
Variants
According to Section 6, “Variants” in [Proposal-Armenian], there are no variants defined within the Armenian script. However, integration with the Latin and Greek LGRs does introduce some in-script variants due to cross-script variant transitivity.
In particular, the Armenian LGR inherits the following in-script variant as result of integration:
- Blocked: U+0572 — U+0578.
Additional Variants: This LGR inherits additional blocked cross-script variants by integration; they may not be listed here unless they result in in-script variants. However, for consistency, the variant mappings among the related scripts Armenian, Cyrillic, Greek and Latin are listed in full. See the merged, Common LGR [RZ-LGR-5] for details of all applicable cross-script variants, including any not listed here; always use the Common LGR for determining cross-script collisions of labels.
Where homoglyphs or near homoglyphs with Armenian code points exist in the Latin, Greek and Cyrillic scripts, out-of-repertoire variants are defined with a comment “Cross-script homoglyph” or “Cross-script near homoglyph” respectively. As result of integration, including the effecs of cross-script transitivity, the number of cross-script variants listed for these scripts is larger than defined in Section 6, “Variants” in [Proposal-Armenian]. These are generally not marked.
Variant Disposition: All variants are of type “blocked”, making labels that differ only by these variants mutually exclusive: whichever label containing either of these variants is chosen earlier would be delegated, while any other equivalent labels should be blocked.
This LGR does not define allocatable variants.
The specification of variants in the Root Zone LGR follows the guidelines in [RFC 8228].
Character Classes
The LGR does not define character classes.
Whole Label Evaluation (WLE) and Context Rules
Default Whole Label Evaluation Rules and Actions
The LGR includes the set of required default WLE rules and actions applicable to the Root Zone and defined in [MSR-5]. They are marked with ⍟.
Armenian-specific Rules
This LGR does not define rules specific to Armenian.
Methodology and Contributors
The Root Zone LGR for the Armenian script was developed by the Armenian Generation Panel. For methodology and contributors, see Sections 4 and 8 of [Proposal-Armenian], as well as [RZ-LGR-5-Overview]. After initial review by the Integration Panel, this LGR was deferred until it could be considered in the context of all related scripts. The LGR has been updated to reflect inherited variants resulting from integration.
References
The following general references are cited in this document:
- [MSR-5]
- Integration Panel, “Maximal Starting Repertoire — MSR-5 Overview and Rationale”, 24 June 2021, https://www.icann.org/en/system/files/files/msr-5-overview-24jun21-en.pdf
- [Proposal-Armenian]
- Armenian Generation Panel, “Proposal for an Armenian Script Root Zone LGR”, 5 November 2015, https://www.icann.org/en/system/files/files/armenian-lgr-proposal-05nov15-en.pdf
- [RFC 5892]
- Faltstrom, P., Ed., “The Unicode Code Points and Internationalized Domain Names for Applications (IDNA)”, RFC 5892, Autust 2010, https://www.rfc-editor.org/info/rfc5892
- [RFC 7940]
- Davies, K. and A. Freytag, “Representing Label Generation Rulesets Using XML”, RFC 7940, August 2016, https://www.rfc-editor.org/info/rfc7940
- [RFC 8228]
- A. Freytag, “Guidance on Designing Label Generation Rulesets (LGRs) Supporting Variant Labels”, RFC 8228, August 2017, https://www.rfc-editor.org/info/rfc8228
- [RZ-LGR-5-Overview]
- Integration Panel, “Root Zone Label Generation Rules (RZ LGR-5): Overview and Summary”, 26 May 2022, https://www.icann.org/sites/default/files/lgr/rz-lgr-5-overview-26may22-en.pdf
- [RZ-LGR-5]
- Integration Panel, “Root Zone Label Generation Rules (RZ-LGR-5)”, 26 May 2022 (XML), https://www.icann.org/sites/default/files/lgr/rz-lgr-5-common-26may22-en.xml
non-normative HTML presentation: https://www.icann.org/sites/default/files/lgr/rz-lgr-5-common-26may22-en.html - [Unicode 11.0]
- The Unicode Consortium. The Unicode Standard, Version 11.0.0, (Mountain View, CA: The Unicode Consortium, 2018. ISBN 978-1-936213-19-1) https://www.unicode.org/versions/Unicode11.0.0/
For references consulted particularly in designing the repertoire for the Armenian script for the Root Zone please see details in the Table of References below. Reference [0] refers to the Unicode Standard version in which corresponding code points were initially encoded. Reference [100] corresponds to a source given in [Proposal-Armenian] for justifying the inclusion of the corresponding code points. Entries in the table may have multiple source reference values.
Repertoire
| Glyph | Code point | Tags and context | Variants |
|---|---|---|---|
| g | U+0067 LATIN SMALL LETTER G 0 Not part of repertoire |
|
ց
U+0581
blocked
Cross-script near homoglyph
|
| h | U+0068 LATIN SMALL LETTER H 0 Not part of repertoire |
|
һ
U+04BB
blocked
հ
U+0570
blocked
Cross-script near homoglyph
|
| i | U+0069 LATIN SMALL LETTER I 0 Not part of repertoire |
|
í
U+00ED
blocked
ï
U+00EF
blocked
ı
U+0131
blocked
ɩ
U+0269
blocked
ΐ
U+0390
blocked
ί
U+03AF
blocked
+6 more
|
| n | U+006E LATIN SMALL LETTER N 0 Not part of repertoire |
|
ń
U+0144
blocked
ŋ
U+014B
blocked
ή
U+03AE
blocked
η
U+03B7
blocked
ղ
U+0572
blocked
ո
U+0578
blocked
Cross-script near homoglyph
+1 more
|
| o | U+006F LATIN SMALL LETTER O 0 Not part of repertoire |
|
ó
U+00F3
blocked
ο
U+03BF
blocked
ό
U+03CC
blocked
о
U+043E
blocked
Cross-script homoglyph
օ
U+0585
blocked
Cross-script homoglyph
|
| q | U+0071 LATIN SMALL LETTER Q 0 Not part of repertoire |
|
զ
U+0566
blocked
Cross-script near homoglyph
|
| u | U+0075 LATIN SMALL LETTER U 0 Not part of repertoire |
|
ú
U+00FA
blocked
ü
U+00FC
blocked
ʋ
U+028B
blocked
ΰ
U+03B0
blocked
υ
U+03C5
blocked
ϋ
U+03CB
blocked
+2 more
|
| í | U+00ED LATIN SMALL LETTER I WITH ACUTE 0 Not part of repertoire |
|
i
U+0069
blocked
ï
U+00EF
blocked
ı
U+0131
blocked
ɩ
U+0269
blocked
ΐ
U+0390
blocked
ί
U+03AF
blocked
+6 more
|
| ï | U+00EF LATIN SMALL LETTER I WITH DIAERESIS 0 Not part of repertoire |
|
i
U+0069
blocked
í
U+00ED
blocked
ı
U+0131
blocked
ɩ
U+0269
blocked
ΐ
U+0390
blocked
ί
U+03AF
blocked
+6 more
|
| ó | U+00F3 LATIN SMALL LETTER O WITH ACUTE 0 Not part of repertoire |
|
o
U+006F
blocked
ο
U+03BF
blocked
ό
U+03CC
blocked
о
U+043E
blocked
օ
U+0585
blocked
|
| ú | U+00FA LATIN SMALL LETTER U WITH ACUTE 0 Not part of repertoire |
|
u
U+0075
blocked
ü
U+00FC
blocked
ʋ
U+028B
blocked
ΰ
U+03B0
blocked
υ
U+03C5
blocked
ϋ
U+03CB
blocked
+2 more
|
| ü | U+00FC LATIN SMALL LETTER U WITH DIAERESIS 0 Not part of repertoire |
|
u
U+0075
blocked
ú
U+00FA
blocked
ʋ
U+028B
blocked
ΰ
U+03B0
blocked
υ
U+03C5
blocked
ϋ
U+03CB
blocked
+2 more
|
| ı | U+0131 LATIN SMALL LETTER DOTLESS I 0 Not part of repertoire |
|
i
U+0069
blocked
í
U+00ED
blocked
ï
U+00EF
blocked
ɩ
U+0269
blocked
ΐ
U+0390
blocked
ί
U+03AF
blocked
+6 more
|
| ń | U+0144 LATIN SMALL LETTER N WITH ACUTE 0 Not part of repertoire |
|
n
U+006E
blocked
ŋ
U+014B
blocked
ή
U+03AE
blocked
η
U+03B7
blocked
ղ
U+0572
blocked
ո
U+0578
blocked
+1 more
|
| ŋ | U+014B LATIN SMALL LETTER ENG 0 Not part of repertoire |
|
n
U+006E
blocked
ń
U+0144
blocked
ή
U+03AE
blocked
η
U+03B7
blocked
ղ
U+0572
blocked
ո
U+0578
blocked
+1 more
|
| ɩ | U+0269 LATIN SMALL LETTER IOTA 0 Not part of repertoire |
|
i
U+0069
blocked
í
U+00ED
blocked
ï
U+00EF
blocked
ı
U+0131
blocked
ΐ
U+0390
blocked
ί
U+03AF
blocked
+6 more
|
| ʋ | U+028B LATIN SMALL LETTER V WITH HOOK 0 Not part of repertoire |
|
u
U+0075
blocked
ú
U+00FA
blocked
ü
U+00FC
blocked
ΰ
U+03B0
blocked
υ
U+03C5
blocked
ϋ
U+03CB
blocked
+2 more
|
| ΐ | U+0390 GREEK SMALL LETTER IOTA WITH DIALYTIKA AND TONOS 0 Not part of repertoire |
|
i
U+0069
blocked
í
U+00ED
blocked
ï
U+00EF
blocked
ı
U+0131
blocked
ɩ
U+0269
blocked
ί
U+03AF
blocked
+6 more
|
| ή | U+03AE GREEK SMALL LETTER ETA WITH TONOS 0 Not part of repertoire |
|
n
U+006E
blocked
ń
U+0144
blocked
ŋ
U+014B
blocked
η
U+03B7
blocked
ղ
U+0572
blocked
ո
U+0578
blocked
+1 more
|
| ί | U+03AF GREEK SMALL LETTER IOTA WITH TONOS 0 Not part of repertoire |
|
i
U+0069
blocked
í
U+00ED
blocked
ï
U+00EF
blocked
ı
U+0131
blocked
ɩ
U+0269
blocked
ΐ
U+0390
blocked
+6 more
|
| ΰ | U+03B0 GREEK SMALL LETTER UPSILON WITH DIALYTIKA AND TONOS 0 Not part of repertoire |
|
u
U+0075
blocked
ú
U+00FA
blocked
ü
U+00FC
blocked
ʋ
U+028B
blocked
υ
U+03C5
blocked
ϋ
U+03CB
blocked
+2 more
|
| η | U+03B7 GREEK SMALL LETTER ETA 0 Not part of repertoire |
|
n
U+006E
blocked
ń
U+0144
blocked
ŋ
U+014B
blocked
Cross-script near homoglyph
ή
U+03AE
blocked
ղ
U+0572
blocked
Cross-script near homoglyph
ո
U+0578
blocked
Cross-script near homoglyph
+1 more
|
| ι | U+03B9 GREEK SMALL LETTER IOTA 0 Not part of repertoire |
|
i
U+0069
blocked
í
U+00ED
blocked
ï
U+00EF
blocked
ı
U+0131
blocked
ɩ
U+0269
blocked
ΐ
U+0390
blocked
+6 more
|
| ο | U+03BF GREEK SMALL LETTER OMICRON 0 Not part of repertoire |
|
o
U+006F
blocked
Cross-script homoglyph
ó
U+00F3
blocked
ό
U+03CC
blocked
о
U+043E
blocked
Cross-script homoglyph
օ
U+0585
blocked
Cross-script homoglyph
|
| υ | U+03C5 GREEK SMALL LETTER UPSILON 0 Not part of repertoire |
|
u
U+0075
blocked
ú
U+00FA
blocked
ü
U+00FC
blocked
ʋ
U+028B
blocked
ΰ
U+03B0
blocked
ϋ
U+03CB
blocked
+2 more
|
| ϊ | U+03CA GREEK SMALL LETTER IOTA WITH DIALYTIKA 0 Not part of repertoire |
|
i
U+0069
blocked
í
U+00ED
blocked
ï
U+00EF
blocked
ı
U+0131
blocked
ɩ
U+0269
blocked
ΐ
U+0390
blocked
+6 more
|
| ϋ | U+03CB GREEK SMALL LETTER UPSILON WITH DIALYTIKA 0 Not part of repertoire |
|
u
U+0075
blocked
ú
U+00FA
blocked
ü
U+00FC
blocked
ʋ
U+028B
blocked
ΰ
U+03B0
blocked
υ
U+03C5
blocked
+2 more
|
| ό | U+03CC GREEK SMALL LETTER OMICRON WITH TONOS 0 Not part of repertoire |
|
o
U+006F
blocked
ó
U+00F3
blocked
ο
U+03BF
blocked
о
U+043E
blocked
օ
U+0585
blocked
|
| ύ | U+03CD GREEK SMALL LETTER UPSILON WITH TONOS 0 Not part of repertoire |
|
u
U+0075
blocked
ú
U+00FA
blocked
ü
U+00FC
blocked
ʋ
U+028B
blocked
ΰ
U+03B0
blocked
υ
U+03C5
blocked
+2 more
|
| о | U+043E CYRILLIC SMALL LETTER O 0 Not part of repertoire |
|
o
U+006F
blocked
Cross-script homoglyph
ó
U+00F3
blocked
ο
U+03BF
blocked
ό
U+03CC
blocked
օ
U+0585
blocked
Cross-script homoglyph
|
| ш | U+0448 CYRILLIC SMALL LETTER SHA 0 Not part of repertoire |
|
ա
U+0561
blocked
Cross-script homoglyph
|
| і | U+0456 CYRILLIC SMALL LETTER BYELORUSSIAN-UKRAINIAN I 0 Not part of repertoire |
|
i
U+0069
blocked
í
U+00ED
blocked
ï
U+00EF
blocked
ı
U+0131
blocked
ɩ
U+0269
blocked
ΐ
U+0390
blocked
+6 more
|
| ї | U+0457 CYRILLIC SMALL LETTER YI 0 Not part of repertoire |
|
i
U+0069
blocked
í
U+00ED
blocked
ï
U+00EF
blocked
ı
U+0131
blocked
ɩ
U+0269
blocked
ΐ
U+0390
blocked
+6 more
|
| һ | U+04BB CYRILLIC SMALL LETTER SHHA 0 Not part of repertoire |
|
h
U+0068
blocked
հ
U+0570
blocked
Cross-script near homoglyph
|
| ա | U+0561 ARMENIAN SMALL LETTER AYB 0 100 Armenian |
|
ш
U+0448
blocked
Cross-script homoglyph
|
| բ | U+0562 ARMENIAN SMALL LETTER BEN 0 100 Armenian |
|
|
| գ | U+0563 ARMENIAN SMALL LETTER GIM 0 100 Armenian |
|
|
| դ | U+0564 ARMENIAN SMALL LETTER DA 0 100 Armenian |
|
|
| ե | U+0565 ARMENIAN SMALL LETTER ECH 0 100 Armenian |
|
|
| զ | U+0566 ARMENIAN SMALL LETTER ZA 0 100 Armenian |
|
q
U+0071
blocked
Cross-script near homoglyph
|
| է | U+0567 ARMENIAN SMALL LETTER EH 0 100 Armenian |
|
|
| ը | U+0568 ARMENIAN SMALL LETTER ET 0 100 Armenian |
|
|
| թ | U+0569 ARMENIAN SMALL LETTER TO 0 100 Armenian |
|
|
| ժ | U+056A ARMENIAN SMALL LETTER ZHE 0 100 Armenian |
|
|
| ի | U+056B ARMENIAN SMALL LETTER INI 0 100 Armenian |
|
|
| լ | U+056C ARMENIAN SMALL LETTER LIWN 0 100 Armenian |
|
|
| խ | U+056D ARMENIAN SMALL LETTER XEH 0 100 Armenian |
|
|
| ծ | U+056E ARMENIAN SMALL LETTER CA 0 100 Armenian |
|
|
| կ | U+056F ARMENIAN SMALL LETTER KEN 0 100 Armenian |
|
|
| հ | U+0570 ARMENIAN SMALL LETTER HO 0 100 Armenian |
|
h
U+0068
blocked
Cross-script near homoglyph
һ
U+04BB
blocked
Cross-script near homoglyph
|
| ձ | U+0571 ARMENIAN SMALL LETTER JA 0 100 Armenian |
|
|
| ղ | U+0572 ARMENIAN SMALL LETTER GHAD 0 100 Armenian |
|
n
U+006E
blocked
ń
U+0144
blocked
ŋ
U+014B
blocked
Cross-script near homoglyph
ή
U+03AE
blocked
η
U+03B7
blocked
Cross-script near homoglyph
ո
U+0578
blocked
Required for integration
+1 more
|
| ճ | U+0573 ARMENIAN SMALL LETTER CHEH 0 100 Armenian |
|
|
| մ | U+0574 ARMENIAN SMALL LETTER MEN 0 100 Armenian |
|
|
| յ | U+0575 ARMENIAN SMALL LETTER YI 0 100 Armenian |
|
|
| ն | U+0576 ARMENIAN SMALL LETTER NOW 0 100 Armenian |
|
|
| շ | U+0577 ARMENIAN SMALL LETTER SHA 0 100 Armenian |
|
|
| ո | U+0578 ARMENIAN SMALL LETTER VO 0 100 Armenian |
|
n
U+006E
blocked
Cross-script near homoglyph
ń
U+0144
blocked
ŋ
U+014B
blocked
ή
U+03AE
blocked
η
U+03B7
blocked
Cross-script near homoglyph
ղ
U+0572
blocked
Required for integration
+1 more
|
| չ | U+0579 ARMENIAN SMALL LETTER CHA 0 100 Armenian |
|
|
| պ | U+057A ARMENIAN SMALL LETTER PEH 0 100 Armenian |
|
|
| ջ | U+057B ARMENIAN SMALL LETTER JHEH 0 100 Armenian |
|
|
| ռ | U+057C ARMENIAN SMALL LETTER RA 0 100 Armenian |
|
|
| ս | U+057D ARMENIAN SMALL LETTER SEH 0 100 Armenian |
|
u
U+0075
blocked
Cross-script near homoglyph
ú
U+00FA
blocked
ü
U+00FC
blocked
ʋ
U+028B
blocked
ΰ
U+03B0
blocked
υ
U+03C5
blocked
+2 more
|
| վ | U+057E ARMENIAN SMALL LETTER VEW 0 100 Armenian |
|
|
| տ | U+057F ARMENIAN SMALL LETTER TIWN 0 100 Armenian |
|
|
| ր | U+0580 ARMENIAN SMALL LETTER REH 0 100 Armenian |
|
|
| ց | U+0581 ARMENIAN SMALL LETTER CO 0 100 Armenian |
|
g
U+0067
blocked
Cross-script near homoglyph
|
| ւ | U+0582 ARMENIAN SMALL LETTER YIWN 0 100 Armenian |
|
i
U+0069
blocked
í
U+00ED
blocked
ï
U+00EF
blocked
ı
U+0131
blocked
ɩ
U+0269
blocked
Cross-script near homoglyph
ΐ
U+0390
blocked
+6 more
|
| փ | U+0583 ARMENIAN SMALL LETTER PIWR 0 100 Armenian |
|
|
| ք | U+0584 ARMENIAN SMALL LETTER KEH 0 100 Armenian |
|
|
| օ | U+0585 ARMENIAN SMALL LETTER OH 0 100 Armenian |
|
o
U+006F
blocked
Cross-script homoglyph
ó
U+00F3
blocked
ο
U+03BF
blocked
Cross-script homoglyph
ό
U+03CC
blocked
о
U+043E
blocked
Cross-script homoglyph
|
| ֆ | U+0586 ARMENIAN SMALL LETTER FEH 0 100 Armenian |
|
|
| ṅ | U+1E45 LATIN SMALL LETTER N WITH DOT ABOVE 0 Not part of repertoire |
|
n
U+006E
blocked
ń
U+0144
blocked
ŋ
U+014B
blocked
ή
U+03AE
blocked
η
U+03B7
blocked
ղ
U+0572
blocked
+1 more
|
| ỉ | U+1EC9 LATIN SMALL LETTER I WITH HOOK ABOVE 0 Not part of repertoire |
|
i
U+0069
blocked
í
U+00ED
blocked
ï
U+00EF
blocked
ı
U+0131
blocked
ɩ
U+0269
blocked
ΐ
U+0390
blocked
+6 more
|
Variants
Code points grouped into sets of mutual variants. Every member of a set produces the same set of variant labels, so a registration of one has implications for all the others. Sets of a single member are omitted, as are the identity mappings RFC 7940 requires each member to declare.
-
iíïıɩΐίιϊіїւỉ
Source Direction Target Disposition Ref Comment i U+0069 ↔ í U+00ED blocked i U+0069 ↔ ï U+00EF blocked i U+0069 ↔ ı U+0131 blocked i U+0069 ↔ ɩ U+0269 blocked i U+0069 ↔ ΐ U+0390 blocked i U+0069 ↔ ί U+03AF blocked i U+0069 ↔ ι U+03B9 blocked i U+0069 ↔ ϊ U+03CA blocked i U+0069 ↔ і U+0456 blocked i U+0069 ↔ ї U+0457 blocked i U+0069 ↔ ւ U+0582 blocked i U+0069 ↔ ỉ U+1EC9 blocked ↔ declared both ways ⇆ both ways, different disposition each way → one direction only
-
uúüʋΰυϋύս
Source Direction Target Disposition Ref Comment u U+0075 ↔ ú U+00FA blocked u U+0075 ↔ ü U+00FC blocked u U+0075 ↔ ʋ U+028B blocked u U+0075 ↔ ΰ U+03B0 blocked u U+0075 ↔ υ U+03C5 blocked u U+0075 ↔ ϋ U+03CB blocked u U+0075 ↔ ύ U+03CD blocked u U+0075 ↔ ս U+057D blocked Cross-script near homoglyph ú U+00FA ↔ ü U+00FC blocked ú U+00FA ↔ ʋ U+028B blocked ú U+00FA ↔ ΰ U+03B0 blocked ú U+00FA ↔ υ U+03C5 blocked ↔ declared both ways ⇆ both ways, different disposition each way → one direction only
-
nńŋήηղոṅ
Source Direction Target Disposition Ref Comment n U+006E ↔ ń U+0144 blocked n U+006E ↔ ŋ U+014B blocked n U+006E ↔ ή U+03AE blocked n U+006E ↔ η U+03B7 blocked n U+006E ↔ ղ U+0572 blocked n U+006E ↔ ո U+0578 blocked Cross-script near homoglyph n U+006E ↔ ṅ U+1E45 blocked ń U+0144 ↔ ŋ U+014B blocked ń U+0144 ↔ ή U+03AE blocked ń U+0144 ↔ η U+03B7 blocked ń U+0144 ↔ ղ U+0572 blocked ń U+0144 ↔ ո U+0578 blocked ↔ declared both ways ⇆ both ways, different disposition each way → one direction only
-
oóοόоօ
Source Direction Target Disposition Ref Comment o U+006F ↔ ó U+00F3 blocked o U+006F ↔ ο U+03BF blocked Cross-script homoglyph o U+006F ↔ ό U+03CC blocked o U+006F ↔ о U+043E blocked Cross-script homoglyph o U+006F ↔ օ U+0585 blocked Cross-script homoglyph ó U+00F3 ↔ ο U+03BF blocked ó U+00F3 ↔ ό U+03CC blocked ó U+00F3 ↔ о U+043E blocked ó U+00F3 ↔ օ U+0585 blocked ο U+03BF ↔ ό U+03CC blocked ο U+03BF ↔ о U+043E blocked Cross-script homoglyph ο U+03BF ↔ օ U+0585 blocked Cross-script homoglyph ↔ declared both ways ⇆ both ways, different disposition each way → one direction only
Rules
Conditions evaluated against a whole label, or against the context around a
single code point. The notation borrows from regular expressions:
^ and $ anchor to the start and end of a label,
. matches any code point, (?= ) and
(?<= ) look ahead and behind, and * and
+ repeat. Two symbols are specific to rulesets:
◆ is the code point being tested, and
⟨name⟩ refers to another rule.
leading-combining-mark MSR default
Default WLE rule matching labels with leading combining marks
^ ({gc:Mn} ∪ {gc:Mc})
Structure
-
^start -
({gc:Mn} ∪ {gc:Mc})union-
{gc:Mn}class -
{gc:Mc}class
-
Referenced by 1 definition
- action 1 (invalid)
Actions
Actions are evaluated in the order shown. The first action whose conditions match determines the disposition of the label.
| # | Disposition | Conditions |
|---|---|---|
| 1 |
invalid
|
label matches leading-combining-mark labels with leading combining marks are invalid MSR default |
| 2 |
invalid
|
any variant is out-of-repertoire-var any variant label with a code point out of repertoire is invalid MSR default |
| 3 |
blocked
|
any variant is blocked any variant label containing blocked variants is blocked MSR default |
| 4 |
allocatable
|
all variants are allocatable variant labels with all variants allocatable are allocatable MSR default |
| 5 |
valid
|
any label default catch all (default action) MSR default |
References
| Ref | Source |
|---|---|
| 0 | The Unicode Standard 1.1 |
| 100 | Omniglot, “Armenian” https://www.omniglot.com/writing/armenian.htm |