Han
Root Zone Label Generation Rules, 6th Edition Current
Summary
| Version | 6 — Root Zone LGR for the Chinese Script |
|---|---|
| Date | |
| Tag |
und-Hani (Han)
|
| Unicode | 16.0.0 |
| Scope | DNS root zone |
| Source file | rz-lgr-6-chinese-script-23sep25-en.xml (3.3mb) |
Description
Root Zone Label Generation Rules for the Chinese Script
Overview
This file contains a set of Label Generation Rules (LGR) for the Chinese script for the Root Zone. For more details on this LGR and additional background on the script, see “Proposal for a Chinese Script Root Zone LGR” [Proposal-Chinese] including the appendices [Proposal-Chinese-Appendices]. This file is one of a set of LGR files that together form an integrated LGR for the DNS Root Zone [RZ-LGR-6]. The format of this file follows [RFC 7940].
Repertoire
The Root Zone repertoire for the Chinese script contains 19,685 single code points. It represents the union of the CDNC IDN Table and the dotAsia IDN Table. For more details, see Section 5, “Repertoire” in [Proposal-Chinese].
Note: This LGR contains 62 code points from the Unicode block: CJK UNIFIED IDEOGRAPHS EXTENDED B.
Read the rest of the description Show less
The repertoire is contained in [MSR-6], which is a subset of [Unicode 16.0.0].
As part of the Root Zone, this LGR includes neither decimal digits nor the HYPHEN-MINUS.
Repertoire Listing: Each code point or range is tagged with the script or scripts with which the code point is used. For each repertoire element, one or more references document sufficient justification for inclusion in the repertoire; see the “References” below.
Code points outside the Chinese script repertoire that are listed in this file are targets for out-of-repertoire variants and are identified by a reflexive (identity) variant of type “out-of-repertoire-var”. They do not form part of the repertoire.
Variants
According to Sections 6 and 7 of [Proposal-Chinese] the LGR defines semantically exchangeable variants (same pronunciations as well as the same meanings) and visually identical variants. Many, but not all, of the semantic variants lead to variant label dispositions of “allocatable” as described below, all other variant labels are “blocked”.
Source References for Variants
The source reference cited for each variant mapping entry indicates whether the variant mapping is same or different from the rules of CDNC, dotAsia, JGP and KGP, or is based on input during the Root Zone LGR integration process.
For example, a value of “201” means the variant mapping matches dotAsia in both code point and variant type”, a value of “202” means the variant mapping matches dotAsia only in code point but not variant type, while a value of “203” means the variant mapping matches no dotAsia code point”.
A value of “701” means the variant mapping agrees with input received from the Integration Panel in both code point and variant type”.
Variant Mapping Types
The LGR uses the following variant types (the prefix “r-” here marks a type used in a reflexive variant mapping, that is, it represents an instance of the original code point at that location, see Section 5.3.4 in [RFC 7940]):
- blocked — variant labels containing a blocked variant will receive a disposition of “blocked”.
- r-simp, simp, simp-1, simp-2 — variant labels that are created with these types or “both” or “r-both” represent an all-simplified label and receive a disposition of “allocatable” unless they contain a mix of “simp-1” and “simp-2”. In that case, such variant labels will receive a disposition of “blocked”.
- r-trad, trad, trad-1, trad-2 — variant labels that are created with these types or “both” or “r-both” represent an all-traditional label and receive a disposition of “allocatable” unless they contain a mix of “trad-1” and “trad-2”. In that case, such variant labels will receive a disposition of “blocked”.
- both, r-both — a variant of either type may be part of either an all-simplified or an all-traditional variant label.
- r-neither — variant labels containing that type together with any other non-reflexive variant type will receive a disposition of “invalid”.
The variant types (“simp-1”, “simp-2”, “trad-1”, “trad-2”) and the corresponding actions reduce the number of multiple allocatable labels, limiting the number to no more than 5 per label. This case can occur for labels containing code points that are part of a small number of variant sets that have multiple traditional or simplified variants.
Note that a label containing only reflexive mappings, including “r-neither”, but not “out-of-repertoire-var” is an original label and receives a disposition of “valid”. (See also “Chinese-specific Actions” below.)
The LGR does not define specific variant types to handle visually identical variants, but adopts “both” and “blocked” instead, as described in Section 7 of [Proposal-Chinese].
As much as possible the scheme retains the same simplified and traditional mappings as existing second level domains. It does not change the simplified type or traditional type of any variant code point; instead, it subdivides them into common simplified/traditional ones and extra simplified/traditional ones, and provides additional disposition rules to limit any allocatable variant to one of these subgroups. While it does not allow the applicant to get arbitrary mixed labels from an unconstrained allocatable label list, it does allow the applicant to select as the original label one specific desired mixed variant.
Comments on Variants
The comment for each variant mapping entry indicates not only whether it is the reflexive identity and therefore applies to those code points in a label that match the original label, but also documents whether it has been conflated with some other type originally introduced to reduce the number of multiple allocatable labels in Section 6.3 of [Proposal-Chinese].
For example, a variant comment of “r-both-ms” indicates that for a given code point, the variant is a code point that could in principle be used with both trad and simp (“r-both”), but because the same variant set has at least one other variant of type “simp” (or of one of the other simplified types), the variant is preferred in a traditional context, such that a “trad” label containing this variant should be “allocatable”, but a “simp” label containing this variant should be “blocked”. The “ms” in the naming convention means that the simplified aspect of the variant is “muted”, even though inherently if would have been of type “r-both”. Effectively, such a variant leads to the same dispositions as an “r-trad”, hence that is the variant type assigned to it, with only the comment indicating that the variant would have inherently been of type “r-both” but with its simp aspect muted.
Character Classes
The LGR does not define character classes.
Whole Label Evaluation (WLE) and Context Rules
Default Whole Label Evaluation Rules and Actions
The LGR includes the set of required default WLE rules and actions applicable to the Root Zone and defined in [MSR-6]. They are marked with ⍟. The actions compute a label disposition based on WLE rules or variant mapping types.
Chinese-specific Rules
None.
Label and Variant Label Disposition
The LGR defines a number of actions that compute a label disposition based on WLE rules or variant mapping types. Some of these are common to all LGRs, and some are specific to this LGR.
Chinese-specific Actions
The LGR contains additional Chinese-specific actions as described in Sections 6 and 7 of [Proposal-Chinese]. These resolve the extended set of variant types into a disposition for variant labels of either “allocatable”, “blocked” (or “valid” for an original label that is the identity variant). Chinese-specific actions that are triggered by the LGR-specific variant types described above limit the “allocatable” variant labels to those that are either fully simplified or fully traditional labels. In addition, these actions return a disposition of “allocatable” for any original label, even those that are mixed between simplified and traditional (see also [RFC 3743] and [RFC 4713]). To account for original labels, reflexive variant mappings with an “r-” prefix are used. (See [RFC 7940])
Note: the only action explicitly triggered by variant type sets including variant type “r-neither” returns a disposition of “valid” for an original label.
Note that variant mapping types are not symmetric: they depend on which code point is considered the source or the target in a given mapping. As specified in [RFC 7940], mapping types are evaluated for each permutation of a label and its variants, with code points that are unchanged in a given label given the type of their “reflexive” or “identity” mapping. The actions finally evaluate the collected set of mapping types and resolve them into one of two dispositions for the variant label. Per [RFC 7940] actions are always applied one after the other, and the evaluation stops at the first action that assigns a disposition to a given label.
For more information on how to assign a variant label disposition under this LGR, see Section 8, “Assigning Variant Dispositions to Labels” in [Proposal-Chinese]. The specification of variants in the LGR follows the guidelines in [RFC 8228].
Methodology and Contributors
The Root Zone LGR for the Chinese Script was developed by the Chinese Generation Panel. For details on methodology and contributors, see Sections 4 and 9 in [Proposal-Chinese], as well as [RZ-LGR-6-Overview].
Changes from RZ LGR-4
For consistency with all other RZ LGRs, the disposition for labels consisting of only original code points is now “valid” instead of “allocatable”. With this change, original labels across the Root Zone LGR are now either valid or invalid, whereas any variant labels are either allocatable or blocked. This removes an exception in processing original labels without affecting the set of labels available for delegation. For the prior version see [RZ-LGR-4-Hani].
References
References [0] to [4] refer to the Unicode Standard versions in which corresponding code points were initially encoded. For example, a reference value of [4] means a character was first encoded in Unicode Version 3.1. References [100] and up indicate that the code point is included in one of the following source references: CDNC IDN Table, dotAsia IDN Table, JGP repertoire [JLGR], KGP repertoire [KLGR], and IICORE or some other list of code points. For example, a reference value of [200] means a code point listed here is included in the dotAsia IDN Table. References cited for variants indicate whether variant mappings match a source reference in mapping, variant type or both. Entries in the table may have multiple source reference values.
In addition, the following general references are cited in this document:
- [JLGR]
- Root Zone Label Generation Rules for Japanese, 20 December 2021, https://www.icann.org/en/system/files/files/proposal-japanese-lgr-20dec21-en.xml
- [KLGR]
- Root Zone Label Generation Rules for Korean, 1 May 2021, https://www.icann.org/en/system/files/files/proposal-korean-lgr-01may21-en.xml
- [MSR-6]
- Integration Panel, “Maximal Starting Repertoire — MSR-6 Overview and Rationale”, 23 September 2025, https://www.icann.org/en/system/files/files/msr-6-overview-23sep25-en.pdf
- [Proposal-Chinese]
- Chinese Script Generation Panel (CGP), “Proposal for a Chinese Script Root Zone LGR”, 26 May 2020, https://www.icann.org/en/system/files/files/proposal-chinese-lgr-26may20-en.pdf
- [Proposal-Chinese-Appendices]
- Appendices to “Proposal for a Chinese Script Root Zone LGR”, 26 May 2020 (ZIP), https://www.icann.org/en/system/files/files/proposal-chinese-lgr-appendices-26may20-en.zip
- [RFC 3743]
- Konishi, K., Huang, K., Qian, H., and Y. Ko, “Joint Engineering Team (JET) Guidelines for Internationalized Domain Names (IDN) Registration and Administration for Chinese, Japanese, and Korean”, RFC 3743, April 2004, https://www.rfc-editor.org/info/rfc4713
- [RFC 4713]
- Lee, X., Mao, W., Chen, E., Hsu, N., and J. Klensin, “Registration and Administration Recommendations for Chinese Domain Names”, RFC 4713, October 2006, https://www.rfc-editor.org/info/rfc4713
- [RFC 7940]
- Davies, K. and A. Freytag, “Representing Label Generation Rulesets Using XML”, RFC 7940, August 2016, https://www.rfc-editor.org/info/rfc7940
- [RFC 8228]
- A. Freytag, “Guidance on Designing Label Generation Rulesets (LGRs) Supporting Variant Labels”, RFC 8228, August 2017, https://www.rfc-editor.org/info/rfc8228
- [RZ-LGR-4-Hani]
- ICANN, Root Zone Label Generation Rules for the Chinese Script (und-Hani), Version 4, 5 November 2020 (XML)
https://www.icann.org/sites/default/files/lgr/lgr-4-chinese-script-05nov20-en.xml
non-normative HTML presentation: https://www.icann.org/sites/default/files/lgr/lgr-4-chinese-script-05nov20-en.html - [RZ-LGR-6-Overview]
- Integration Panel, “Root Zone Label Generation Rules (RZ LGR-6): Overview and Summary”, 23 September 2025, https://www.icann.org/sites/default/files/lgr/rz-lgr-6-overview-23sep25-en.pdf
- [RZ-LGR-6]
- Integration Panel, “Root Zone Label Generation Rules (RZ-LGR-6)”, 23 September 2025 (XML), https://www.icann.org/sites/default/files/lgr/rz-lgr-6-common-23sep25-en.xml
non-normative HTML presentation: https://www.icann.org/sites/default/files/lgr/rz-lgr-6-common-23sep25-en.html - [Unicode 16.0.0]
- The Unicode Consortium. The Unicode Standard, Version 16.0.0, (South San Francisco: The Unicode Consortium, 2024. ISBN 978-1-936213-34-4) https://www.unicode.org/versions/Unicode16.0.0/
For references consulted, particularly in designing the repertoire for the Chinese script for the Root Zone, please see details in the Table of References below. References [0] and above refer to the Unicode Standard version in which corresponding code points were initially encoded. References [100] and above correspond to a source given in [Proposal-Chinese] for justifying the inclusion of the corresponding code points and variants. Entries in the table may have multiple source reference values. If links to certain references are not available, the data may be archived as part of [Proposal-Chinese].
Repertoire
| Glyph | Code point | Tags and context | Variants |
|---|---|---|---|
| 㑇 | U+3447 CJK UNIFIED IDEOGRAPH-3447 3 100 200 300 |
|
㑳
U+3473
trad
|
| 㑳 | U+3473 CJK UNIFIED IDEOGRAPH-3473 3 100 200 300 |
|
㑇
U+3447
simp
|
| 㓤 | U+34E4 CJK UNIFIED IDEOGRAPH-34E4 3 200 600 |
|
|
| 㕷 | U+3577 CJK UNIFIED IDEOGRAPH-3577 3 200 600 |
|
|
| 㖞 | U+359E CJK UNIFIED IDEOGRAPH-359E 3 100 200 |
|
喎
U+558E
trad
|
| 㖡 | U+35A1 CJK UNIFIED IDEOGRAPH-35A1 3 200 600 |
|
|
| 㖭 | U+35AD CJK UNIFIED IDEOGRAPH-35AD 3 200 600 |
|
|
| 㖿 | U+35BF CJK UNIFIED IDEOGRAPH-35BF 3 200 600 |
|
|
| 㗎 | U+35CE CJK UNIFIED IDEOGRAPH-35CE 3 200 600 |
|
|
| 㗳 | U+35F3 CJK UNIFIED IDEOGRAPH-35F3 3 200 600 |
|
|
| 㗾 | U+35FE CJK UNIFIED IDEOGRAPH-35FE 3 200 600 |
|
|
| 㘎 | U+360E CJK UNIFIED IDEOGRAPH-360E 3 100 200 300 |
|
㘚
U+361A
trad
|
| 㘚 | U+361A CJK UNIFIED IDEOGRAPH-361A 3 100 200 300 |
|
㘎
U+360E
simp
|
| 㤘 | U+3918 CJK UNIFIED IDEOGRAPH-3918 3 100 200 300 |
|
㥮
U+396E
trad
|
| 㥠 | U+3960 CJK UNIFIED IDEOGRAPH-3960 3 500 Not part of repertoire |
|
諝
U+8ADD
blocked
谞
U+8C1E
blocked
|
| 㥮 | U+396E CJK UNIFIED IDEOGRAPH-396E 3 100 200 300 |
|
㤘
U+3918
simp
|
| 㧏 | U+39CF CJK UNIFIED IDEOGRAPH-39CF 3 100 200 |
|
掆
U+6386
trad
|
| 㧐 | U+39D0 CJK UNIFIED IDEOGRAPH-39D0 3 100 200 300 |
|
㩳
U+3A73
trad
|
| 㧛 | U+39DB CJK UNIFIED IDEOGRAPH-39DB 3 200 |
|
㩜
U+3A5C
blocked
揽
U+63FD
blocked
擥
U+64E5
trad
攬
U+652C
blocked
|
| 㧟 | U+39DF CJK UNIFIED IDEOGRAPH-39DF 3 100 200 300 600 |
|
擓
U+64D3
trad
|
| 㧸 | U+39F8 CJK UNIFIED IDEOGRAPH-39F8 3 200 600 |
|
|
| 㧾 | U+39FE CJK UNIFIED IDEOGRAPH-39FE 3 200 600 |
|
|
| 㨘 | U+3A18 CJK UNIFIED IDEOGRAPH-3A18 3 200 600 |
|
擤
U+64E4
blocked
|
| 㩒 | U+3A52 CJK UNIFIED IDEOGRAPH-3A52 3 200 600 |
|
擒
U+64D2
simp
|
| 㩜 | U+3A5C CJK UNIFIED IDEOGRAPH-3A5C 3 100 |
|
㧛
U+39DB
blocked
揽
U+63FD
blocked
擥
U+64E5
blocked
攬
U+652C
blocked
|
| 㩧 | U+3A67 CJK UNIFIED IDEOGRAPH-3A67 3 200 600 |
|
|
| 㩳 | U+3A73 CJK UNIFIED IDEOGRAPH-3A73 3 100 200 300 |
|
㧐
U+39D0
simp
|
| 㬹 | U+3B39 CJK UNIFIED IDEOGRAPH-3B39 3 200 600 |
|
|
| 㭎 | U+3B4E CJK UNIFIED IDEOGRAPH-3B4E 3 100 200 300 600 |
|
棡
U+68E1
trad
|
| 㮣 | U+3BA3 CJK UNIFIED IDEOGRAPH-3BA3 3 200 |
|
槩
U+69E9
blocked
|
| 㱮 | U+3C6E CJK UNIFIED IDEOGRAPH-3C6E 3 100 200 |
|
殨
U+6BA8
trad
|
| 㳠 | U+3CE0 CJK UNIFIED IDEOGRAPH-3CE0 3 100 200 |
|
澾
U+6FBE
trad
|
| 㷧 | U+3DE7 CJK UNIFIED IDEOGRAPH-3DE7 3 200 600 |
|
|
| 㷫 | U+3DEB CJK UNIFIED IDEOGRAPH-3DEB 3 200 600 |
|
|
| 㹴 | U+3E74 CJK UNIFIED IDEOGRAPH-3E74 3 200 600 |
|
|
| 㻐 | U+3ED0 CJK UNIFIED IDEOGRAPH-3ED0 3 200 600 |
|
|
| 䁖 | U+4056 CJK UNIFIED IDEOGRAPH-4056 3 100 200 300 |
|
瞜
U+779C
trad
|
| 䁥 | U+4065 CJK UNIFIED IDEOGRAPH-4065 3 200 600 |
|
|
| 䁪 | U+406A CJK UNIFIED IDEOGRAPH-406A 3 200 600 |
|
|
| 䂻 | U+40BB CJK UNIFIED IDEOGRAPH-40BB 3 200 600 |
|
|
| 䃟 | U+40DF CJK UNIFIED IDEOGRAPH-40DF 3 200 600 |
|
|
| 䅟 | U+415F CJK UNIFIED IDEOGRAPH-415F 3 100 200 300 |
|
穇
U+7A47
trad
|
| 䌷 | U+4337 CJK UNIFIED IDEOGRAPH-4337 3 100 200 |
|
紬
U+7D2C
trad
綢
U+7DA2
blocked
绸
U+7EF8
blocked
|
| 䎬 | U+43AC CJK UNIFIED IDEOGRAPH-43AC 3 100 200 |
|
䎱
U+43B1
trad
|
| 䎱 | U+43B1 CJK UNIFIED IDEOGRAPH-43B1 3 100 200 |
|
䎬
U+43AC
simp
|
| 䏓 | U+43D3 CJK UNIFIED IDEOGRAPH-43D3 3 200 |
|
朊
U+670A
blocked
|
| 䏝 | U+43DD CJK UNIFIED IDEOGRAPH-43DD 3 100 200 300 |
|
膞
U+819E
trad
|
| 䑃 | U+4443 CJK UNIFIED IDEOGRAPH-4443 3 200 |
|
朦
U+6726
blocked
|
| 䓖 | U+44D6 CJK UNIFIED IDEOGRAPH-44D6 3 100 200 300 |
|
藭
U+85ED
trad
|
| 䓪 | U+44EA CJK UNIFIED IDEOGRAPH-44EA 3 200 600 |
|
|
| 䘆 | U+4606 CJK UNIFIED IDEOGRAPH-4606 3 200 600 |
|
|
| 䙌 | U+464C CJK UNIFIED IDEOGRAPH-464C 3 100 200 |
|
䙡
U+4661
trad
|
| 䙡 | U+4661 CJK UNIFIED IDEOGRAPH-4661 3 100 200 |
|
䙌
U+464C
simp
|
| 䜣 | U+4723 CJK UNIFIED IDEOGRAPH-4723 3 100 200 300 600 |
|
訢
U+8A22
trad
|
| 䜩 | U+4729 CJK UNIFIED IDEOGRAPH-4729 3 100 200 |
|
讌
U+8B8C
trad
|
| 䝼 | U+477C CJK UNIFIED IDEOGRAPH-477C 3 100 200 |
|
䞍
U+478D
simp
|
| 䞍 | U+478D CJK UNIFIED IDEOGRAPH-478D 3 100 200 |
|
䝼
U+477C
trad
|
| 䟴 | U+47F4 CJK UNIFIED IDEOGRAPH-47F4 3 200 600 |
|
|
| 䢂 | U+4882 CJK UNIFIED IDEOGRAPH-4882 3 200 |
|
𨋢
U+282E2
trad
|
| 䥇 | U+4947 CJK UNIFIED IDEOGRAPH-4947 3 100 200 |
|
䦂
U+4982
simp
|
| 䥺 | U+497A CJK UNIFIED IDEOGRAPH-497A 3 100 200 |
|
釾
U+91FE
trad
|
| 䥽 | U+497D CJK UNIFIED IDEOGRAPH-497D 3 100 200 300 |
|
鏺
U+93FA
trad
|
| 䦂 | U+4982 CJK UNIFIED IDEOGRAPH-4982 3 100 200 |
|
䥇
U+4947
trad
|
| 䦃 | U+4983 CJK UNIFIED IDEOGRAPH-4983 3 100 200 300 |
|
鐯
U+942F
trad
|
| 䦅 | U+4985 CJK UNIFIED IDEOGRAPH-4985 3 100 200 |
|
鐥
U+9425
trad
|
| 䦆 | U+4986 CJK UNIFIED IDEOGRAPH-4986 3 100 200 |
|
钁
U+9481
trad
|
| 䦛 | U+499B CJK UNIFIED IDEOGRAPH-499B 3 100 200 |
|
䦶
U+49B6
simp
|
| 䦟 | U+499F CJK UNIFIED IDEOGRAPH-499F 3 100 200 |
|
䦷
U+49B7
simp
|
| 䦶 | U+49B6 CJK UNIFIED IDEOGRAPH-49B6 3 100 200 |
|
䦛
U+499B
trad
|
| 䦷 | U+49B7 CJK UNIFIED IDEOGRAPH-49B7 3 100 200 |
|
䦟
U+499F
trad
|
| 䪸 | U+4AB8 CJK UNIFIED IDEOGRAPH-4AB8 3 200 500 600 |
|
|
| 䱷 | U+4C77 CJK UNIFIED IDEOGRAPH-4C77 3 100 200 |
|
䲣
U+4CA3
simp
|
| 䱽 | U+4C7D CJK UNIFIED IDEOGRAPH-4C7D 3 200 600 |
|
䲝
U+4C9D
simp
鯧
U+9BE7
blocked
鲳
U+9CB3
blocked
|
| 䲁 | U+4C81 CJK UNIFIED IDEOGRAPH-4C81 3 200 300 600 |
|
鳚
U+9CDA
simp
|
| 䲅 | U+4C85 CJK UNIFIED IDEOGRAPH-4C85 3 200 600 |
|
|
| 䲝 | U+4C9D CJK UNIFIED IDEOGRAPH-4C9D 3 200 |
|
䱽
U+4C7D
trad
鯧
U+9BE7
blocked
鲳
U+9CB3
blocked
|
| 䲞 | U+4C9E CJK UNIFIED IDEOGRAPH-4C9E 3 200 |
|
𩶘
U+29D98
trad
|
| 䲟 | U+4C9F CJK UNIFIED IDEOGRAPH-4C9F 3 100 200 300 |
|
鮣
U+9BA3
trad
|
| 䲠 | U+4CA0 CJK UNIFIED IDEOGRAPH-4CA0 3 100 200 300 |
|
鰆
U+9C06
trad
|
| 䲡 | U+4CA1 CJK UNIFIED IDEOGRAPH-4CA1 3 100 200 |
|
鰌
U+9C0C
trad
鰍
U+9C0D
blocked
鳅
U+9CC5
blocked
|
| 䲢 | U+4CA2 CJK UNIFIED IDEOGRAPH-4CA2 3 100 200 300 |
|
鰧
U+9C27
trad
|
| 䲣 | U+4CA3 CJK UNIFIED IDEOGRAPH-4CA3 3 100 200 |
|
䱷
U+4C77
trad
|
| 䴓 | U+4D13 CJK UNIFIED IDEOGRAPH-4D13 3 100 200 300 |
|
鳾
U+9CFE
trad
|
| 䴔 | U+4D14 CJK UNIFIED IDEOGRAPH-4D14 3 100 200 300 |
|
鵁
U+9D41
trad
|
| 䴕 | U+4D15 CJK UNIFIED IDEOGRAPH-4D15 3 100 200 300 |
|
鴷
U+9D37
trad
|
| 䴖 | U+4D16 CJK UNIFIED IDEOGRAPH-4D16 3 100 200 300 |
|
鶄
U+9D84
trad
|
| 䴗 | U+4D17 CJK UNIFIED IDEOGRAPH-4D17 3 100 200 300 |
|
鶪
U+9DAA
trad
|
| 䴘 | U+4D18 CJK UNIFIED IDEOGRAPH-4D18 3 100 200 300 |
|
鷈
U+9DC8
blocked
鷉
U+9DC9
trad
|
| 䴙 | U+4D19 CJK UNIFIED IDEOGRAPH-4D19 3 100 200 300 |
|
鷿
U+9DFF
blocked
鸊
U+9E0A
trad
|
| 䶮 | U+4DAE CJK UNIFIED IDEOGRAPH-4DAE 3 100 200 300 |
|
龑
U+9F91
trad
|
| 一 | U+4E00 CJK UNIFIED IDEOGRAPH-4E00 0 100 200 300 400 500 600 |
|
壱
U+58F1
blocked
壹
U+58F9
blocked
弌
U+5F0C
blocked
|
| 丁 | U+4E01 CJK UNIFIED IDEOGRAPH-4E01 0 100 200 300 400 500 600 |
|
|
| 丂 | U+4E02 CJK UNIFIED IDEOGRAPH-4E02 0 100 200 |
|
|
| 七 | U+4E03 CJK UNIFIED IDEOGRAPH-4E03 0 100 200 300 400 500 600 |
|
|
| 丄 | U+4E04 CJK UNIFIED IDEOGRAPH-4E04 0 100 200 |
|
上
U+4E0A
both
仩
U+4EE9
blocked
|
| 丅 | U+4E05 CJK UNIFIED IDEOGRAPH-4E05 0 100 200 |
|
下
U+4E0B
both
|
| 丆 | U+4E06 CJK UNIFIED IDEOGRAPH-4E06 0 100 200 |
|
|
| 万 | U+4E07 CJK UNIFIED IDEOGRAPH-4E07 0 100 200 300 400 500 600 |
|
萬
U+842C
trad
|
| 丈 | U+4E08 CJK UNIFIED IDEOGRAPH-4E08 0 100 200 300 400 500 600 |
|
|
| 三 | U+4E09 CJK UNIFIED IDEOGRAPH-4E09 0 100 200 300 400 500 600 |
|
|
| 上 | U+4E0A CJK UNIFIED IDEOGRAPH-4E0A 0 100 200 300 400 500 600 |
|
丄
U+4E04
blocked
仩
U+4EE9
blocked
|
| 下 | U+4E0B CJK UNIFIED IDEOGRAPH-4E0B 0 100 200 300 400 500 600 |
|
丅
U+4E05
blocked
|
| 丌 | U+4E0C CJK UNIFIED IDEOGRAPH-4E0C 0 100 200 |
|
亓
U+4E93
blocked
其
U+5176
blocked
|
| 不 | U+4E0D CJK UNIFIED IDEOGRAPH-4E0D 0 100 200 300 400 500 600 |
|
|
| 与 | U+4E0E CJK UNIFIED IDEOGRAPH-4E0E 0 100 200 300 400 600 |
|
與
U+8207
trad
|
| 丏 | U+4E0F CJK UNIFIED IDEOGRAPH-4E0F 0 100 200 300 |
|
丐
U+4E10
simp
|
| 丐 | U+4E10 CJK UNIFIED IDEOGRAPH-4E10 0 100 200 300 400 600 |
|
丏
U+4E0F
blocked
|
| 丑 | U+4E11 CJK UNIFIED IDEOGRAPH-4E11 0 100 200 300 400 500 600 |
|
醜
U+919C
trad
|
| 专 | U+4E13 CJK UNIFIED IDEOGRAPH-4E13 0 100 200 300 600 |
|
專
U+5C08
trad
|
| 且 | U+4E14 CJK UNIFIED IDEOGRAPH-4E14 0 100 200 300 400 500 600 |
|
|
| 丕 | U+4E15 CJK UNIFIED IDEOGRAPH-4E15 0 100 200 300 400 500 600 |
|
|
| 世 | U+4E16 CJK UNIFIED IDEOGRAPH-4E16 0 100 200 300 400 500 600 |
|
丗
U+4E17
blocked
卋
U+534B
blocked
|
| 丗 | U+4E17 CJK UNIFIED IDEOGRAPH-4E17 0 100 200 400 |
|
世
U+4E16
both
卋
U+534B
blocked
|
| 丘 | U+4E18 CJK UNIFIED IDEOGRAPH-4E18 0 100 200 300 400 500 600 |
|
丠
U+4E20
blocked
坵
U+5775
blocked
|
| 丙 | U+4E19 CJK UNIFIED IDEOGRAPH-4E19 0 100 200 300 400 500 600 |
|
|
| 业 | U+4E1A CJK UNIFIED IDEOGRAPH-4E1A 0 100 200 300 600 |
|
業
U+696D
trad
|
| 丛 | U+4E1B CJK UNIFIED IDEOGRAPH-4E1B 0 100 200 300 600 |
|
叢
U+53E2
trad-1
欉
U+6B09
trad-2
藂
U+85C2
blocked
|
| 东 | U+4E1C CJK UNIFIED IDEOGRAPH-4E1C 0 100 200 300 600 |
|
東
U+6771
trad
|
| 丝 | U+4E1D CJK UNIFIED IDEOGRAPH-4E1D 0 100 200 300 600 |
|
糸
U+7CF8
blocked
糹
U+7CF9
blocked
絲
U+7D72
trad
纟
U+7E9F
blocked
|
| 丞 | U+4E1E CJK UNIFIED IDEOGRAPH-4E1E 0 100 200 300 400 500 600 |
|
|
| 丟 | U+4E1F CJK UNIFIED IDEOGRAPH-4E1F 0 100 200 600 |
|
丢
U+4E22
simp
|
| 丠 | U+4E20 CJK UNIFIED IDEOGRAPH-4E20 0 100 200 |
|
丘
U+4E18
both
坵
U+5775
blocked
|
| 両 | U+4E21 CJK UNIFIED IDEOGRAPH-4E21 0 100 200 400 600 |
|
两
U+4E24
simp
兩
U+5169
trad
|
| 丢 | U+4E22 CJK UNIFIED IDEOGRAPH-4E22 0 100 200 300 600 |
|
丟
U+4E1F
trad
|
| 丣 | U+4E23 CJK UNIFIED IDEOGRAPH-4E23 0 100 200 |
|
酉
U+9149
both
|
| 两 | U+4E24 CJK UNIFIED IDEOGRAPH-4E24 0 100 200 300 600 |
|
両
U+4E21
blocked
兩
U+5169
trad
|
| 严 | U+4E25 CJK UNIFIED IDEOGRAPH-4E25 0 100 200 300 600 |
|
厳
U+53B3
blocked
嚴
U+56B4
trad
|
| 並 | U+4E26 CJK UNIFIED IDEOGRAPH-4E26 0 100 200 300 400 600 |
|
併
U+4F75
blocked
倂
U+5002
blocked
并
U+5E76
simp
幷
U+5E77
blocked
竝
U+7ADD
blocked
|
| 丧 | U+4E27 CJK UNIFIED IDEOGRAPH-4E27 0 100 200 300 600 |
|
喪
U+55AA
trad
|
| 丨 | U+4E28 CJK UNIFIED IDEOGRAPH-4E28 0 100 200 |
|
|
| 个 | U+4E2A CJK UNIFIED IDEOGRAPH-4E2A 0 100 200 300 400 600 |
|
個
U+500B
trad
箇
U+7B87
blocked
|
| 丫 | U+4E2B CJK UNIFIED IDEOGRAPH-4E2B 0 100 200 300 600 |
|
|
| 丬 | U+4E2C CJK UNIFIED IDEOGRAPH-4E2C 0 100 200 |
|
爿
U+723F
trad
|
| 中 | U+4E2D CJK UNIFIED IDEOGRAPH-4E2D 0 100 200 300 400 500 600 |
|
|
| 丮 | U+4E2E CJK UNIFIED IDEOGRAPH-4E2E 0 100 200 |
|
|
| 丯 | U+4E2F CJK UNIFIED IDEOGRAPH-4E2F 0 100 200 |
|
|
| 丰 | U+4E30 CJK UNIFIED IDEOGRAPH-4E30 0 100 200 300 600 |
|
豊
U+8C4A
blocked
豐
U+8C50
trad
|
| 丱 | U+4E31 CJK UNIFIED IDEOGRAPH-4E31 0 100 200 400 600 |
|
|
| 串 | U+4E32 CJK UNIFIED IDEOGRAPH-4E32 0 100 200 300 400 500 600 |
|
賗
U+8CD7
blocked
|
| 丳 | U+4E33 CJK UNIFIED IDEOGRAPH-4E33 0 100 200 |
|
|
| 临 | U+4E34 CJK UNIFIED IDEOGRAPH-4E34 0 100 200 300 600 |
|
臨
U+81E8
trad
|
| 丵 | U+4E35 CJK UNIFIED IDEOGRAPH-4E35 0 100 200 |
|
|
| 丶 | U+4E36 CJK UNIFIED IDEOGRAPH-4E36 0 100 200 400 |
|
|
| 丷 | U+4E37 CJK UNIFIED IDEOGRAPH-4E37 0 100 200 |
|
|
| 丸 | U+4E38 CJK UNIFIED IDEOGRAPH-4E38 0 100 200 300 400 500 600 |
|
|
| 丹 | U+4E39 CJK UNIFIED IDEOGRAPH-4E39 0 100 200 300 400 500 600 |
|
|
| 为 | U+4E3A CJK UNIFIED IDEOGRAPH-4E3A 0 100 200 300 600 |
|
為
U+70BA
trad
爲
U+7232
blocked
|
| 主 | U+4E3B CJK UNIFIED IDEOGRAPH-4E3B 0 100 200 300 400 500 600 |
|
|
| 丼 | U+4E3C CJK UNIFIED IDEOGRAPH-4E3C 0 100 200 400 600 |
|
井
U+4E95
simp
|
| 丽 | U+4E3D CJK UNIFIED IDEOGRAPH-4E3D 0 100 200 300 600 |
|
麗
U+9E97
trad
|
| 举 | U+4E3E CJK UNIFIED IDEOGRAPH-4E3E 0 100 200 300 600 |
|
挙
U+6319
blocked
擧
U+64E7
blocked
舉
U+8209
trad
|
| 丿 | U+4E3F CJK UNIFIED IDEOGRAPH-4E3F 0 100 200 400 |
|
|
| 乀 | U+4E40 CJK UNIFIED IDEOGRAPH-4E40 0 100 200 |
|
|
| 乁 | U+4E41 CJK UNIFIED IDEOGRAPH-4E41 0 100 200 |
|
|
| 乂 | U+4E42 CJK UNIFIED IDEOGRAPH-4E42 0 100 200 300 400 500 600 |
|
|
| 乃 | U+4E43 CJK UNIFIED IDEOGRAPH-4E43 0 100 200 300 400 500 600 |
|
廼
U+5EFC
blocked
迺
U+8FFA
trad
|
| 乄 | U+4E44 CJK UNIFIED IDEOGRAPH-4E44 0 100 200 |
|
|
| 久 | U+4E45 CJK UNIFIED IDEOGRAPH-4E45 0 100 200 300 400 500 600 |
|
乆
U+4E46
blocked
|
| 乆 | U+4E46 CJK UNIFIED IDEOGRAPH-4E46 0 100 200 |
|
久
U+4E45
both
|
| 乇 | U+4E47 CJK UNIFIED IDEOGRAPH-4E47 0 100 200 |
|
|
| 么 | U+4E48 CJK UNIFIED IDEOGRAPH-4E48 0 100 200 300 600 |
|
幺
U+5E7A
blocked
庅
U+5E85
blocked
麼
U+9EBC
trad
麽
U+9EBD
blocked
|
| 义 | U+4E49 CJK UNIFIED IDEOGRAPH-4E49 0 100 200 300 600 |
|
羛
U+7F9B
blocked
義
U+7FA9
trad
|
| 乊 | U+4E4A CJK UNIFIED IDEOGRAPH-4E4A 0 100 200 |
|
|
| 之 | U+4E4B CJK UNIFIED IDEOGRAPH-4E4B 0 100 200 300 400 500 600 |
|
|
| 乌 | U+4E4C CJK UNIFIED IDEOGRAPH-4E4C 0 100 200 300 600 |
|
烏
U+70CF
trad
|
| 乍 | U+4E4D CJK UNIFIED IDEOGRAPH-4E4D 0 100 200 300 400 500 600 |
|
|
| 乎 | U+4E4E CJK UNIFIED IDEOGRAPH-4E4E 0 100 200 300 400 500 600 |
|
|
| 乏 | U+4E4F CJK UNIFIED IDEOGRAPH-4E4F 0 100 200 300 400 500 600 |
|
|
| 乐 | U+4E50 CJK UNIFIED IDEOGRAPH-4E50 0 100 200 300 600 |
|
楽
U+697D
blocked
樂
U+6A02
trad
|
| 乑 | U+4E51 CJK UNIFIED IDEOGRAPH-4E51 0 100 200 |
|
|
| 乒 | U+4E52 CJK UNIFIED IDEOGRAPH-4E52 0 100 200 300 600 |
|
|
| 乓 | U+4E53 CJK UNIFIED IDEOGRAPH-4E53 0 100 200 300 600 |
|
|
| 乔 | U+4E54 CJK UNIFIED IDEOGRAPH-4E54 0 100 200 300 600 |
|
喬
U+55AC
trad
|
| 乖 | U+4E56 CJK UNIFIED IDEOGRAPH-4E56 0 100 200 300 400 500 600 |
|
|
| 乗 | U+4E57 CJK UNIFIED IDEOGRAPH-4E57 0 100 200 300 400 600 |
|
乘
U+4E58
both
|
| 乘 | U+4E58 CJK UNIFIED IDEOGRAPH-4E58 0 100 200 300 400 500 600 |
|
乗
U+4E57
blocked
|
| 乙 | U+4E59 CJK UNIFIED IDEOGRAPH-4E59 0 100 200 300 400 500 600 |
|
|
| 乚 | U+4E5A CJK UNIFIED IDEOGRAPH-4E5A 0 100 200 |
|
|
| 乛 | U+4E5B CJK UNIFIED IDEOGRAPH-4E5B 0 100 200 |
|
|
| 乜 | U+4E5C CJK UNIFIED IDEOGRAPH-4E5C 0 100 200 300 600 |
|
|
| 九 | U+4E5D CJK UNIFIED IDEOGRAPH-4E5D 0 100 200 300 400 500 600 |
|
|
| 乞 | U+4E5E CJK UNIFIED IDEOGRAPH-4E5E 0 100 200 300 400 500 600 |
|
|
| 也 | U+4E5F CJK UNIFIED IDEOGRAPH-4E5F 0 100 200 300 400 500 600 |
|
|
| 习 | U+4E60 CJK UNIFIED IDEOGRAPH-4E60 0 100 200 300 600 |
|
習
U+7FD2
trad
|
| 乡 | U+4E61 CJK UNIFIED IDEOGRAPH-4E61 0 100 200 300 600 |
|
郷
U+90F7
blocked
鄉
U+9109
trad
鄕
U+9115
blocked
|
| 乢 | U+4E62 CJK UNIFIED IDEOGRAPH-4E62 0 100 200 400 |
|
|
| 乣 | U+4E63 CJK UNIFIED IDEOGRAPH-4E63 0 100 200 |
|
|
| 乤 | U+4E64 CJK UNIFIED IDEOGRAPH-4E64 0 100 200 |
|
|
| 乥 | U+4E65 CJK UNIFIED IDEOGRAPH-4E65 0 100 200 |
|
|
| 书 | U+4E66 CJK UNIFIED IDEOGRAPH-4E66 0 100 200 300 600 |
|
書
U+66F8
trad
|
| 乧 | U+4E67 CJK UNIFIED IDEOGRAPH-4E67 0 100 200 |
|
|
| 乩 | U+4E69 CJK UNIFIED IDEOGRAPH-4E69 0 100 200 300 600 |
|
稽
U+7A3D
blocked
|
| 乪 | U+4E6A CJK UNIFIED IDEOGRAPH-4E6A 0 100 200 600 |
|
|
| 乫 | U+4E6B CJK UNIFIED IDEOGRAPH-4E6B 0 100 200 500 600 |
|
|
| 乬 | U+4E6C CJK UNIFIED IDEOGRAPH-4E6C 0 100 200 |
|
|
| 乭 | U+4E6D CJK UNIFIED IDEOGRAPH-4E6D 0 100 200 500 600 |
|
|
| 乮 | U+4E6E CJK UNIFIED IDEOGRAPH-4E6E 0 100 200 |
|
|
| 乯 | U+4E6F CJK UNIFIED IDEOGRAPH-4E6F 0 100 200 |
|
|
| 买 | U+4E70 CJK UNIFIED IDEOGRAPH-4E70 0 100 200 300 600 |
|
買
U+8CB7
trad
|
| 乱 | U+4E71 CJK UNIFIED IDEOGRAPH-4E71 0 100 200 300 400 600 |
|
乿
U+4E7F
blocked
亂
U+4E82
trad
|
| 乲 | U+4E72 CJK UNIFIED IDEOGRAPH-4E72 0 100 200 |
|
|
| 乳 | U+4E73 CJK UNIFIED IDEOGRAPH-4E73 0 100 200 300 400 500 600 |
|
|
| 乴 | U+4E74 CJK UNIFIED IDEOGRAPH-4E74 0 100 200 |
|
|
| 乵 | U+4E75 CJK UNIFIED IDEOGRAPH-4E75 0 100 200 |
|
|
| 乶 | U+4E76 CJK UNIFIED IDEOGRAPH-4E76 0 100 200 500 600 |
|
|
| 乷 | U+4E77 CJK UNIFIED IDEOGRAPH-4E77 0 100 200 500 600 |
|
|
| 乸 | U+4E78 CJK UNIFIED IDEOGRAPH-4E78 0 100 200 300 600 |
|
|
| 乺 | U+4E7A CJK UNIFIED IDEOGRAPH-4E7A 0 100 200 |
|
|
| 乻 | U+4E7B CJK UNIFIED IDEOGRAPH-4E7B 0 100 200 |
|
|
| 乼 | U+4E7C CJK UNIFIED IDEOGRAPH-4E7C 0 100 200 |
|
|
| 乽 | U+4E7D CJK UNIFIED IDEOGRAPH-4E7D 0 100 200 |
|
|
| 乾 | U+4E7E CJK UNIFIED IDEOGRAPH-4E7E 0 100 200 300 400 500 600 |
|
亁
U+4E81
blocked
干
U+5E72
simp
幹
U+5E79
blocked
榦
U+69A6
blocked
漧
U+6F27
blocked
|
| 乿 | U+4E7F CJK UNIFIED IDEOGRAPH-4E7F 0 100 200 |
|
乱
U+4E71
simp
亂
U+4E82
blocked
|
| 亀 | U+4E80 CJK UNIFIED IDEOGRAPH-4E80 0 100 200 400 600 |
|
龜
U+9F9C
trad
龟
U+9F9F
simp
|
| 亁 | U+4E81 CJK UNIFIED IDEOGRAPH-4E81 0 100 200 300 |
|
乾
U+4E7E
trad
干
U+5E72
simp
幹
U+5E79
blocked
榦
U+69A6
blocked
漧
U+6F27
blocked
|
| 亂 | U+4E82 CJK UNIFIED IDEOGRAPH-4E82 0 100 200 300 400 500 600 |
|
乱
U+4E71
simp
乿
U+4E7F
blocked
|
| 亃 | U+4E83 CJK UNIFIED IDEOGRAPH-4E83 0 100 200 |
|
|
| 亄 | U+4E84 CJK UNIFIED IDEOGRAPH-4E84 0 100 200 |
|
|
| 亅 | U+4E85 CJK UNIFIED IDEOGRAPH-4E85 0 100 200 400 |
|
|
| 了 | U+4E86 CJK UNIFIED IDEOGRAPH-4E86 0 100 200 300 400 500 600 |
|
暸
U+66B8
blocked
瞭
U+77AD
trad
|
| 亇 | U+4E87 CJK UNIFIED IDEOGRAPH-4E87 0 100 200 |
|
|
| 予 | U+4E88 CJK UNIFIED IDEOGRAPH-4E88 0 100 200 300 400 500 600 |
|
|
| 争 | U+4E89 CJK UNIFIED IDEOGRAPH-4E89 0 100 200 300 400 600 |
|
爭
U+722D
trad
|
| 亊 | U+4E8A CJK UNIFIED IDEOGRAPH-4E8A 0 400 Not part of repertoire |
|
事
U+4E8B
blocked
|
| 事 | U+4E8B CJK UNIFIED IDEOGRAPH-4E8B 0 100 200 300 400 500 600 |
|
亊
U+4E8A
blocked
|
| 二 | U+4E8C CJK UNIFIED IDEOGRAPH-4E8C 0 100 200 300 400 500 600 |
|
弍
U+5F0D
blocked
貮
U+8CAE
blocked
貳
U+8CB3
blocked
贰
U+8D30
blocked
|
| 亍 | U+4E8D CJK UNIFIED IDEOGRAPH-4E8D 0 100 200 300 |
|
|
| 于 | U+4E8E CJK UNIFIED IDEOGRAPH-4E8E 0 100 200 300 400 500 600 |
|
扵
U+6275
blocked
於
U+65BC
blocked
|
| 亏 | U+4E8F CJK UNIFIED IDEOGRAPH-4E8F 0 100 200 300 600 |
|
虧
U+8667
trad
|
| 亐 | U+4E90 CJK UNIFIED IDEOGRAPH-4E90 0 100 200 500 600 |
|
|
| 云 | U+4E91 CJK UNIFIED IDEOGRAPH-4E91 0 100 200 300 400 500 600 |
|
雲
U+96F2
trad
|
| 互 | U+4E92 CJK UNIFIED IDEOGRAPH-4E92 0 100 200 300 400 500 600 |
|
|
| 亓 | U+4E93 CJK UNIFIED IDEOGRAPH-4E93 0 100 200 300 600 |
|
丌
U+4E0C
blocked
其
U+5176
blocked
|
| 五 | U+4E94 CJK UNIFIED IDEOGRAPH-4E94 0 100 200 300 400 500 600 |
|
伍
U+4F0D
blocked
|
| 井 | U+4E95 CJK UNIFIED IDEOGRAPH-4E95 0 100 200 300 400 500 600 |
|
丼
U+4E3C
blocked
|
| 亗 | U+4E97 CJK UNIFIED IDEOGRAPH-4E97 0 100 200 |
|
岁
U+5C81
simp
歲
U+6B72
trad
歳
U+6B73
blocked
|
| 亘 | U+4E98 CJK UNIFIED IDEOGRAPH-4E98 0 100 200 300 400 500 600 |
|
亙
U+4E99
trad
|
| 亙 | U+4E99 CJK UNIFIED IDEOGRAPH-4E99 0 100 200 300 400 600 |
|
亘
U+4E98
simp
|
| 亚 | U+4E9A CJK UNIFIED IDEOGRAPH-4E9A 0 100 200 300 600 |
|
亜
U+4E9C
blocked
亞
U+4E9E
trad
|
| 些 | U+4E9B CJK UNIFIED IDEOGRAPH-4E9B 0 100 200 300 400 500 600 |
|
|
| 亜 | U+4E9C CJK UNIFIED IDEOGRAPH-4E9C 0 100 200 400 600 |
|
亚
U+4E9A
simp
亞
U+4E9E
trad
|
| 亝 | U+4E9D CJK UNIFIED IDEOGRAPH-4E9D 0 100 200 300 |
|
斉
U+6589
blocked
齊
U+9F4A
trad
齐
U+9F50
simp
|
| 亞 | U+4E9E CJK UNIFIED IDEOGRAPH-4E9E 0 100 200 300 400 500 600 |
|
亚
U+4E9A
simp
亜
U+4E9C
blocked
|
| 亟 | U+4E9F CJK UNIFIED IDEOGRAPH-4E9F 0 100 200 300 400 600 |
|
|
| 亠 | U+4EA0 CJK UNIFIED IDEOGRAPH-4EA0 0 100 200 400 |
|
|
| 亡 | U+4EA1 CJK UNIFIED IDEOGRAPH-4EA1 0 100 200 300 400 500 600 |
|
亾
U+4EBE
blocked
兦
U+5166
blocked
|
| 亢 | U+4EA2 CJK UNIFIED IDEOGRAPH-4EA2 0 100 200 300 400 500 600 |
|
|
| 交 | U+4EA4 CJK UNIFIED IDEOGRAPH-4EA4 0 100 200 300 400 500 600 |
|
|
| 亥 | U+4EA5 CJK UNIFIED IDEOGRAPH-4EA5 0 100 200 300 400 500 600 |
|
|
| 亦 | U+4EA6 CJK UNIFIED IDEOGRAPH-4EA6 0 100 200 300 400 500 600 |
|
Variants
Code points grouped into sets of mutual variants. Every member of a set produces the same set of variant labels, so a registration of one has implications for all the others. Sets of a single member are omitted, as are the identity mappings RFC 7940 requires each member to declare.
-
喦壧岩嵒巌巖碞礹
Source Direction Target Disposition Ref Comment 喦 U+55A6 ↔ 壧 U+58E7 blocked 101 201 喦 U+55A6 ⇆ 岩 U+5CA9 → simp ← blocked 101 201 喦 U+55A6 ↔ 嵒 U+5D52 blocked 101 201 喦 U+55A6 ↔ 巌 U+5DCC blocked 101 201 喦 U+55A6 ↔ 巖 U+5DD6 blocked 101 201 喦 U+55A6 ↔ 碞 U+789E blocked 101 201 喦 U+55A6 ↔ 礹 U+7939 blocked 101 201 壧 U+58E7 ⇆ 岩 U+5CA9 → simp ← blocked 101 201 壧 U+58E7 ↔ 嵒 U+5D52 blocked 101 201 壧 U+58E7 ↔ 巌 U+5DCC blocked 101 201 壧 U+58E7 ↔ 巖 U+5DD6 blocked 101 201 壧 U+58E7 ↔ 碞 U+789E blocked 101 201 ↔ declared both ways ⇆ both ways, different disposition each way → one direction only
-
坛埮墰墵壇壜罈罎
Source Direction Target Disposition Ref Comment 坛 U+575B ↔ 埮 U+57EE blocked 101 203 坛 U+575B ↔ 墰 U+58B0 blocked 101 203 坛 U+575B ↔ 墵 U+58B5 blocked 101 203 坛 U+575B ⇆ 壇 U+58C7 → trad-1 ← simp 101 201 坛 U+575B ↔ 壜 U+58DC blocked 101 201 坛 U+575B ⇆ 罈 U+7F48 → trad-2 ← simp 101 201 坛 U+575B ⇆ 罎 U+7F4E → blocked ← simp 101 201 埮 U+57EE ↔ 墰 U+58B0 blocked 101 203 埮 U+57EE ↔ 墵 U+58B5 blocked 101 203 埮 U+57EE ↔ 壇 U+58C7 blocked 101 203 埮 U+57EE ↔ 壜 U+58DC blocked 101 203 埮 U+57EE ↔ 罈 U+7F48 blocked 101 203 ↔ declared both ways ⇆ both ways, different disposition each way → one direction only
-
总惣捴搃摠総縂總
Source Direction Target Disposition Ref Comment 总 U+603B ⇆ 惣 U+60E3 → blocked ← simp 103 203 301 总 U+603B ⇆ 捴 U+6374 → blocked ← simp 101 201 301 总 U+603B ⇆ 搃 U+6403 → blocked ← simp 101 201 301 总 U+603B ⇆ 摠 U+6460 → blocked ← simp 101 201 301 总 U+603B ⇆ 総 U+7DCF → blocked ← simp 101 201 301 总 U+603B ⇆ 縂 U+7E02 → blocked ← simp 101 201 301 总 U+603B ⇆ 總 U+7E3D → trad ← simp 101 201 301 惣 U+60E3 ↔ 捴 U+6374 blocked 103 203 301 惣 U+60E3 ↔ 搃 U+6403 blocked 103 203 301 惣 U+60E3 ↔ 摠 U+6460 blocked 103 203 301 惣 U+60E3 ↔ 総 U+7DCF blocked 103 203 301 惣 U+60E3 ↔ 縂 U+7E02 blocked 103 203 301 ↔ declared both ways ⇆ both ways, different disposition each way → one direction only
-
剳劄扎札箚紥紮
Source Direction Target Disposition Ref Comment 剳 U+5273 ⇆ 劄 U+5284 → trad ← blocked 101 201 剳 U+5273 ↔ 扎 U+624E blocked 101 201 剳 U+5273 ⇆ 札 U+672D → simp ← blocked 101 201 剳 U+5273 ↔ 箚 U+7B9A blocked 101 201 剳 U+5273 ↔ 紥 U+7D25 blocked 101 201 剳 U+5273 ↔ 紮 U+7D2E blocked 101 201 劄 U+5284 ↔ 扎 U+624E blocked 101 201 劄 U+5284 ⇆ 札 U+672D → simp ← blocked 101 201 劄 U+5284 ⇆ 箚 U+7B9A → blocked ← trad 101 201 劄 U+5284 ↔ 紥 U+7D25 blocked 101 201 劄 U+5284 ↔ 紮 U+7D2E blocked 101 201 扎 U+624E ↔ 札 U+672D blocked 101 201 ↔ declared both ways ⇆ both ways, different disposition each way → one direction only
-
囘回囬廻廽迴逥
Source Direction Target Disposition Ref Comment 囘 U+56D8 ⇆ 回 U+56DE → both ← blocked 101 201 囘 U+56D8 ↔ 囬 U+56EC blocked 101 201 囘 U+56D8 ↔ 廻 U+5EFB blocked 101 201 囘 U+56D8 ↔ 廽 U+5EFD blocked 101 201 囘 U+56D8 ↔ 迴 U+8FF4 blocked 101 201 囘 U+56D8 ↔ 逥 U+9025 blocked 101 201 回 U+56DE ⇆ 囬 U+56EC → blocked ← both 101 201 回 U+56DE ⇆ 廻 U+5EFB → blocked ← simp 101 201 回 U+56DE ⇆ 廽 U+5EFD → blocked ← simp 101 201 回 U+56DE ⇆ 迴 U+8FF4 → trad ← simp 101 201 回 U+56DE ⇆ 逥 U+9025 → blocked ← simp 101 201 囬 U+56EC ↔ 廻 U+5EFB blocked 101 201 ↔ declared both ways ⇆ both ways, different disposition each way → one direction only
-
宁寍寕寗寜寧甯
Source Direction Target Disposition Ref Comment 宁 U+5B81 ⇆ 寍 U+5BCD → blocked ← simp 101 201 701 宁 U+5B81 ⇆ 寕 U+5BD5 → blocked ← simp 101 201 701 宁 U+5B81 ↔ 寗 U+5BD7 blocked 101 201 宁 U+5B81 ⇆ 寜 U+5BDC → blocked ← simp 101 201 701 宁 U+5B81 ⇆ 寧 U+5BE7 → trad ← simp 101 201 701 宁 U+5B81 ↔ 甯 U+752F blocked 101 203 寍 U+5BCD ↔ 寕 U+5BD5 blocked 101 201 701 寍 U+5BCD ↔ 寗 U+5BD7 blocked 101 201 寍 U+5BCD ↔ 寜 U+5BDC blocked 101 201 701 寍 U+5BCD ↔ 寧 U+5BE7 blocked 101 201 701 寍 U+5BCD ↔ 甯 U+752F blocked 101 203 寕 U+5BD5 ↔ 寗 U+5BD7 blocked 101 201 ↔ declared both ways ⇆ both ways, different disposition each way → one direction only
-
斗闘鬥鬦鬪鬬鬭
Source Direction Target Disposition Ref Comment 斗 U+6597 ⇆ 闘 U+95D8 → blocked ← simp 101 201 斗 U+6597 ⇆ 鬥 U+9B25 → trad ← simp 101 201 斗 U+6597 ⇆ 鬦 U+9B26 → blocked ← simp 101 201 斗 U+6597 ⇆ 鬪 U+9B2A → blocked ← simp 101 201 斗 U+6597 ⇆ 鬬 U+9B2C → blocked ← simp 101 201 斗 U+6597 ⇆ 鬭 U+9B2D → blocked ← simp 101 201 闘 U+95D8 ⇆ 鬥 U+9B25 → trad ← blocked 101 201 闘 U+95D8 ↔ 鬦 U+9B26 blocked 101 201 闘 U+95D8 ↔ 鬪 U+9B2A blocked 101 201 闘 U+95D8 ↔ 鬬 U+9B2C blocked 101 201 闘 U+95D8 ↔ 鬭 U+9B2D blocked 101 201 鬥 U+9B25 ⇆ 鬦 U+9B26 → blocked ← trad 101 201 ↔ declared both ways ⇆ both ways, different disposition each way → one direction only
-
硷碱礆险険險鹼
Source Direction Target Disposition Ref Comment 硷 U+7877 ↔ 碱 U+78B1 blocked 101 201 硷 U+7877 ⇆ 礆 U+7906 → blocked ← simp 101 201 硷 U+7877 ↔ 险 U+9669 blocked 101 201 硷 U+7877 ↔ 険 U+967A blocked 801 硷 U+7877 ↔ 險 U+96AA blocked 101 201 硷 U+7877 ⇆ 鹼 U+9E7C → trad ← simp 101 201 碱 U+78B1 ↔ 礆 U+7906 blocked 101 201 碱 U+78B1 ↔ 险 U+9669 blocked 101 201 碱 U+78B1 ↔ 険 U+967A blocked 801 碱 U+78B1 ↔ 險 U+96AA blocked 101 201 碱 U+78B1 ⇆ 鹼 U+9E7C → trad ← blocked 101 201 礆 U+7906 ↔ 险 U+9669 blocked 101 201 ↔ declared both ways ⇆ both ways, different disposition each way → one direction only
-
粗蔍觕麁麄麆麤
Source Direction Target Disposition Ref Comment 粗 U+7C97 ⇆ 蔍 U+850D → blocked ← simp 101 201 粗 U+7C97 ⇆ 觕 U+89D5 → blocked ← simp 101 201 粗 U+7C97 ⇆ 麁 U+9E81 → blocked ← both 101 201 粗 U+7C97 ⇆ 麄 U+9E84 → blocked ← both 101 201 粗 U+7C97 ⇆ 麆 U+9E86 → blocked ← simp 101 201 粗 U+7C97 ⇆ 麤 U+9EA4 → blocked ← simp 101 201 蔍 U+850D ↔ 觕 U+89D5 blocked 101 201 蔍 U+850D ↔ 麁 U+9E81 blocked 101 201 蔍 U+850D ↔ 麄 U+9E84 blocked 101 201 蔍 U+850D ↔ 麆 U+9E86 blocked 101 201 蔍 U+850D ↔ 麤 U+9EA4 blocked 101 201 觕 U+89D5 ↔ 麁 U+9E81 blocked 101 201 ↔ declared both ways ⇆ both ways, different disposition each way → one direction only
-
並併倂并幷竝
Source Direction Target Disposition Ref Comment 並 U+4E26 ↔ 併 U+4F75 blocked 101 201 並 U+4E26 ↔ 倂 U+5002 blocked 101 201 並 U+4E26 ⇆ 并 U+5E76 → simp ← trad-1 101 201 並 U+4E26 ↔ 幷 U+5E77 blocked 101 201 並 U+4E26 ⇆ 竝 U+7ADD → blocked ← trad 101 201 併 U+4F75 ⇆ 倂 U+5002 → blocked ← trad 101 201 併 U+4F75 ⇆ 并 U+5E76 → simp ← trad-2 101 201 併 U+4F75 ↔ 幷 U+5E77 blocked 101 201 併 U+4F75 ↔ 竝 U+7ADD blocked 101 201 倂 U+5002 ⇆ 并 U+5E76 → simp ← blocked 101 201 倂 U+5002 ↔ 幷 U+5E77 blocked 101 201 501 倂 U+5002 ↔ 竝 U+7ADD blocked 101 201 ↔ declared both ways ⇆ both ways, different disposition each way → one direction only
Rules
Conditions evaluated against a whole label, or against the context around a
single code point. The notation borrows from regular expressions:
^ and $ anchor to the start and end of a label,
. matches any code point, (?= ) and
(?<= ) look ahead and behind, and * and
+ repeat. Two symbols are specific to rulesets:
◆ is the code point being tested, and
⟨name⟩ refers to another rule.
leading-combining-mark MSR default
Default WLE rule matching labels with leading combining marks
^ ({gc:Mn} ∪ {gc:Mc})
Structure
-
^start -
({gc:Mn} ∪ {gc:Mc})union-
{gc:Mn}class -
{gc:Mc}class
-
Referenced by 1 definition
- action 1 (invalid)
Actions
Actions are evaluated in the order shown. The first action whose conditions match determines the disposition of the label.
| # | Disposition | Conditions |
|---|---|---|
| 1 |
invalid
|
label matches leading-combining-mark 100 labels with leading combining marks are invalid MSR default |
| 2 |
invalid
|
any variant is out-of-repertoire-var 100 any variant label with a code point out of repertoire is invalid MSR default |
| 3 |
blocked
|
any variant is blocked 100 any variant label containing blocked variants is blocked MSR default |
| 4 |
allocatable
|
all variants are allocatable 100 variant labels with all variants allocatable are allocatable MSR default |
| 5 |
valid
|
all variants are r-neitherr-tradr-simpr-both any remaining label containing only original code points is valid |
| 6 |
allocatable
|
only variants of type simpr-simpbothr-bothsimp-1 any label of simplified type 1 is allocatable |
| 7 |
allocatable
|
only variants of type simpr-simpbothr-bothsimp-2 any label of simplified type 2 is allocatable |
| 8 |
allocatable
|
only variants of type tradr-tradbothr-bothtrad-1 any label of traditional type 1 is allocatable |
| 9 |
allocatable
|
only variants of type tradr-tradbothr-bothtrad-2 any label of traditional type 2 is allocatable |
| 10 |
blocked
|
any variant is simptradbothsimp-1simp-2trad-1trad-2 any other mixed labels are blocked |
| 11 |
valid
|
any label default 100 catch all (default action) MSR default |
References
| Ref | Source |
|---|---|
| 0 | The Unicode Standard, Version 1.1 |
| 3 | The Unicode Standard, Version 3.0 |
| 4 | The Unicode Standard, Version 3.1 |
| 100 | CDNC Chinese Characters and Variants Table https://www.cdnc.asia/file/unicode-1-2.txt |
| 200 | DotAsia, .ASIA ZH IDN Language Table https://www.iana.org/domains/idn-tables/tables/asia_zh_1.1.txt |
| 300 | Table of General Standard Chinese Characters by China’s State Council https://www.gov.cn/zwgk/2013-08/19/content_2469793.htm |
| 400 | JGP Repertoire 201703, as documented in Appendix B |
| 500 | KGP Repertoire 201703, as documented in Appendix C |
| 600 | IICORE International Ideographs Core https://hanzi.unihan.com.cn/downloads/IIcoreMappingTable.txt |
| 101 | CDNC Chinese Characters and Variants Table, as documented in Appendices G.1 and G.2 |
| 102 | CDNC Chinese Characters and Variants Table, as documented in Appendices G.1 and G.2 |
| 103 | CDNC Chinese Characters and Variants Table, as documented in Appendices G.1 and G.2 |
| 201 | dotASIA ZH IDN Language Table https://www.iana.org/domains/idn-tables/tables/asia_zh_1.1.txt |
| 202 | dotASIA ZH IDN Language Table https://www.iana.org/domains/idn-tables/tables/asia_zh_1.1.txt |
| 203 | dotASIA ZH IDN Language Table https://www.iana.org/domains/idn-tables/tables/asia_zh_1.1.txt |
| 301 | CGP Internal Review, as documented in Appendix N |
| 501 | KLGR Proposal |
| 701 | IP Communication May 2019, as documented in Appendix F |
| 801 | Out-of-repertoire variants |