Thaana (script, RSP full variant set)
Second-Level Reference Label Generation Rules, 25 October 2024 Current
Summary
| Version | 1 — Second Level Reference LGR |
|---|---|
| Date | |
| Tag |
und-Thaa (Thaana)
|
| Unicode | 11.0.0 |
| Source file | lgr-second-level-thaana-rsp-full-variant-script-25oct24-en.xml (109.1kb) |
Description
Reference Label Generation Rules for the Thaana Script
Overview
This document specifies a set of Label Generation Rules (LGR) for the Thaana script using a script-specific repertoire for the second level domain or domains identified above. The format of this file follows [RFC 7940]. This LGR is adapted from the “Reference LGR for the Second Level for the Thaana Script” [Ref-LGR-und-Thaa], for details, see Change History below.
Standalone LGR: This LGR is designed to be used in a zone that does not cater to IDNs other than those valid under this LGR. This LGR lacks features that would allow its use in the context of another LGR in the same zone, and it may contain other features incompatible with such use.
For details and additional background on the Thaana script, see "Thaana Script Reference Label Generation Rules for Second-Level Domain Names" [Proposal-Thaana].
Repertoire
The repertoire includes the 49 letters and diacritics of the Thaana script in everyday use as defined in Section 5.1 “Included Code Points” in [Proposal-Thaana].
U+07B1 THAANA LETTER NAA (baru nūnu) is a dialect specific consonant. Given the resurgence of the use of the consonant in online writing and social media, a decision was made to include it in the repertoire at this time, despite it not being officially recognized as part of the base consonants.
For the second level, the repertoire has been augmented with the ASCII digits, U+0030 to U+0039, plus U+002D HYPHEN-MINUS, for a total of 61 repertoire elements.
Repertoire Listing: Each code point or range is tagged with the script or scripts with which the code point is used and one or more other character categories. For each repertoire element, one or more references document sufficient justification for inclusion in the repertoire; see the “References” below.
Variants
This LGR defines a number of in-script variants as described in Section 6.1 “In-script Variants”of [Proposal-Thaana]. No cross-script variants have been identified based on any discernable similarity with another script or otherwise required for the security of the Thaana LGR. However, if used in the context of an LGR for any other zone, variants may be required for the digits.
Variant Disposition: All variants are of type “blocked”, making labels that differ only by these variants mutually exclusive: whichever label containing either of these variants is chosen earlier would be delegated, while any other equivalent labels should be blocked. There is no preference among these labels.
This LGR does not define allocatable variants.
The specification of variants in this LGR follows the guidelines in [RFC 8228].
Character Classes
Thaana has 25 consonants and 11 vowels. The first nine letters of Thaana are derived from the Arabic/Persian numerals (see below). The vowels are written above/below the letters.
- Common-digits — ASCII digits: U+0030 to U+0039.
- Consonants — in the Thaana script, consonants are base characters and all but one must be followed by a vowel. Additional restrictions apply to the two consonants Noonu and Raa.
- Consonants for Arabic — additions in the script for transcribing Arabic and other loan words. For the purposes of this LGR, there is no distinction between these and other consonants.
- Vowels — vowels are combining marks that always follow a consonant.
Whole Label Evaluation (WLE) and Context Rules
Common Rules
By default, the LGR includes the rules and actions to implement the following restrictions mandated by the IDNA protocol. They are marked with ⍟.
- Hyphen Restrictions — restrictions on the allowable placement of hyphens (no leading/ending hyphen and no hyphen in positions 3 and 4). These restrictions are described in Section 4.2.3.1 of RFC 5891 [150]. They are implemented here as context rule on U+002D (-) HYPHEN-MINUS.
- Leading Combining Marks — restrictions on the allowable placement of combining marks (no leading combining mark). This rule is described in Section 4.2.3.2 of RFC 5891 [150].
Script-specific rules in this LGR already prevent combining marks in leading position making the "leading-combining-mark" rule technically redundant. It is retained here for consistency.
Right-to-Left Rules
- leading-digit — restrictions on the allowable placement of digits in a right-to-left context (no leading digit), (see section 2.1 of RFC 5893 [160]); implemented here as a context rule on each digit.
Default Actions
This LGR includes the complete set default actions for LGRs as well as the action needed to invalidate labels with misplaced combining marks. They are marked with ⍟. For a description see [RFC 7940] and [150]. An additional action is triggered by mixed digit labels.
Script-specific Rules
The LGR defines the following script-specific rules concerning the placement of vowels and preventing some combinations from starting a word.
- follows-C-or-N — WLE 1: a vowel always follows a consonant or including Noonu and Raa.
- followed-by-V — WLE 2: a consonant, except Noonu or Raa is always followed by a vowel.
- start-of-word-followed-by-C — WLE 3: N followed by C cannot start a word, that is, it cannot be the start of a label, or follow a hyphen or digit.
- followed-by-NC-or-NN= — WLE 4: N cannot be follwoed by NC or NN.
Methodology
This Second Level Reference LGR for the Thaana Script was developed by the Thaana community and edited by Asmus Freytag and Michel Suignard, based on community feedback and public review.
Changes from Version Dated 25 October 2024
This version modifies the Second Level Reference LGR for the Thaana Script [Ref-LGR-und-Thaa] by injecting the complete (maximal) set of cross-repertoire variants, including any imposed by transitivity. Injected variants are marked by special comments. Any character classes, context and WLE rules required for testing are also imported. In all other respects, description or annotations have not been updated to reflect the injected variants. Any LGR elements that might pose a possible conflict when the LGR is used with the Common LGR for cross-repertoire variant resolution are clearly marked. All modifications are carried out mechanically; there may be an occasional context rule or similar that is injected because its definition relates to some repertoire element even though it can never be triggered by any label valid under the modified LGR.
References
This document cites the following general references.
- [Guidelines]
- ICANN, “Guidelines for Developing Reference LGRs for the Second Level”, (Los Angeles, California: ICANN, 27 May 2020), https://www.icann.org/en/system/files/files/lgr-guidelines-second-level-27may20-en.pdf
- [Level-2-Overview]
- Internet Corporation for Assigned Names and Numbers, (ICANN),“Reference Label Generation Rules (LGR) for the Second Level: Overview and Summary” (PDF), (Los Angeles, California: ICANN, 25 October 2024), https://www.icann.org/en/system/files/files/level2-lgr-overview-summary-25oct24-en.pdf
- [Proposal-Thaana]
- "Thaana Script Reference Label Generation Rules for Second-Level Domain Names", 12 September 2024, https://www.icann.org/en/system/files/files/proposal-thaana-second-level-12Sep24-en.pdf
- [Ref-LGR-und-Thaa]
- ICANN, Second Level Reference Label Generation Rules for the Thaana Script (und-Thaa), 25 October 2024 (XML) https://www.icann.org/sites/default/files/packages/lgr/lgr-second-level-thaana-script-25oct24-en.xml non-normative HTML presentation: https://www.icann.org/sites/default/files/packages/lgr/lgr-second-level-thaana-script-25oct24-en.html
- [RFC 7940]
- Davies, K. and A. Freytag, “Representing Label Generation Rulesets Using XML”, RFC 7940, August 2016, https://www.rfc-editor.org/info/rfc7940
- [RFC 8228]
- A. Freytag, “Guidance on Designing Label Generation Rulesets (LGRs) Supporting Variant Labels”, RFC 8228, August 2017, https://www.rfc-editor.org/info/rfc8228
- [UNICODE 11.0.0]
- The Unicode Consortium. The Unicode Standard, Version 11.0.0, (Mountain View, CA: The Unicode Consortium, 2018. ISBN 978-1-936213-19-1) https://www.unicode.org/versions/Unicode11.0.0/
References [0] to [3] refer to the Unicode Standard versions in which the corresponding code points were initially encoded. References [401] and above correspond to sources given in [Proposal-Thaana] justifying the inclusion of the corresponding cod5 points. Entries in the table may have multiple source reference values. In the listing of whole label evaluation and context rules, references [150] and [160] indicate the source for common rules.
Repertoire
| Glyph | Code point | Tags and context | Variants |
|---|---|---|---|
| - | U+002D HYPHEN-MINUS |
|
·
U+00B7
blocked
(injected)
|
| 0 | U+0030 DIGIT ZERO (context not found in "Common") |
|
٠
U+0660
blocked
(injected)
۰
U+06F0
blocked
(injected)
०
U+0966
blocked
(injected)
০
U+09E6
blocked
(injected)
૦
U+0AE6
blocked
(injected)
೦
U+0CE6
blocked
(injected)
+4 more
|
| 1 | U+0031 DIGIT ONE (context not found in "Common") |
|
١
U+0661
blocked
(injected)
۱
U+06F1
blocked
(injected)
१
U+0967
blocked
(injected)
১
U+09E7
blocked
(injected)
૧
U+0AE7
blocked
(injected)
೧
U+0CE7
blocked
(injected)
+4 more
|
| 2 | U+0032 DIGIT TWO (context not found in "Common") |
|
٢
U+0662
blocked
(injected)
۲
U+06F2
blocked
(injected)
२
U+0968
blocked
(injected)
২
U+09E8
blocked
(injected)
ર
U+0AB0
blocked
(injected)
૨
U+0AE8
blocked
(injected)
+5 more
|
| 3 | U+0033 DIGIT THREE (context not found in "Common") |
|
٣
U+0663
blocked
(injected)
۳
U+06F3
blocked
(injected)
३
U+0969
blocked
(injected)
৩
U+09E9
blocked
(injected)
૩
U+0AE9
blocked
(injected)
೩
U+0CE9
blocked
(injected)
+4 more
|
| 4 | U+0034 DIGIT FOUR (context not found in "Common") |
|
٤
U+0664
blocked
(injected)
۴
U+06F4
blocked
(injected)
४
U+096A
blocked
(injected)
৪
U+09EA
blocked
(injected)
૪
U+0AEA
blocked
(injected)
೪
U+0CEA
blocked
(injected)
+4 more
|
| 5 | U+0035 DIGIT FIVE (context not found in "Common") |
|
٥
U+0665
blocked
(injected)
۵
U+06F5
blocked
(injected)
५
U+096B
blocked
(injected)
৫
U+09EB
blocked
(injected)
પ
U+0AAA
blocked
(injected)
૫
U+0AEB
blocked
(injected)
+5 more
|
| 6 | U+0036 DIGIT SIX (context not found in "Common") |
|
٦
U+0666
blocked
(injected)
۶
U+06F6
blocked
(injected)
६
U+096C
blocked
(injected)
৬
U+09EC
blocked
(injected)
૬
U+0AEC
blocked
(injected)
೬
U+0CEC
blocked
(injected)
+4 more
|
| 7 | U+0037 DIGIT SEVEN (context not found in "Common") |
|
٧
U+0667
blocked
(injected)
۷
U+06F7
blocked
(injected)
७
U+096D
blocked
(injected)
৭
U+09ED
blocked
(injected)
૭
U+0AED
blocked
(injected)
೭
U+0CED
blocked
(injected)
+4 more
|
| 8 | U+0038 DIGIT EIGHT (context not found in "Common") |
|
٨
U+0668
blocked
(injected)
۸
U+06F8
blocked
(injected)
८
U+096E
blocked
(injected)
৮
U+09EE
blocked
(injected)
૮
U+0AEE
blocked
(injected)
೮
U+0CEE
blocked
(injected)
+4 more
|
| 9 | U+0039 DIGIT NINE (context not found in "Common") |
|
٩
U+0669
blocked
(injected)
۹
U+06F9
blocked
(injected)
९
U+096F
blocked
(injected)
৯
U+09EF
blocked
(injected)
૯
U+0AEF
blocked
(injected)
೯
U+0CEF
blocked
(injected)
+4 more
|
| · | U+00B7 MIDDLE DOT Not part of repertoire (injected) | variant target only |
-
U+002D
blocked
(injected)
|
| ٠ | U+0660 ARABIC-INDIC DIGIT ZERO Not part of repertoire (injected) | variant target only |
0
U+0030
blocked
(injected)
۰
U+06F0
blocked
(injected)
०
U+0966
blocked
(injected)
০
U+09E6
blocked
(injected)
૦
U+0AE6
blocked
(injected)
೦
U+0CE6
blocked
(injected)
+4 more
|
| ١ | U+0661 ARABIC-INDIC DIGIT ONE Not part of repertoire (injected) | variant target only |
1
U+0031
blocked
(injected)
۱
U+06F1
blocked
(injected)
१
U+0967
blocked
(injected)
১
U+09E7
blocked
(injected)
૧
U+0AE7
blocked
(injected)
೧
U+0CE7
blocked
(injected)
+4 more
|
| ٢ | U+0662 ARABIC-INDIC DIGIT TWO Not part of repertoire (injected) | variant target only |
2
U+0032
blocked
(injected)
۲
U+06F2
blocked
(injected)
२
U+0968
blocked
(injected)
২
U+09E8
blocked
(injected)
ર
U+0AB0
blocked
(injected)
૨
U+0AE8
blocked
(injected)
+5 more
|
| ٣ | U+0663 ARABIC-INDIC DIGIT THREE Not part of repertoire (injected) | variant target only |
3
U+0033
blocked
(injected)
۳
U+06F3
blocked
(injected)
३
U+0969
blocked
(injected)
৩
U+09E9
blocked
(injected)
૩
U+0AE9
blocked
(injected)
೩
U+0CE9
blocked
(injected)
+4 more
|
| ٤ | U+0664 ARABIC-INDIC DIGIT FOUR Not part of repertoire (injected) | variant target only |
4
U+0034
blocked
(injected)
۴
U+06F4
blocked
(injected)
४
U+096A
blocked
(injected)
৪
U+09EA
blocked
(injected)
૪
U+0AEA
blocked
(injected)
೪
U+0CEA
blocked
(injected)
+4 more
|
| ٥ | U+0665 ARABIC-INDIC DIGIT FIVE Not part of repertoire (injected) | variant target only |
5
U+0035
blocked
(injected)
۵
U+06F5
blocked
(injected)
५
U+096B
blocked
(injected)
৫
U+09EB
blocked
(injected)
પ
U+0AAA
blocked
(injected)
૫
U+0AEB
blocked
(injected)
+5 more
|
| ٦ | U+0666 ARABIC-INDIC DIGIT SIX Not part of repertoire (injected) | variant target only |
6
U+0036
blocked
(injected)
۶
U+06F6
blocked
(injected)
६
U+096C
blocked
(injected)
৬
U+09EC
blocked
(injected)
૬
U+0AEC
blocked
(injected)
೬
U+0CEC
blocked
(injected)
+4 more
|
| ٧ | U+0667 ARABIC-INDIC DIGIT SEVEN Not part of repertoire (injected) | variant target only |
7
U+0037
blocked
(injected)
۷
U+06F7
blocked
(injected)
७
U+096D
blocked
(injected)
৭
U+09ED
blocked
(injected)
૭
U+0AED
blocked
(injected)
೭
U+0CED
blocked
(injected)
+4 more
|
| ٨ | U+0668 ARABIC-INDIC DIGIT EIGHT Not part of repertoire (injected) | variant target only |
8
U+0038
blocked
(injected)
۸
U+06F8
blocked
(injected)
८
U+096E
blocked
(injected)
৮
U+09EE
blocked
(injected)
૮
U+0AEE
blocked
(injected)
೮
U+0CEE
blocked
(injected)
+4 more
|
| ٩ | U+0669 ARABIC-INDIC DIGIT NINE Not part of repertoire (injected) | variant target only |
9
U+0039
blocked
(injected)
۹
U+06F9
blocked
(injected)
९
U+096F
blocked
(injected)
৯
U+09EF
blocked
(injected)
૯
U+0AEF
blocked
(injected)
೯
U+0CEF
blocked
(injected)
+4 more
|
| ۰ | U+06F0 EXTENDED ARABIC-INDIC DIGIT ZERO Not part of repertoire (injected) | variant target only |
0
U+0030
blocked
(injected)
٠
U+0660
blocked
(injected)
०
U+0966
blocked
(injected)
০
U+09E6
blocked
(injected)
૦
U+0AE6
blocked
(injected)
೦
U+0CE6
blocked
(injected)
+4 more
|
| ۱ | U+06F1 EXTENDED ARABIC-INDIC DIGIT ONE Not part of repertoire (injected) | variant target only |
1
U+0031
blocked
(injected)
١
U+0661
blocked
(injected)
१
U+0967
blocked
(injected)
১
U+09E7
blocked
(injected)
૧
U+0AE7
blocked
(injected)
೧
U+0CE7
blocked
(injected)
+4 more
|
| ۲ | U+06F2 EXTENDED ARABIC-INDIC DIGIT TWO Not part of repertoire (injected) | variant target only |
2
U+0032
blocked
(injected)
٢
U+0662
blocked
(injected)
२
U+0968
blocked
(injected)
২
U+09E8
blocked
(injected)
ર
U+0AB0
blocked
(injected)
૨
U+0AE8
blocked
(injected)
+5 more
|
| ۳ | U+06F3 EXTENDED ARABIC-INDIC DIGIT THREE Not part of repertoire (injected) | variant target only |
3
U+0033
blocked
(injected)
٣
U+0663
blocked
(injected)
३
U+0969
blocked
(injected)
৩
U+09E9
blocked
(injected)
૩
U+0AE9
blocked
(injected)
೩
U+0CE9
blocked
(injected)
+4 more
|
| ۴ | U+06F4 EXTENDED ARABIC-INDIC DIGIT FOUR Not part of repertoire (injected) | variant target only |
4
U+0034
blocked
(injected)
٤
U+0664
blocked
(injected)
४
U+096A
blocked
(injected)
৪
U+09EA
blocked
(injected)
૪
U+0AEA
blocked
(injected)
೪
U+0CEA
blocked
(injected)
+4 more
|
| ۵ | U+06F5 EXTENDED ARABIC-INDIC DIGIT FIVE Not part of repertoire (injected) | variant target only |
5
U+0035
blocked
(injected)
٥
U+0665
blocked
(injected)
५
U+096B
blocked
(injected)
৫
U+09EB
blocked
(injected)
પ
U+0AAA
blocked
(injected)
૫
U+0AEB
blocked
(injected)
+5 more
|
| ۶ | U+06F6 EXTENDED ARABIC-INDIC DIGIT SIX Not part of repertoire (injected) | variant target only |
6
U+0036
blocked
(injected)
٦
U+0666
blocked
(injected)
६
U+096C
blocked
(injected)
৬
U+09EC
blocked
(injected)
૬
U+0AEC
blocked
(injected)
೬
U+0CEC
blocked
(injected)
+4 more
|
| ۷ | U+06F7 EXTENDED ARABIC-INDIC DIGIT SEVEN Not part of repertoire (injected) | variant target only |
7
U+0037
blocked
(injected)
٧
U+0667
blocked
(injected)
७
U+096D
blocked
(injected)
৭
U+09ED
blocked
(injected)
૭
U+0AED
blocked
(injected)
೭
U+0CED
blocked
(injected)
+4 more
|
| ۸ | U+06F8 EXTENDED ARABIC-INDIC DIGIT EIGHT Not part of repertoire (injected) | variant target only |
8
U+0038
blocked
(injected)
٨
U+0668
blocked
(injected)
८
U+096E
blocked
(injected)
৮
U+09EE
blocked
(injected)
૮
U+0AEE
blocked
(injected)
೮
U+0CEE
blocked
(injected)
+4 more
|
| ۹ | U+06F9 EXTENDED ARABIC-INDIC DIGIT NINE Not part of repertoire (injected) | variant target only |
9
U+0039
blocked
(injected)
٩
U+0669
blocked
(injected)
९
U+096F
blocked
(injected)
৯
U+09EF
blocked
(injected)
૯
U+0AEF
blocked
(injected)
೯
U+0CEF
blocked
(injected)
+4 more
|
| ހ | U+0780 THAANA LETTER HAA 3 401 |
|
ޙ
U+0799
blocked
ޚ
U+079A
blocked
|
| ށ | U+0781 THAANA LETTER SHAVIYANI 3 401 |
|
ޝ
U+079D
blocked
|
| ނ | U+0782 THAANA LETTER NOONU 3 401 |
|
ޱ
U+07B1
blocked
|
| ރ | U+0783 THAANA LETTER RAA 3 401 |
|
ޜ
U+079C
blocked
|
| ބ | U+0784 THAANA LETTER BAA 3 401 |
|
|
| ޅ | U+0785 THAANA LETTER LHAVIYANI 3 401 |
|
|
| ކ | U+0786 THAANA LETTER KAAFU 3 401 |
|
|
| އ | U+0787 THAANA LETTER ALIFU 3 401 |
|
ޢ
U+07A2
blocked
ޣ
U+07A3
blocked
|
| ވ | U+0788 THAANA LETTER VAAVU 3 401 |
|
ޥ
U+07A5
blocked
|
| މ | U+0789 THAANA LETTER MEEMU 3 401 |
|
|
| ފ | U+078A THAANA LETTER FAAFU 3 401 |
|
|
| ދ | U+078B THAANA LETTER DHAALU 3 401 |
|
ޛ
U+079B
blocked
|
| ތ | U+078C THAANA LETTER THAA 3 401 |
|
ޘ
U+0798
blocked
ޠ
U+07A0
blocked
ޡ
U+07A1
blocked
|
| ލ | U+078D THAANA LETTER LAAMU 3 401 |
|
|
| ގ | U+078E THAANA LETTER GAAFU 3 401 |
|
ޤ
U+07A4
blocked
|
| ޏ | U+078F THAANA LETTER GNAVIYANI 3 401 |
|
|
| ސ | U+0790 THAANA LETTER SEENU 3 401 |
|
ޞ
U+079E
blocked
ޟ
U+079F
blocked
|
| ޑ | U+0791 THAANA LETTER DAVIYANI 3 401 |
|
|
| ޒ | U+0792 THAANA LETTER ZAVIYANI 3 401 |
|
|
| ޓ | U+0793 THAANA LETTER TAVIYANI 3 401 |
|
|
| ޔ | U+0794 THAANA LETTER YAA 3 401 |
|
|
| ޕ | U+0795 THAANA LETTER PAVIYANI 3 401 |
|
|
| ޖ | U+0796 THAANA LETTER JAVIYANI 3 401 |
|
|
| ޗ | U+0797 THAANA LETTER CHAVIYANI 3 401 |
|
|
| ޘ | U+0798 THAANA LETTER TTAA 3 401 |
|
ތ
U+078C
blocked
ޠ
U+07A0
blocked
ޡ
U+07A1
blocked
|
| ޙ | U+0799 THAANA LETTER HHAA 3 401 |
|
ހ
U+0780
blocked
ޚ
U+079A
blocked
|
| ޚ | U+079A THAANA LETTER KHAA 3 401 |
|
ހ
U+0780
blocked
ޙ
U+0799
blocked
|
| ޛ | U+079B THAANA LETTER THAALU 3 401 |
|
ދ
U+078B
blocked
|
| ޜ | U+079C THAANA LETTER ZAA 3 401 |
|
ރ
U+0783
blocked
|
| ޝ | U+079D THAANA LETTER SHEENU 3 401 |
|
ށ
U+0781
blocked
|
| ޞ | U+079E THAANA LETTER SAADHU 3 401 |
|
ސ
U+0790
blocked
ޟ
U+079F
blocked
|
| ޟ | U+079F THAANA LETTER DAADHU 3 401 |
|
ސ
U+0790
blocked
ޞ
U+079E
blocked
|
| ޠ | U+07A0 THAANA LETTER TO 3 401 |
|
ތ
U+078C
blocked
ޘ
U+0798
blocked
ޡ
U+07A1
blocked
|
| ޡ | U+07A1 THAANA LETTER ZO 3 401 |
|
ތ
U+078C
blocked
ޘ
U+0798
blocked
ޠ
U+07A0
blocked
|
| ޢ | U+07A2 THAANA LETTER AINU 3 401 |
|
އ
U+0787
blocked
ޣ
U+07A3
blocked
|
| ޣ | U+07A3 THAANA LETTER GHAINU 3 401 |
|
އ
U+0787
blocked
ޢ
U+07A2
blocked
|
| ޤ | U+07A4 THAANA LETTER QAAFU 3 401 |
|
ގ
U+078E
blocked
|
| ޥ | U+07A5 THAANA LETTER WAAVU 3 401 |
|
ވ
U+0788
blocked
|
| ަ | U+07A6 THAANA ABAFILI 3 401 |
|
|
| ާ | U+07A7 THAANA AABAAFILI 3 401 |
|
|
| ި | U+07A8 THAANA IBIFILI 3 401 |
|
|
| ީ | U+07A9 THAANA EEBEEFILI 3 401 |
|
|
| ު | U+07AA THAANA UBUFILI 3 401 |
|
|
| ޫ | U+07AB THAANA OOBOOFILI 3 401 |
|
|
| ެ | U+07AC THAANA EBEFILI 3 401 |
|
|
| ޭ | U+07AD THAANA EYBEYFILI 3 401 |
|
|
| ޮ | U+07AE THAANA OBOFILI 3 401 |
|
|
| ޯ | U+07AF THAANA OABOAFILI 3 401 |
|
|
| ް | U+07B0 THAANA SUKUN 3 401 |
|
|
| ޱ | U+07B1 THAANA LETTER NAA 5 401 |
|
ނ
U+0782
blocked
|
| ० | U+0966 DEVANAGARI DIGIT ZERO Not part of repertoire (injected) | variant target only |
0
U+0030
blocked
(injected)
٠
U+0660
blocked
(injected)
۰
U+06F0
blocked
(injected)
০
U+09E6
blocked
(injected)
૦
U+0AE6
blocked
(injected)
೦
U+0CE6
blocked
(injected)
+4 more
|
| १ | U+0967 DEVANAGARI DIGIT ONE Not part of repertoire (injected) | variant target only |
1
U+0031
blocked
(injected)
١
U+0661
blocked
(injected)
۱
U+06F1
blocked
(injected)
১
U+09E7
blocked
(injected)
૧
U+0AE7
blocked
(injected)
೧
U+0CE7
blocked
(injected)
+4 more
|
| २ | U+0968 DEVANAGARI DIGIT TWO Not part of repertoire (injected) | variant target only |
2
U+0032
blocked
(injected)
٢
U+0662
blocked
(injected)
۲
U+06F2
blocked
(injected)
২
U+09E8
blocked
(injected)
ર
U+0AB0
blocked
(injected)
૨
U+0AE8
blocked
(injected)
+5 more
|
| ३ | U+0969 DEVANAGARI DIGIT THREE Not part of repertoire (injected) | variant target only |
3
U+0033
blocked
(injected)
٣
U+0663
blocked
(injected)
۳
U+06F3
blocked
(injected)
৩
U+09E9
blocked
(injected)
૩
U+0AE9
blocked
(injected)
೩
U+0CE9
blocked
(injected)
+4 more
|
| ४ | U+096A DEVANAGARI DIGIT FOUR Not part of repertoire (injected) | variant target only |
4
U+0034
blocked
(injected)
٤
U+0664
blocked
(injected)
۴
U+06F4
blocked
(injected)
৪
U+09EA
blocked
(injected)
૪
U+0AEA
blocked
(injected)
೪
U+0CEA
blocked
(injected)
+4 more
|
| ५ | U+096B DEVANAGARI DIGIT FIVE Not part of repertoire (injected) | variant target only |
5
U+0035
blocked
(injected)
٥
U+0665
blocked
(injected)
۵
U+06F5
blocked
(injected)
৫
U+09EB
blocked
(injected)
પ
U+0AAA
blocked
(injected)
૫
U+0AEB
blocked
(injected)
+5 more
|
| ६ | U+096C DEVANAGARI DIGIT SIX Not part of repertoire (injected) | variant target only |
6
U+0036
blocked
(injected)
٦
U+0666
blocked
(injected)
۶
U+06F6
blocked
(injected)
৬
U+09EC
blocked
(injected)
૬
U+0AEC
blocked
(injected)
೬
U+0CEC
blocked
(injected)
+4 more
|
| ७ | U+096D DEVANAGARI DIGIT SEVEN Not part of repertoire (injected) | variant target only |
7
U+0037
blocked
(injected)
٧
U+0667
blocked
(injected)
۷
U+06F7
blocked
(injected)
৭
U+09ED
blocked
(injected)
૭
U+0AED
blocked
(injected)
೭
U+0CED
blocked
(injected)
+4 more
|
| ८ | U+096E DEVANAGARI DIGIT EIGHT Not part of repertoire (injected) | variant target only |
8
U+0038
blocked
(injected)
٨
U+0668
blocked
(injected)
۸
U+06F8
blocked
(injected)
৮
U+09EE
blocked
(injected)
૮
U+0AEE
blocked
(injected)
೮
U+0CEE
blocked
(injected)
+4 more
|
| ९ | U+096F DEVANAGARI DIGIT NINE Not part of repertoire (injected) | variant target only |
9
U+0039
blocked
(injected)
٩
U+0669
blocked
(injected)
۹
U+06F9
blocked
(injected)
৯
U+09EF
blocked
(injected)
૯
U+0AEF
blocked
(injected)
೯
U+0CEF
blocked
(injected)
+4 more
|
| ০ | U+09E6 BENGALI DIGIT ZERO Not part of repertoire (injected) | variant target only |
0
U+0030
blocked
(injected)
٠
U+0660
blocked
(injected)
۰
U+06F0
blocked
(injected)
०
U+0966
blocked
(injected)
૦
U+0AE6
blocked
(injected)
೦
U+0CE6
blocked
(injected)
+4 more
|
| ১ | U+09E7 BENGALI DIGIT ONE Not part of repertoire (injected) | variant target only |
1
U+0031
blocked
(injected)
١
U+0661
blocked
(injected)
۱
U+06F1
blocked
(injected)
१
U+0967
blocked
(injected)
૧
U+0AE7
blocked
(injected)
೧
U+0CE7
blocked
(injected)
+4 more
|
| ২ | U+09E8 BENGALI DIGIT TWO Not part of repertoire (injected) | variant target only |
2
U+0032
blocked
(injected)
٢
U+0662
blocked
(injected)
۲
U+06F2
blocked
(injected)
२
U+0968
blocked
(injected)
ર
U+0AB0
blocked
(injected)
૨
U+0AE8
blocked
(injected)
+5 more
|
| ৩ | U+09E9 BENGALI DIGIT THREE Not part of repertoire (injected) | variant target only |
3
U+0033
blocked
(injected)
٣
U+0663
blocked
(injected)
۳
U+06F3
blocked
(injected)
३
U+0969
blocked
(injected)
૩
U+0AE9
blocked
(injected)
೩
U+0CE9
blocked
(injected)
+4 more
|
| ৪ | U+09EA BENGALI DIGIT FOUR Not part of repertoire (injected) | variant target only |
4
U+0034
blocked
(injected)
٤
U+0664
blocked
(injected)
۴
U+06F4
blocked
(injected)
४
U+096A
blocked
(injected)
૪
U+0AEA
blocked
(injected)
೪
U+0CEA
blocked
(injected)
+4 more
|
| ৫ | U+09EB BENGALI DIGIT FIVE Not part of repertoire (injected) | variant target only |
5
U+0035
blocked
(injected)
٥
U+0665
blocked
(injected)
۵
U+06F5
blocked
(injected)
५
U+096B
blocked
(injected)
પ
U+0AAA
blocked
(injected)
૫
U+0AEB
blocked
(injected)
+5 more
|
| ৬ | U+09EC BENGALI DIGIT SIX Not part of repertoire (injected) | variant target only |
6
U+0036
blocked
(injected)
٦
U+0666
blocked
(injected)
۶
U+06F6
blocked
(injected)
६
U+096C
blocked
(injected)
૬
U+0AEC
blocked
(injected)
೬
U+0CEC
blocked
(injected)
+4 more
|
| ৭ | U+09ED BENGALI DIGIT SEVEN Not part of repertoire (injected) | variant target only |
7
U+0037
blocked
(injected)
٧
U+0667
blocked
(injected)
۷
U+06F7
blocked
(injected)
७
U+096D
blocked
(injected)
૭
U+0AED
blocked
(injected)
೭
U+0CED
blocked
(injected)
+4 more
|
| ৮ | U+09EE BENGALI DIGIT EIGHT Not part of repertoire (injected) | variant target only |
8
U+0038
blocked
(injected)
٨
U+0668
blocked
(injected)
۸
U+06F8
blocked
(injected)
८
U+096E
blocked
(injected)
૮
U+0AEE
blocked
(injected)
೮
U+0CEE
blocked
(injected)
+4 more
|
| ৯ | U+09EF BENGALI DIGIT NINE Not part of repertoire (injected) | variant target only |
9
U+0039
blocked
(injected)
٩
U+0669
blocked
(injected)
۹
U+06F9
blocked
(injected)
९
U+096F
blocked
(injected)
૯
U+0AEF
blocked
(injected)
೯
U+0CEF
blocked
(injected)
+4 more
|
| પ | U+0AAA GUJARATI LETTER PA Not part of repertoire (injected) | variant target only |
5
U+0035
blocked
(injected)
٥
U+0665
blocked
(injected)
۵
U+06F5
blocked
(injected)
५
U+096B
blocked
(injected)
৫
U+09EB
blocked
(injected)
૫
U+0AEB
blocked
(injected)
+5 more
|
| ર | U+0AB0 GUJARATI LETTER RA Not part of repertoire (injected) | variant target only |
2
U+0032
blocked
(injected)
٢
U+0662
blocked
(injected)
۲
U+06F2
blocked
(injected)
२
U+0968
blocked
(injected)
২
U+09E8
blocked
(injected)
૨
U+0AE8
blocked
(injected)
+5 more
|
| ૦ | U+0AE6 GUJARATI DIGIT ZERO Not part of repertoire (injected) | variant target only |
0
U+0030
blocked
(injected)
٠
U+0660
blocked
(injected)
۰
U+06F0
blocked
(injected)
०
U+0966
blocked
(injected)
০
U+09E6
blocked
(injected)
೦
U+0CE6
blocked
(injected)
+4 more
|
| ૧ | U+0AE7 GUJARATI DIGIT ONE Not part of repertoire (injected) | variant target only |
1
U+0031
blocked
(injected)
١
U+0661
blocked
(injected)
۱
U+06F1
blocked
(injected)
१
U+0967
blocked
(injected)
১
U+09E7
blocked
(injected)
೧
U+0CE7
blocked
(injected)
+4 more
|
| ૨ | U+0AE8 GUJARATI DIGIT TWO Not part of repertoire (injected) | variant target only |
2
U+0032
blocked
(injected)
٢
U+0662
blocked
(injected)
۲
U+06F2
blocked
(injected)
२
U+0968
blocked
(injected)
২
U+09E8
blocked
(injected)
ર
U+0AB0
blocked
(injected)
+5 more
|
| ૩ | U+0AE9 GUJARATI DIGIT THREE Not part of repertoire (injected) | variant target only |
3
U+0033
blocked
(injected)
٣
U+0663
blocked
(injected)
۳
U+06F3
blocked
(injected)
३
U+0969
blocked
(injected)
৩
U+09E9
blocked
(injected)
೩
U+0CE9
blocked
(injected)
+4 more
|
| ૪ | U+0AEA GUJARATI DIGIT FOUR Not part of repertoire (injected) | variant target only |
4
U+0034
blocked
(injected)
٤
U+0664
blocked
(injected)
۴
U+06F4
blocked
(injected)
४
U+096A
blocked
(injected)
৪
U+09EA
blocked
(injected)
೪
U+0CEA
blocked
(injected)
+4 more
|
| ૫ | U+0AEB GUJARATI DIGIT FIVE Not part of repertoire (injected) | variant target only |
5
U+0035
blocked
(injected)
٥
U+0665
blocked
(injected)
۵
U+06F5
blocked
(injected)
५
U+096B
blocked
(injected)
৫
U+09EB
blocked
(injected)
પ
U+0AAA
blocked
(injected)
+5 more
|
| ૬ | U+0AEC GUJARATI DIGIT SIX Not part of repertoire (injected) | variant target only |
6
U+0036
blocked
(injected)
٦
U+0666
blocked
(injected)
۶
U+06F6
blocked
(injected)
६
U+096C
blocked
(injected)
৬
U+09EC
blocked
(injected)
೬
U+0CEC
blocked
(injected)
+4 more
|
| ૭ | U+0AED GUJARATI DIGIT SEVEN Not part of repertoire (injected) | variant target only |
7
U+0037
blocked
(injected)
٧
U+0667
blocked
(injected)
۷
U+06F7
blocked
(injected)
७
U+096D
blocked
(injected)
৭
U+09ED
blocked
(injected)
೭
U+0CED
blocked
(injected)
+4 more
|
| ૮ | U+0AEE GUJARATI DIGIT EIGHT Not part of repertoire (injected) | variant target only |
8
U+0038
blocked
(injected)
٨
U+0668
blocked
(injected)
۸
U+06F8
blocked
(injected)
८
U+096E
blocked
(injected)
৮
U+09EE
blocked
(injected)
೮
U+0CEE
blocked
(injected)
+4 more
|
| ૯ | U+0AEF GUJARATI DIGIT NINE Not part of repertoire (injected) | variant target only |
9
U+0039
blocked
(injected)
٩
U+0669
blocked
(injected)
۹
U+06F9
blocked
(injected)
९
U+096F
blocked
(injected)
৯
U+09EF
blocked
(injected)
೯
U+0CEF
blocked
(injected)
+4 more
|
| ೦ | U+0CE6 KANNADA DIGIT ZERO Not part of repertoire (injected) | variant target only |
0
U+0030
blocked
(injected)
٠
U+0660
blocked
(injected)
۰
U+06F0
blocked
(injected)
०
U+0966
blocked
(injected)
০
U+09E6
blocked
(injected)
૦
U+0AE6
blocked
(injected)
+4 more
|
| ೧ | U+0CE7 KANNADA DIGIT ONE Not part of repertoire (injected) | variant target only |
1
U+0031
blocked
(injected)
١
U+0661
blocked
(injected)
۱
U+06F1
blocked
(injected)
१
U+0967
blocked
(injected)
১
U+09E7
blocked
(injected)
૧
U+0AE7
blocked
(injected)
+4 more
|
| ೨ | U+0CE8 KANNADA DIGIT TWO Not part of repertoire (injected) | variant target only |
2
U+0032
blocked
(injected)
٢
U+0662
blocked
(injected)
۲
U+06F2
blocked
(injected)
२
U+0968
blocked
(injected)
২
U+09E8
blocked
(injected)
ર
U+0AB0
blocked
(injected)
+5 more
|
| ೩ | U+0CE9 KANNADA DIGIT THREE Not part of repertoire (injected) | variant target only |
3
U+0033
blocked
(injected)
٣
U+0663
blocked
(injected)
۳
U+06F3
blocked
(injected)
३
U+0969
blocked
(injected)
৩
U+09E9
blocked
(injected)
૩
U+0AE9
blocked
(injected)
+4 more
|
| ೪ | U+0CEA KANNADA DIGIT FOUR Not part of repertoire (injected) | variant target only |
4
U+0034
blocked
(injected)
٤
U+0664
blocked
(injected)
۴
U+06F4
blocked
(injected)
४
U+096A
blocked
(injected)
৪
U+09EA
blocked
(injected)
૪
U+0AEA
blocked
(injected)
+4 more
|
| ೫ | U+0CEB KANNADA DIGIT FIVE Not part of repertoire (injected) | variant target only |
5
U+0035
blocked
(injected)
٥
U+0665
blocked
(injected)
۵
U+06F5
blocked
(injected)
५
U+096B
blocked
(injected)
৫
U+09EB
blocked
(injected)
પ
U+0AAA
blocked
(injected)
+5 more
|
| ೬ | U+0CEC KANNADA DIGIT SIX Not part of repertoire (injected) | variant target only |
6
U+0036
blocked
(injected)
٦
U+0666
blocked
(injected)
۶
U+06F6
blocked
(injected)
६
U+096C
blocked
(injected)
৬
U+09EC
blocked
(injected)
૬
U+0AEC
blocked
(injected)
+4 more
|
| ೭ | U+0CED KANNADA DIGIT SEVEN Not part of repertoire (injected) | variant target only |
7
U+0037
blocked
(injected)
٧
U+0667
blocked
(injected)
۷
U+06F7
blocked
(injected)
७
U+096D
blocked
(injected)
৭
U+09ED
blocked
(injected)
૭
U+0AED
blocked
(injected)
+4 more
|
| ೮ | U+0CEE KANNADA DIGIT EIGHT Not part of repertoire (injected) | variant target only |
8
U+0038
blocked
(injected)
٨
U+0668
blocked
(injected)
۸
U+06F8
blocked
(injected)
८
U+096E
blocked
(injected)
৮
U+09EE
blocked
(injected)
૮
U+0AEE
blocked
(injected)
+4 more
|
| ೯ | U+0CEF KANNADA DIGIT NINE Not part of repertoire (injected) | variant target only |
9
U+0039
blocked
(injected)
٩
U+0669
blocked
(injected)
۹
U+06F9
blocked
(injected)
९
U+096F
blocked
(injected)
৯
U+09EF
blocked
(injected)
૯
U+0AEF
blocked
(injected)
+4 more
|
| ๐ | U+0E50 THAI DIGIT ZERO Not part of repertoire (injected) | variant target only |
0
U+0030
blocked
(injected)
٠
U+0660
blocked
(injected)
۰
U+06F0
blocked
(injected)
०
U+0966
blocked
(injected)
০
U+09E6
blocked
(injected)
૦
U+0AE6
blocked
(injected)
+4 more
|
| ๑ | U+0E51 THAI DIGIT ONE Not part of repertoire (injected) | variant target only |
1
U+0031
blocked
(injected)
١
U+0661
blocked
(injected)
۱
U+06F1
blocked
(injected)
१
U+0967
blocked
(injected)
১
U+09E7
blocked
(injected)
૧
U+0AE7
blocked
(injected)
+4 more
|
| ๒ | U+0E52 THAI DIGIT TWO Not part of repertoire (injected) | variant target only |
2
U+0032
blocked
(injected)
٢
U+0662
blocked
(injected)
۲
U+06F2
blocked
(injected)
२
U+0968
blocked
(injected)
২
U+09E8
blocked
(injected)
ર
U+0AB0
blocked
(injected)
+5 more
|
| ๓ | U+0E53 THAI DIGIT THREE Not part of repertoire (injected) | variant target only |
3
U+0033
blocked
(injected)
٣
U+0663
blocked
(injected)
۳
U+06F3
blocked
(injected)
३
U+0969
blocked
(injected)
৩
U+09E9
blocked
(injected)
૩
U+0AE9
blocked
(injected)
+4 more
|
| ๔ | U+0E54 THAI DIGIT FOUR Not part of repertoire (injected) | variant target only |
4
U+0034
blocked
(injected)
٤
U+0664
blocked
(injected)
۴
U+06F4
blocked
(injected)
४
U+096A
blocked
(injected)
৪
U+09EA
blocked
(injected)
૪
U+0AEA
blocked
(injected)
+4 more
|
| ๕ | U+0E55 THAI DIGIT FIVE Not part of repertoire (injected) | variant target only |
5
U+0035
blocked
(injected)
٥
U+0665
blocked
(injected)
۵
U+06F5
blocked
(injected)
५
U+096B
blocked
(injected)
৫
U+09EB
blocked
(injected)
પ
U+0AAA
blocked
(injected)
+5 more
|
| ๖ | U+0E56 THAI DIGIT SIX Not part of repertoire (injected) | variant target only |
6
U+0036
blocked
(injected)
٦
U+0666
blocked
(injected)
۶
U+06F6
blocked
(injected)
६
U+096C
blocked
(injected)
৬
U+09EC
blocked
(injected)
૬
U+0AEC
blocked
(injected)
+4 more
|
| ๗ | U+0E57 THAI DIGIT SEVEN Not part of repertoire (injected) | variant target only |
7
U+0037
blocked
(injected)
٧
U+0667
blocked
(injected)
۷
U+06F7
blocked
(injected)
७
U+096D
blocked
(injected)
৭
U+09ED
blocked
(injected)
૭
U+0AED
blocked
(injected)
+4 more
|
| ๘ | U+0E58 THAI DIGIT EIGHT Not part of repertoire (injected) | variant target only |
8
U+0038
blocked
(injected)
٨
U+0668
blocked
(injected)
۸
U+06F8
blocked
(injected)
८
U+096E
blocked
(injected)
৮
U+09EE
blocked
(injected)
૮
U+0AEE
blocked
(injected)
+4 more
|
| ๙ | U+0E59 THAI DIGIT NINE Not part of repertoire (injected) | variant target only |
9
U+0039
blocked
(injected)
٩
U+0669
blocked
(injected)
۹
U+06F9
blocked
(injected)
९
U+096F
blocked
(injected)
৯
U+09EF
blocked
(injected)
૯
U+0AEF
blocked
(injected)
+4 more
|
| ໐ | U+0ED0 LAO DIGIT ZERO Not part of repertoire (injected) | variant target only |
0
U+0030
blocked
(injected)
٠
U+0660
blocked
(injected)
۰
U+06F0
blocked
(injected)
०
U+0966
blocked
(injected)
০
U+09E6
blocked
(injected)
૦
U+0AE6
blocked
(injected)
+4 more
|
| ໑ | U+0ED1 LAO DIGIT ONE Not part of repertoire (injected) | variant target only |
1
U+0031
blocked
(injected)
١
U+0661
blocked
(injected)
۱
U+06F1
blocked
(injected)
१
U+0967
blocked
(injected)
১
U+09E7
blocked
(injected)
૧
U+0AE7
blocked
(injected)
+4 more
|
| ໒ | U+0ED2 LAO DIGIT TWO Not part of repertoire (injected) | variant target only |
2
U+0032
blocked
(injected)
٢
U+0662
blocked
(injected)
۲
U+06F2
blocked
(injected)
२
U+0968
blocked
(injected)
২
U+09E8
blocked
(injected)
ર
U+0AB0
blocked
(injected)
+5 more
|
| ໓ | U+0ED3 LAO DIGIT THREE Not part of repertoire (injected) | variant target only |
3
U+0033
blocked
(injected)
٣
U+0663
blocked
(injected)
۳
U+06F3
blocked
(injected)
३
U+0969
blocked
(injected)
৩
U+09E9
blocked
(injected)
૩
U+0AE9
blocked
(injected)
+4 more
|
| ໔ | U+0ED4 LAO DIGIT FOUR Not part of repertoire (injected) | variant target only |
4
U+0034
blocked
(injected)
٤
U+0664
blocked
(injected)
۴
U+06F4
blocked
(injected)
४
U+096A
blocked
(injected)
৪
U+09EA
blocked
(injected)
૪
U+0AEA
blocked
(injected)
+4 more
|
| ໕ | U+0ED5 LAO DIGIT FIVE Not part of repertoire (injected) | variant target only |
5
U+0035
blocked
(injected)
٥
U+0665
blocked
(injected)
۵
U+06F5
blocked
(injected)
५
U+096B
blocked
(injected)
৫
U+09EB
blocked
(injected)
પ
U+0AAA
blocked
(injected)
+5 more
|
| ໖ | U+0ED6 LAO DIGIT SIX Not part of repertoire (injected) | variant target only |
6
U+0036
blocked
(injected)
٦
U+0666
blocked
(injected)
۶
U+06F6
blocked
(injected)
६
U+096C
blocked
(injected)
৬
U+09EC
blocked
(injected)
૬
U+0AEC
blocked
(injected)
+4 more
|
| ໗ | U+0ED7 LAO DIGIT SEVEN Not part of repertoire (injected) | variant target only |
7
U+0037
blocked
(injected)
٧
U+0667
blocked
(injected)
۷
U+06F7
blocked
(injected)
७
U+096D
blocked
(injected)
৭
U+09ED
blocked
(injected)
૭
U+0AED
blocked
(injected)
+4 more
|
| ໘ | U+0ED8 LAO DIGIT EIGHT Not part of repertoire (injected) | variant target only |
8
U+0038
blocked
(injected)
٨
U+0668
blocked
(injected)
۸
U+06F8
blocked
(injected)
८
U+096E
blocked
(injected)
৮
U+09EE
blocked
(injected)
૮
U+0AEE
blocked
(injected)
+4 more
|
| ໙ | U+0ED9 LAO DIGIT NINE Not part of repertoire (injected) | variant target only |
9
U+0039
blocked
(injected)
٩
U+0669
blocked
(injected)
۹
U+06F9
blocked
(injected)
९
U+096F
blocked
(injected)
৯
U+09EF
blocked
(injected)
૯
U+0AEF
blocked
(injected)
+4 more
|
| ၀ | U+1040 MYANMAR DIGIT ZERO Not part of repertoire (injected) | variant target only |
0
U+0030
blocked
(injected)
٠
U+0660
blocked
(injected)
۰
U+06F0
blocked
(injected)
०
U+0966
blocked
(injected)
০
U+09E6
blocked
(injected)
૦
U+0AE6
blocked
(injected)
+4 more
|
| ၁ | U+1041 MYANMAR DIGIT ONE Not part of repertoire (injected) | variant target only |
1
U+0031
blocked
(injected)
١
U+0661
blocked
(injected)
۱
U+06F1
blocked
(injected)
१
U+0967
blocked
(injected)
১
U+09E7
blocked
(injected)
૧
U+0AE7
blocked
(injected)
+4 more
|
| ၂ | U+1042 MYANMAR DIGIT TWO Not part of repertoire (injected) | variant target only |
2
U+0032
blocked
(injected)
٢
U+0662
blocked
(injected)
۲
U+06F2
blocked
(injected)
२
U+0968
blocked
(injected)
২
U+09E8
blocked
(injected)
ર
U+0AB0
blocked
(injected)
+5 more
|
| ၃ | U+1043 MYANMAR DIGIT THREE Not part of repertoire (injected) | variant target only |
3
U+0033
blocked
(injected)
٣
U+0663
blocked
(injected)
۳
U+06F3
blocked
(injected)
३
U+0969
blocked
(injected)
৩
U+09E9
blocked
(injected)
૩
U+0AE9
blocked
(injected)
+4 more
|
| ၄ | U+1044 MYANMAR DIGIT FOUR Not part of repertoire (injected) | variant target only |
4
U+0034
blocked
(injected)
٤
U+0664
blocked
(injected)
۴
U+06F4
blocked
(injected)
४
U+096A
blocked
(injected)
৪
U+09EA
blocked
(injected)
૪
U+0AEA
blocked
(injected)
+4 more
|
| ၅ | U+1045 MYANMAR DIGIT FIVE Not part of repertoire (injected) | variant target only |
5
U+0035
blocked
(injected)
٥
U+0665
blocked
(injected)
۵
U+06F5
blocked
(injected)
५
U+096B
blocked
(injected)
৫
U+09EB
blocked
(injected)
પ
U+0AAA
blocked
(injected)
+5 more
|
| ၆ | U+1046 MYANMAR DIGIT SIX Not part of repertoire (injected) | variant target only |
6
U+0036
blocked
(injected)
٦
U+0666
blocked
(injected)
۶
U+06F6
blocked
(injected)
६
U+096C
blocked
(injected)
৬
U+09EC
blocked
(injected)
૬
U+0AEC
blocked
(injected)
+4 more
|
| ၇ | U+1047 MYANMAR DIGIT SEVEN Not part of repertoire (injected) | variant target only |
7
U+0037
blocked
(injected)
٧
U+0667
blocked
(injected)
۷
U+06F7
blocked
(injected)
७
U+096D
blocked
(injected)
৭
U+09ED
blocked
(injected)
૭
U+0AED
blocked
(injected)
+4 more
|
| ၈ | U+1048 MYANMAR DIGIT EIGHT Not part of repertoire (injected) | variant target only |
8
U+0038
blocked
(injected)
٨
U+0668
blocked
(injected)
۸
U+06F8
blocked
(injected)
८
U+096E
blocked
(injected)
৮
U+09EE
blocked
(injected)
૮
U+0AEE
blocked
(injected)
+4 more
|
| ၉ | U+1049 MYANMAR DIGIT NINE Not part of repertoire (injected) | variant target only |
9
U+0039
blocked
(injected)
٩
U+0669
blocked
(injected)
۹
U+06F9
blocked
(injected)
९
U+096F
blocked
(injected)
৯
U+09EF
blocked
(injected)
૯
U+0AEF
blocked
(injected)
+4 more
|
| ០ | U+17E0 KHMER DIGIT ZERO Not part of repertoire (injected) | variant target only |
0
U+0030
blocked
(injected)
٠
U+0660
blocked
(injected)
۰
U+06F0
blocked
(injected)
०
U+0966
blocked
(injected)
০
U+09E6
blocked
(injected)
૦
U+0AE6
blocked
(injected)
+4 more
|
| ១ | U+17E1 KHMER DIGIT ONE Not part of repertoire (injected) | variant target only |
1
U+0031
blocked
(injected)
١
U+0661
blocked
(injected)
۱
U+06F1
blocked
(injected)
१
U+0967
blocked
(injected)
১
U+09E7
blocked
(injected)
૧
U+0AE7
blocked
(injected)
+4 more
|
| ២ | U+17E2 KHMER DIGIT TWO Not part of repertoire (injected) | variant target only |
2
U+0032
blocked
(injected)
٢
U+0662
blocked
(injected)
۲
U+06F2
blocked
(injected)
२
U+0968
blocked
(injected)
২
U+09E8
blocked
(injected)
ર
U+0AB0
blocked
(injected)
+5 more
|
| ៣ | U+17E3 KHMER DIGIT THREE Not part of repertoire (injected) | variant target only |
3
U+0033
blocked
(injected)
٣
U+0663
blocked
(injected)
۳
U+06F3
blocked
(injected)
३
U+0969
blocked
(injected)
৩
U+09E9
blocked
(injected)
૩
U+0AE9
blocked
(injected)
+4 more
|
| ៤ | U+17E4 KHMER DIGIT FOUR Not part of repertoire (injected) | variant target only |
4
U+0034
blocked
(injected)
٤
U+0664
blocked
(injected)
۴
U+06F4
blocked
(injected)
४
U+096A
blocked
(injected)
৪
U+09EA
blocked
(injected)
૪
U+0AEA
blocked
(injected)
+4 more
|
| ៥ | U+17E5 KHMER DIGIT FIVE Not part of repertoire (injected) | variant target only |
5
U+0035
blocked
(injected)
٥
U+0665
blocked
(injected)
۵
U+06F5
blocked
(injected)
५
U+096B
blocked
(injected)
৫
U+09EB
blocked
(injected)
પ
U+0AAA
blocked
(injected)
+5 more
|
| ៦ | U+17E6 KHMER DIGIT SIX Not part of repertoire (injected) | variant target only |
6
U+0036
blocked
(injected)
٦
U+0666
blocked
(injected)
۶
U+06F6
blocked
(injected)
६
U+096C
blocked
(injected)
৬
U+09EC
blocked
(injected)
૬
U+0AEC
blocked
(injected)
+4 more
|
| ៧ | U+17E7 KHMER DIGIT SEVEN Not part of repertoire (injected) | variant target only |
7
U+0037
blocked
(injected)
٧
U+0667
blocked
(injected)
۷
U+06F7
blocked
(injected)
७
U+096D
blocked
(injected)
৭
U+09ED
blocked
(injected)
૭
U+0AED
blocked
(injected)
+4 more
|
| ៨ | U+17E8 KHMER DIGIT EIGHT Not part of repertoire (injected) | variant target only |
8
U+0038
blocked
(injected)
٨
U+0668
blocked
(injected)
۸
U+06F8
blocked
(injected)
८
U+096E
blocked
(injected)
৮
U+09EE
blocked
(injected)
૮
U+0AEE
blocked
(injected)
+4 more
|
| ៩ | U+17E9 KHMER DIGIT NINE Not part of repertoire (injected) | variant target only |
9
U+0039
blocked
(injected)
٩
U+0669
blocked
(injected)
۹
U+06F9
blocked
(injected)
९
U+096F
blocked
(injected)
৯
U+09EF
blocked
(injected)
૯
U+0AEF
blocked
(injected)
+4 more
|
Variants
Code points grouped into sets of mutual variants. Every member of a set produces the same set of variant labels, so a registration of one has implications for all the others. Sets of a single member are omitted, as are the identity mappings RFC 7940 requires each member to declare.
-
2٢۲२২ર૨೨๒໒၂២
Source Direction Target Disposition Ref Comment 2 U+0032 ↔ ٢ U+0662 blocked (injected) 2 U+0032 ↔ ۲ U+06F2 blocked (injected) 2 U+0032 ↔ २ U+0968 blocked (injected) 2 U+0032 ↔ ২ U+09E8 blocked (injected) 2 U+0032 ↔ ર U+0AB0 blocked (injected) 2 U+0032 ↔ ૨ U+0AE8 blocked (injected) 2 U+0032 ↔ ೨ U+0CE8 blocked (injected) 2 U+0032 ↔ ๒ U+0E52 blocked (injected) 2 U+0032 ↔ ໒ U+0ED2 blocked (injected) 2 U+0032 ↔ ၂ U+1042 blocked (injected) 2 U+0032 ↔ ២ U+17E2 blocked (injected) ٢ U+0662 ↔ ۲ U+06F2 blocked (injected) ↔ declared both ways ⇆ both ways, different disposition each way → one direction only
-
5٥۵५৫પ૫೫๕໕၅៥
Source Direction Target Disposition Ref Comment 5 U+0035 ↔ ٥ U+0665 blocked (injected) 5 U+0035 ↔ ۵ U+06F5 blocked (injected) 5 U+0035 ↔ ५ U+096B blocked (injected) 5 U+0035 ↔ ৫ U+09EB blocked (injected) 5 U+0035 ↔ પ U+0AAA blocked (injected) 5 U+0035 ↔ ૫ U+0AEB blocked (injected) 5 U+0035 ↔ ೫ U+0CEB blocked (injected) 5 U+0035 ↔ ๕ U+0E55 blocked (injected) 5 U+0035 ↔ ໕ U+0ED5 blocked (injected) 5 U+0035 ↔ ၅ U+1045 blocked (injected) 5 U+0035 ↔ ៥ U+17E5 blocked (injected) ٥ U+0665 ↔ ۵ U+06F5 blocked (injected) ↔ declared both ways ⇆ both ways, different disposition each way → one direction only
-
0٠۰०০૦೦๐໐၀០
Source Direction Target Disposition Ref Comment 0 U+0030 ↔ ٠ U+0660 blocked (injected) 0 U+0030 ↔ ۰ U+06F0 blocked (injected) 0 U+0030 ↔ ० U+0966 blocked (injected) 0 U+0030 ↔ ০ U+09E6 blocked (injected) 0 U+0030 ↔ ૦ U+0AE6 blocked (injected) 0 U+0030 ↔ ೦ U+0CE6 blocked (injected) 0 U+0030 ↔ ๐ U+0E50 blocked (injected) 0 U+0030 ↔ ໐ U+0ED0 blocked (injected) 0 U+0030 ↔ ၀ U+1040 blocked (injected) 0 U+0030 ↔ ០ U+17E0 blocked (injected) ٠ U+0660 ↔ ۰ U+06F0 blocked (injected) ٠ U+0660 ↔ ० U+0966 blocked (injected) ↔ declared both ways ⇆ both ways, different disposition each way → one direction only
-
1١۱१১૧೧๑໑၁១
Source Direction Target Disposition Ref Comment 1 U+0031 ↔ ١ U+0661 blocked (injected) 1 U+0031 ↔ ۱ U+06F1 blocked (injected) 1 U+0031 ↔ १ U+0967 blocked (injected) 1 U+0031 ↔ ১ U+09E7 blocked (injected) 1 U+0031 ↔ ૧ U+0AE7 blocked (injected) 1 U+0031 ↔ ೧ U+0CE7 blocked (injected) 1 U+0031 ↔ ๑ U+0E51 blocked (injected) 1 U+0031 ↔ ໑ U+0ED1 blocked (injected) 1 U+0031 ↔ ၁ U+1041 blocked (injected) 1 U+0031 ↔ ១ U+17E1 blocked (injected) ١ U+0661 ↔ ۱ U+06F1 blocked (injected) ١ U+0661 ↔ १ U+0967 blocked (injected) ↔ declared both ways ⇆ both ways, different disposition each way → one direction only
-
3٣۳३৩૩೩๓໓၃៣
Source Direction Target Disposition Ref Comment 3 U+0033 ↔ ٣ U+0663 blocked (injected) 3 U+0033 ↔ ۳ U+06F3 blocked (injected) 3 U+0033 ↔ ३ U+0969 blocked (injected) 3 U+0033 ↔ ৩ U+09E9 blocked (injected) 3 U+0033 ↔ ૩ U+0AE9 blocked (injected) 3 U+0033 ↔ ೩ U+0CE9 blocked (injected) 3 U+0033 ↔ ๓ U+0E53 blocked (injected) 3 U+0033 ↔ ໓ U+0ED3 blocked (injected) 3 U+0033 ↔ ၃ U+1043 blocked (injected) 3 U+0033 ↔ ៣ U+17E3 blocked (injected) ٣ U+0663 ↔ ۳ U+06F3 blocked (injected) ٣ U+0663 ↔ ३ U+0969 blocked (injected) ↔ declared both ways ⇆ both ways, different disposition each way → one direction only
-
4٤۴४৪૪೪๔໔၄៤
Source Direction Target Disposition Ref Comment 4 U+0034 ↔ ٤ U+0664 blocked (injected) 4 U+0034 ↔ ۴ U+06F4 blocked (injected) 4 U+0034 ↔ ४ U+096A blocked (injected) 4 U+0034 ↔ ৪ U+09EA blocked (injected) 4 U+0034 ↔ ૪ U+0AEA blocked (injected) 4 U+0034 ↔ ೪ U+0CEA blocked (injected) 4 U+0034 ↔ ๔ U+0E54 blocked (injected) 4 U+0034 ↔ ໔ U+0ED4 blocked (injected) 4 U+0034 ↔ ၄ U+1044 blocked (injected) 4 U+0034 ↔ ៤ U+17E4 blocked (injected) ٤ U+0664 ↔ ۴ U+06F4 blocked (injected) ٤ U+0664 ↔ ४ U+096A blocked (injected) ↔ declared both ways ⇆ both ways, different disposition each way → one direction only
-
6٦۶६৬૬೬๖໖၆៦
Source Direction Target Disposition Ref Comment 6 U+0036 ↔ ٦ U+0666 blocked (injected) 6 U+0036 ↔ ۶ U+06F6 blocked (injected) 6 U+0036 ↔ ६ U+096C blocked (injected) 6 U+0036 ↔ ৬ U+09EC blocked (injected) 6 U+0036 ↔ ૬ U+0AEC blocked (injected) 6 U+0036 ↔ ೬ U+0CEC blocked (injected) 6 U+0036 ↔ ๖ U+0E56 blocked (injected) 6 U+0036 ↔ ໖ U+0ED6 blocked (injected) 6 U+0036 ↔ ၆ U+1046 blocked (injected) 6 U+0036 ↔ ៦ U+17E6 blocked (injected) ٦ U+0666 ↔ ۶ U+06F6 blocked (injected) ٦ U+0666 ↔ ६ U+096C blocked (injected) ↔ declared both ways ⇆ both ways, different disposition each way → one direction only
-
7٧۷७৭૭೭๗໗၇៧
Source Direction Target Disposition Ref Comment 7 U+0037 ↔ ٧ U+0667 blocked (injected) 7 U+0037 ↔ ۷ U+06F7 blocked (injected) 7 U+0037 ↔ ७ U+096D blocked (injected) 7 U+0037 ↔ ৭ U+09ED blocked (injected) 7 U+0037 ↔ ૭ U+0AED blocked (injected) 7 U+0037 ↔ ೭ U+0CED blocked (injected) 7 U+0037 ↔ ๗ U+0E57 blocked (injected) 7 U+0037 ↔ ໗ U+0ED7 blocked (injected) 7 U+0037 ↔ ၇ U+1047 blocked (injected) 7 U+0037 ↔ ៧ U+17E7 blocked (injected) ٧ U+0667 ↔ ۷ U+06F7 blocked (injected) ٧ U+0667 ↔ ७ U+096D blocked (injected) ↔ declared both ways ⇆ both ways, different disposition each way → one direction only
-
8٨۸८৮૮೮๘໘၈៨
Source Direction Target Disposition Ref Comment 8 U+0038 ↔ ٨ U+0668 blocked (injected) 8 U+0038 ↔ ۸ U+06F8 blocked (injected) 8 U+0038 ↔ ८ U+096E blocked (injected) 8 U+0038 ↔ ৮ U+09EE blocked (injected) 8 U+0038 ↔ ૮ U+0AEE blocked (injected) 8 U+0038 ↔ ೮ U+0CEE blocked (injected) 8 U+0038 ↔ ๘ U+0E58 blocked (injected) 8 U+0038 ↔ ໘ U+0ED8 blocked (injected) 8 U+0038 ↔ ၈ U+1048 blocked (injected) 8 U+0038 ↔ ៨ U+17E8 blocked (injected) ٨ U+0668 ↔ ۸ U+06F8 blocked (injected) ٨ U+0668 ↔ ८ U+096E blocked (injected) ↔ declared both ways ⇆ both ways, different disposition each way → one direction only
-
9٩۹९৯૯೯๙໙၉៩
Source Direction Target Disposition Ref Comment 9 U+0039 ↔ ٩ U+0669 blocked (injected) 9 U+0039 ↔ ۹ U+06F9 blocked (injected) 9 U+0039 ↔ ९ U+096F blocked (injected) 9 U+0039 ↔ ৯ U+09EF blocked (injected) 9 U+0039 ↔ ૯ U+0AEF blocked (injected) 9 U+0039 ↔ ೯ U+0CEF blocked (injected) 9 U+0039 ↔ ๙ U+0E59 blocked (injected) 9 U+0039 ↔ ໙ U+0ED9 blocked (injected) 9 U+0039 ↔ ၉ U+1049 blocked (injected) 9 U+0039 ↔ ៩ U+17E9 blocked (injected) ٩ U+0669 ↔ ۹ U+06F9 blocked (injected) ٩ U+0669 ↔ ९ U+096F blocked (injected) ↔ declared both ways ⇆ both ways, different disposition each way → one direction only
-
ތޘޠޡ
Source Direction Target Disposition Ref Comment ތ U+078C ↔ ޘ U+0798 blocked ތ U+078C ↔ ޠ U+07A0 blocked ތ U+078C ↔ ޡ U+07A1 blocked ޘ U+0798 ↔ ޠ U+07A0 blocked ޘ U+0798 ↔ ޡ U+07A1 blocked ޠ U+07A0 ↔ ޡ U+07A1 blocked ↔ declared both ways ⇆ both ways, different disposition each way → one direction only
Character classes
Named sets of code points that the rules below refer to.
| Name | Definition |
|---|---|
Common-digits |
{tag Common-digit}
Digits from the ASCII range MSR default
|
N |
[0782-0783]
Thaana NoonNu and Thana Raa
|
C |
({tag consonant} ∖ {N})
Any Thaana consonant other than NoonNu or Raa
|
V |
{tag vowel}
Any Thaana vowel
|
Rules
Conditions evaluated against a whole label, or against the context around a
single code point. The notation borrows from regular expressions:
^ and $ anchor to the start and end of a label,
. matches any code point, (?= ) and
(?<= ) look ahead and behind, and * and
+ repeat. Two symbols are specific to rulesets:
◆ is the code point being tested, and
⟨name⟩ refers to another rule.
hyphen-minus-disallowed MSR default
RFC 5891 restrictions on placement of U+002D HYPHEN-MINUS
( ( (?<= ^ ) ◆ ) │ ( ◆ (?= $ ) ) │ ( (?<= ^ . . U+002D ) ◆ ) )
Structure
-
( ( (?<= ^ ) ◆ ) │ ( ◆ (?= $ ) ) │ ( (?<= ^ . . U+002D ) ◆ ) )choice-
(?<= ^ ) ◆rule-
(?<= ^ )look-behind-
^start
-
-
◆anchor
-
-
◆ (?= $ )rule-
◆anchor -
(?= $ )look-ahead-
$end
-
-
-
(?<= ^ . . U+002D ) ◆rule-
(?<= ^ . . U+002D )look-behind-
^start -
.any -
.any -
U+002Dchar
-
-
◆anchor
-
-
Referenced by 1 definition
- negative context of U+002D
leading-combining-mark MSR default 150
RFC 5891 restrictions on placement of combining marks
^ {gc:Mn} {gc:Mc}
Referenced by 1 definition
- action 1 (invalid)
leading-digit MSR default 160
RFC 5893 RTL labels cannot start with a digit
(?<= ^ ) ◆
Structure
-
(?<= ^ )look-behind-
^start
-
-
◆anchor
Referenced by 10 definitions
- negative context of U+0030
- negative context of U+0031
- negative context of U+0032
- negative context of U+0033
- negative context of U+0034
- negative context of U+0035
- negative context of U+0036
- negative context of U+0037
- negative context of U+0038
- negative context of U+0039
start-of-word
A context describing the start of a word, used in the formuation of WLE 3
( ^ │ U+002D │ {Common-digits} )
Structure
-
( ^ │ U+002D │ {Common-digits} )choice-
^start -
U+002Dchar -
{Common-digits}class
-
Referenced by 1 definition
- rule start-of-word-followed-by-C
start-of-word-followed-by-C
WLE 3: N followed by C cannot start a word, that is, it cannot be the start of a label, or follow a hyphen or digit.
(?<= ⟨start-of-word⟩ ) ◆ (?= {C} )
Structure
-
(?<= ⟨start-of-word⟩ )look-behind-
⟨start-of-word⟩rule
-
-
◆anchor -
(?= {C} )look-ahead-
{C}class
-
Referenced by 1 definition
- rule disallowed-for-N
followed-by-NC-or-NN
WLE 4: N cannot be followed by NC or NN
◆ (?= {N} ( {C} │ {N} ) )
Structure
-
◆anchor -
(?= {N} ( {C} │ {N} ) )look-ahead-
{N}class -
( {C} │ {N} )choice-
{C}class -
{N}class
-
-
Referenced by 1 definition
- rule disallowed-for-N
disallowed-for-N
Prohibited context for N, combines WLE 3 and WLE 4
( ⟨start-of-word-followed-by-C⟩ │ ⟨followed-by-NC-or-NN⟩ )
Structure
-
( ⟨start-of-word-followed-by-C⟩ │ ⟨followed-by-NC-or-NN⟩ )choice-
⟨start-of-word-followed-by-C⟩rule -
⟨followed-by-NC-or-NN⟩rule
-
Referenced by 2 definitions
- negative context of U+0782
- negative context of U+0783
follows-C-or-N
WLE1: a vowel always follows a consonant or Noonnu or Raa.
(?<= ( {C} │ {N} ) ) ◆
Structure
-
(?<= ( {C} │ {N} ) )look-behind-
( {C} │ {N} )choice-
{C}class -
{N}class
-
-
-
◆anchor
Referenced by 11 definitions
- context of U+07A6
- context of U+07A7
- context of U+07A8
- context of U+07A9
- context of U+07AA
- context of U+07AB
- context of U+07AC
- context of U+07AD
- context of U+07AE
- context of U+07AF
- context of U+07B0
followed-by-V
WLE2: a consonant is always follwed by a vowel.
◆ (?= {V} )
Structure
-
◆anchor -
(?= {V} )look-ahead-
{V}class
-
Referenced by 37 definitions
- context of U+0780
- context of U+0781
- context of U+0784
- context of U+0785
- context of U+0786
- context of U+0787
- context of U+0788
- context of U+0789
- context of U+078A
- context of U+078B
- context of U+078C
- context of U+078D
Common--surrounded-by-L MSR default
code point both follows and precedes L, required context for Ela Geminada (injected, but possibly optional)
(?<= U+006C ) ◆ (?= U+006C )
Structure
-
(?<= U+006C )look-behind-
U+006Cchar
-
-
◆anchor -
(?= U+006C )look-ahead-
U+006Cchar
-
Referenced by 2 definitions
- variant condition on U+002D
- variant condition on U+00B7
Actions
Actions are evaluated in the order shown. The first action whose conditions match determines the disposition of the label.
| # | Disposition | Conditions |
|---|---|---|
| 1 |
invalid
|
label matches leading-combining-mark RFC 5891 restrictions on placement of combining marks MSR default |
| 2 |
blocked
|
any variant is blocked any variant label containing blocked variants is blocked MSR default |
| 3 |
invalid
|
any variant is out-of-repertoire-var any variant label with a code point out of repertoire is invalid (injected) MSR default |
| 4 |
valid
|
any label default catch all; default action MSR default |
References
| Ref | Source |
|---|---|
| 0 | The Unicode Standard, Version 1.1 |
| 3 | The Unicode Standard, Version 3.0 |
| 5 | The Unicode Standard, Version 3.2 |
| 150 | RFC 5891, Internationalized Domain Names in Applications(IDNA): Protocol https://tools.ietf.org/html/rfc5891 |
| 160 | RFC 5893, Right - to - Left Scripts for Internationalized Domain Names for Applications (IDNA) https://tools.ietf.org/html/rfc5893 |
| 401 | Dhivehi Writing Systems by Naseema Mohamed, page 7-8, NCLHR, 1999. |